#opnfv-meeting: OPNFV Brahmaputra release planning meeting

Meeting started by ChrisPriceAB at 15:02:45 UTC (full logs).

Meeting summary

    1. Jonas Bjurel (Fuel) ([1]JonasB, 15:02:57)
    2. Bryan Sullivan (bryan_att, 15:03:01)
    3. Ana Cunha (Yardstick) (anac1, 15:03:05)
    4. Fatih Degirmenci (Releng) (fdegir, 15:03:19)
    5. Chris Price (ChrisPriceAB, 15:03:26)
    6. Ashlee Young (ONOSFW) (ashyoung, 15:03:26)
    7. Uli (uli-k, 15:03:28)
    8. billyoma (VSPERF) (billyoma, 15:03:37)
    9. Bin Hu (bin_, 15:03:38)
    10. Ryota Mibu (Doctor) (r-mibu, 15:03:52)
    11. OPNFV Release IRC Channel == (#opnfv-release) to be used for daily release discussions (ChrisPriceAB, 15:04:01)

  1. Brahmaputra schedule overview (ChrisPriceAB, 15:04:21)
    1. https://wiki.opnfv.org/releases/brahmaputra/release_plan Brahmaputra release plan (ChrisPriceAB, 15:05:07)
    2. we are finding a new goto bridge with more places (ChrisPriceAB, 15:07:23)
    3. Daniel Smith (lmcdasm, 15:08:13)
    4. Tim Rozet (trozet, 15:08:18)
    5. Heather Kirksey (HKirksey, 15:08:27)
    6. Jie Hu (hujie, 15:08:28)
    7. Brian Castelli (spirentbrian, 15:08:31)
    8. please use the TSC goto bridge: https://global.gotomeeting.com/join/798898261 (ChrisPriceAB, 15:08:34)
    9. hongbo tian (hongbotian, 15:08:37)
    10. Milestone C is due on the 25th of September, requiring each project ot have their plans in Jira (ChrisPriceAB, 15:11:13)
    11. By milestone C we should have our sprints planned, the timing and scope of the sprints and epic/stories to be addressed. (ChrisPriceAB, 15:12:01)
    12. Rex Lee (rex_lee, 15:12:16)
    13. Debra reminds us that we will be running a time-boxed release and will cut scope rather than move the dates. (ChrisPriceAB, 15:12:21)
    14. this leads to the project being strict on reaching milestones. (ChrisPriceAB, 15:12:41)
    15. Jonas raises the topic of inter-project dependancies and the importance of having those clear by milestone C (ChrisPriceAB, 15:13:38)
    16. https://etherpad.opnfv.org/p/artifact_handling ([1]JonasB, 15:14:03)
    17. Debra outlines that both the incoming and outgoing dependancies need to be addressed as part of the planning phase. (ChrisPriceAB, 15:15:44)

  2. status reports (ChrisPriceAB, 15:15:55)
    1. Debra asks that projects participating provide status reports (ChrisPriceAB, 15:16:10)
    2. Debra would like to have each project # info in their status during these meetings. However it would be difficult to address all issues in real time on the calls. (ChrisPriceAB, 15:16:42)
    3. Debra outlines that having status reporting via the web by Fridays, where these can be checked, will give everyone a chance to review those prior to the project meetings. (ChrisPriceAB, 15:17:25)
    4. Ray outlines that using Jira for up to date information will allow collaboration across timezones. (ChrisPriceAB, 15:18:30)
    5. Billy provides the suggestion that we maintain a single brahmaputra release page to keep track of all project information. (ChrisPriceAB, 15:19:10)
    6. https://wiki.opnfv.org/_media/wiki/opnfv_escalator_questionnaire_20150723.pptx (hujie, 15:20:09)
    7. https://docs.google.com/forms/d/11o1mt15zcq0WBtXYK0n6lKF8XuIzQTwvv8ePTjmcoF0/viewform?usp=send_form (hujie, 15:20:38)
    8. ONOSFW status https://wiki.opnfv.org/collaborative_development_projects/onosfw (ashyoung, 15:20:52)
    9. https://global.gotomeeting.com/join/798898261 (ChrisPriceAB, 15:22:18)
    10. ACTION: fdegir and debra and others to craft a proposal on how we might achieve tracking and logging to present to the community (ChrisPriceAB, 15:24:28)

  3. concerns and questions form the community (ChrisPriceAB, 15:25:24)
    1. ashyoung voices some concerns around infrastructure tools. ashyoung is having trouble getting code reviews done. (ChrisPriceAB, 15:26:19)
    2. ashyoung also has concerns on getting developer resources to have hands on access to LF resources. (ChrisPriceAB, 15:26:50)
    3. fatih comments that we lack resources for CI and releng. Accessing LF resources is not a solution, an the hope if that Pharos can help facilitate community resource scaling. (ChrisPriceAB, 15:30:15)
    4. people start beating the pharos team (virtually), we need more pharos resources to help beat back... (ChrisPriceAB, 15:30:47)
    5. Manuel R (MR_Sandvine, 15:30:58)
    6. Peter Lee (corenova, 15:31:15)
    7. dneary ask if there is a brahmaputra scope available (ChrisPriceAB, 15:32:02)
    8. Debra responds that this should be complete at Milestone C (ChrisPriceAB, 15:32:14)
    9. Debra clarifies that after milestone C, no projects will be able to join the Brahmaputra release (ChrisPriceAB, 15:35:35)
    10. it is made clear that infrastructure projects need to have requirements on them clear by milestone C. (ChrisPriceAB, 15:40:11)

  4. project roll call (ChrisPriceAB, 15:40:15)
    1. Apex (trozet, 15:40:23)
    2. Chris Price opnfvdocs (ChrisPriceAB, 15:40:25)
    3. Uli Octopus (uli-k, 15:40:32)
    4. VSPERF (billyoma for Maryam Tahhan) (billyoma, 15:40:39)
    5. pharos (trevor_intel, 15:40:40)
    6. Ashlee Young ONOSFW (ashyoung, 15:40:42)
    7. Morgan Functest (morgan_orange, 15:40:43)
    8. Peter Promise (corenova, 15:40:52)
    9. IPv6 (bin_, 15:40:52)
    10. hongbo bottlenecks (hongbotian, 15:40:54)
    11. Jonas Bjurel (fuel) ([1]JonasB, 15:40:58)
    12. hujie Escalator (hujie, 15:41:01)
    13. Bryan copper (bryan_att, 15:41:07)
    14. Ryota Doctor (r-mibu, 15:41:08)
    15. Fatih Degirmenci Releng (fdegir, 15:41:11)
    16. Ana Cunha (Yardstick) (anac1, 15:41:18)
    17. Bin IPv6 (bin_, 15:41:28)

  5. Project dependancies (ChrisPriceAB, 15:42:16)
    1. Debra outlines the needs for projects to be very clear on their dependencies by milestone-C, or a pre-milestone checkpoint on dependancies. (ChrisPriceAB, 15:42:50)
    2. bryan_att states it would be helpful to project leads to know what types of requirements the infra and test teams need to know about. (ChrisPriceAB, 15:43:51)
    3. anac1 outlines the need to know what type of testing needs to be done for each project. What is the SUT and which project is best suited to work with the project. (ChrisPriceAB, 15:44:23)
    4. anac1 outlines that this is best done in Jira to make it clear what requirements are existing between projects. (ChrisPriceAB, 15:45:20)
    5. morgan_orange outlines the need to have a test plan ready by september is going to be very hard to achieve. (ChrisPriceAB, 15:46:36)
    6. Debra asks for clarification from the installer infra team on what is required. (ChrisPriceAB, 15:48:03)
    7. Jonas outlines that Genesis can respond next week as well on the needed requirements. They will need to know how artifacts will be packaged, package dependancies and versions, and sample manifests that will be delivered. (ChrisPriceAB, 15:48:52)
    8. https://etherpad.opnfv.org/p/artifact_handling detailed overview of the dependancies for installers (ChrisPriceAB, 15:50:42)


Meeting ended at 16:04:00 UTC (full logs).

Action items

  1. fdegir and debra and others to craft a proposal on how we might achieve tracking and logging to present to the community


Action items, by person

  1. fdegir
    1. fdegir and debra and others to craft a proposal on how we might achieve tracking and logging to present to the community


People present (lines said)

  1. ChrisPriceAB (64)
  2. fdegir (15)
  3. bryan_att (15)
  4. collabot (10)
  5. hujie (6)
  6. corenova (6)
  7. ashyoung (6)
  8. trozet (4)
  9. dneary (3)
  10. [1]JonasB (3)
  11. bin_ (3)
  12. HKirksey (3)
  13. hongbotian (3)
  14. n0ano (2)
  15. rex_lee (2)
  16. anac1 (2)
  17. VikramDham_ (2)
  18. r-mibu (2)
  19. uli-k (2)
  20. billyoma (2)
  21. lmcdasm (2)
  22. spirentbrian (1)
  23. RayNugent_ (1)
  24. morgan_orange (1)
  25. StuartMackie (1)
  26. trevor_intel (1)
  27. debrascott (1)
  28. MR_Sandvine (1)


Generated by MeetBot 0.1.4.