#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 15:00:46 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 15:00:50)
    1. Edgar StPierre (edgarstp, 15:00:56)
    2. Chris Price (ChrisPriceAB, 15:00:57)
    3. dlenrow (dlenrow, 15:01:08)
    4. Bryan Sullivan (bryan_att, 15:01:14)
    5. Frank Brockners (frankbrockners, 15:01:47)

  2. Previous minutes of meeting. (ChrisPriceAB, 15:04:06)
    1. Previous minutes if meeting approved, no comments. (ChrisPriceAB, 15:04:20)

  3. Agenda Bashing (ChrisPriceAB, 15:04:26)
    1. Ashiq Khan (Ashiq, 15:04:47)
    2. additional agenda topic: Genesis timelines (frankbrockners, 15:05:20)
    3. Parviz Yegani (Parviz, 15:05:48)

  4. Latest from the Design Summit & OPNFV Summit (ChrisPriceAB, 15:06:11)
    1. Uli Kleber (uli-k, 15:06:15)
    2. the design summit has been very effective and well attended. (ChrisPriceAB, 15:09:04)
    3. feedback thus far includes improvements in size of rooms, whiteboards, and video streaming could be improvements. (ChrisPriceAB, 15:09:53)
    4. also, video dongles for computers to plug into faster (ChrisPriceAB, 15:10:31)
    5. A reminder on a design summit wrap-up session at 4:30pm PT in Regency B-C (rpaik, 15:10:32)
    6. Chris Wright (cdub, 15:10:41)
    7. Ashiq adds that room reservations have been an issue, using etherpad, wiki, and/or sched has made it a little confusing. (ChrisPriceAB, 15:11:26)

  5. OPNFV Software License (ChrisPriceAB, 15:12:14)
    1. Wenjing Chu (Wenjing, 15:12:56)
    2. Scott, director of strategic programs for the linux foundation, introduces himself (ChrisPriceAB, 15:13:15)
    3. Dirk Kutscher (dku, 15:13:34)
    4. Scott would like to help with our process development to institute best practices heading into our Brahmaputra release. (ChrisPriceAB, 15:13:51)
    5. Scott mentions the licence file is a good practice and should continue (ChrisPriceAB, 15:14:31)
    6. The information around the contributor per file should also contain the license information as a best practice. (ChrisPriceAB, 15:15:10)
    7. https://wiki.opnfv.org/developer/contribution_guidelines coding guidelines including file header templates. (ChrisPriceAB, 15:16:02)
    8. dneary asks if this is a reccomendation, or a requirement. (ChrisPriceAB, 15:18:21)
    9. Scott answers this is a requirement for contribution. (ChrisPriceAB, 15:18:36)
    10. Tapio Tallgren (Tapio_T, 15:20:08)
    11. a question was raised on gif, jpeg, etc. (rpaik, 15:21:58)
    12. plus how do you handle binaries (rpaik, 15:23:34)
    13. ACTION: rpaik to set up a follow up discussion around binary files with Scott and Frank and other interested parties. (ChrisPriceAB, 15:23:51)
    14. Scott is also part of a working group in the LF that is looking to simplify the process of adding license information to files. This is due to be ready around March. (ChrisPriceAB, 15:26:52)
    15. byran_att asks if all patches are required to carry the copyright and license info of the contributor? (ChrisPriceAB, 15:29:29)
    16. The OPNFV team discuss the methods in place, where we track contributors in our GIT logs which do not require us to update the header for each patch. (ChrisPriceAB, 15:33:46)
    17. ACTION: The TSC shall invest some time working on clarifying the roles and expectations on contributors and the reviewing committers. (ChrisPriceAB, 15:36:09)

  6. Brahmaputra artifact governance and expectations (ChrisPriceAB, 15:37:51)
    1. dneary (joining IRC late, on phone earlier) (dneary, 15:40:24)
    2. http://producingoss.com/en/managing-volunteers.html#territoriality (dneary, 15:41:36)
    3. ACTION: frankbrockners and chrispriceab to put a concrete proposal together on release contents based on this discussion for review. (ChrisPriceAB, 15:58:13)
    4. dneary explicitly states that he wants brahmaputra to be based on at a minimum patches that are accepted upstream. (ChrisPriceAB, 15:58:44)
    5. frankbrockners explains this may not always be possible due to the large cross project dependencies in OPNFV. (ChrisPriceAB, 15:59:07)
    6. frankbrockners adds that the install teams are geting nervous about the amount of last minute work that might come up. Frinday 13th is the end-date for requesting work from the installer teams. (ChrisPriceAB, 16:01:19)
    7. ACTION: all PTL's makse sure your requirements are into the genesis requirements. (ChrisPriceAB, 16:01:36)


Meeting ended at 16:01:59 UTC (full logs).

Action items

  1. rpaik to set up a follow up discussion around binary files with Scott and Frank and other interested parties.
  2. The TSC shall invest some time working on clarifying the roles and expectations on contributors and the reviewing committers.
  3. frankbrockners and chrispriceab to put a concrete proposal together on release contents based on this discussion for review.
  4. all PTL's makse sure your requirements are into the genesis requirements.


Action items, by person

  1. ChrisPriceAB
    1. frankbrockners and chrispriceab to put a concrete proposal together on release contents based on this discussion for review.
  2. frankbrockners
    1. frankbrockners and chrispriceab to put a concrete proposal together on release contents based on this discussion for review.
  3. rpaik
    1. rpaik to set up a follow up discussion around binary files with Scott and Frank and other interested parties.
  4. UNASSIGNED
    1. The TSC shall invest some time working on clarifying the roles and expectations on contributors and the reviewing committers.
    2. all PTL's makse sure your requirements are into the genesis requirements.


People present (lines said)

  1. ChrisPriceAB (35)
  2. collabot (6)
  3. dneary (3)
  4. bryan_att (3)
  5. rpaik (3)
  6. frankbrockners (2)
  7. dku (1)
  8. dlenrow (1)
  9. cdub (1)
  10. Tapio_T (1)
  11. Parviz (1)
  12. edgarstp (1)
  13. Ashiq (1)
  14. uli-k (1)
  15. Wenjing (1)


Generated by MeetBot 0.1.4.