#opnfv-meeting: OPNFV TSC
Meeting started by ChrisPriceAB at 14:58:48 UTC
(full logs).
Meeting summary
- 
  - Uli Kleber (uli-k,
    14:58:58)
 
 
- roll call (ChrisPriceAB, 14:59:01)
  - Uli Kleber (uli-k,
    14:59:05)
- Gerald Kunzmann (DOCOMO) (GeraldK,
    14:59:07)
- Chris Price (ChrisPriceAB,
    14:59:13)
- Frank Brockners (frankbrockners,
    14:59:15)
- mlynch (Mike_Lynch,
    14:59:42)
- Edgar StPierre (edgarstp,
    15:00:52)
 
 
- approval of previous minutes of meeting (ChrisPriceAB, 15:01:15)
  - the minutes of two past have been approved due
    to no feedback. (ChrisPriceAB,
    15:01:49)
- Bryan Sullivan (bryan_att,
    15:01:50)
- Brian Skerry (bjskerry,
    15:02:05)
- previous minutes are also approved.
    (ChrisPriceAB,
    15:02:19)
- Morgan Richomme (morgan_orange,
    15:02:22)
- Dirk Kutscher (dku,
    15:02:32)
 
 
- Agenda Bashing (ChrisPriceAB, 15:02:33)
  - https://wiki.opnfv.org/wiki/tsc
    current agendsa (ChrisPriceAB,
    15:02:48)
- Vikram Dham (VikramDham,
    15:03:06)
- Tapio Tallgren (ttallgren,
    15:03:21)
- no further topics proposed (ChrisPriceAB,
    15:04:06)
 
 
- Milestone D update (ChrisPriceAB, 15:04:21)
  - Debra outlines the plan for projects passing
    milestone D of Brahmaputra (ChrisPriceAB,
    15:04:44)
- Debra will prepare list of questions to every
    project (GeraldK,
    15:04:52)
- Debra will create a page per project on the
    Brahmaputra Wiki area (GeraldK,
    15:05:52)
- Frank requests to have this list of questions
    in advance, preferrably by today (GeraldK,
    15:06:26)
 
 
- Project lifecycle discussions (ChrisPriceAB, 15:06:51)
  - The project proposal wiki is being updated to
    reflect the recent changes in bylaws (ChrisPriceAB,
    15:07:30)
- Ildiko asks rpaik when the www.opnfv.org pages
    will be updated (ChrisPriceAB,
    15:07:47)
- rpaik responds that the creative services team
    are working to update the web page (ChrisPriceAB,
    15:08:06)
- Parviz Yegani (Parviz,
    15:08:15)
- Ildikov has asked for community input into the
    activity on the mailing lists. (ChrisPriceAB,
    15:08:43)
- Discussion on Word vs rst (GeraldK,
    15:09:08)
- dlenrow (dlenrow,
    15:09:11)
- https://wiki.opnfv.org/project_proposals/template
    (frankbrockners,
    15:09:52)
- https://wiki.opnfv.org/project_proposals
    (ildikov,
    15:10:12)
- frankbrockers promotes simplicity and thinks
    the wiki is suitable given our current best parctices (ChrisPriceAB,
    15:10:53)
- Chris prefers rst and using our repositories,
    Frank proposes Wiki (with link from project page to project proposal
    page) (GeraldK,
    15:10:54)
- a motion is put to remove the word document
    sitting on the wiki (ChrisPriceAB,
    15:11:20)
- no (Julien-zte,
    15:11:39)
- AGREED: the TSC
    agrees to remove the word document and stick to the wiki proposal
    template (ChrisPriceAB,
    15:12:18)
 
 
- Project scope adjustments after the amended bylaws (ChrisPriceAB, 15:12:58)
  - question is on procedures around scope
    adjustment, e.g. reduce/increase project scope (GeraldK,
    15:14:21)
- Ray questions what is the project maturity gate
    when projects can change the scope frequently (GeraldK,
    15:15:21)
- dlenrow asks how active the TSC should be when
    project scope changes (rpaik,
    15:16:32)
- problem might occur when a project scope might
    affect another project or even the overall OPNFV scope. (GeraldK,
    15:17:14)
- Uli-K: there are several where the TSC would
    need to decide on updated project scope. we should encourage
    projects to seek guidance on the new scope. (GeraldK,
    15:19:46)
- Chris: if the project wants to change scope,
    they could just come to TSC to ask for approval. (GeraldK,
    15:20:36)
- Is there an example of a scope problem in OPNFV
    currently that we could use to test proposed solutions to this
    (possible non) problem? (dlenrow,
    15:20:44)
- Debra raises the question about the size of
    scope changes; would scope changes really affect the project that
    much? (GeraldK,
    15:21:27)
- Frank: what is the purpose of this discussion:
    does TSC simply wants to know about the change? (GeraldK,
    15:22:34)
- Ray: project scope should stay inside OPNFV
    scope and project should not overlap with other projects
    (GeraldK,
    15:23:06)
- frankbrockners proposes that we handle project
    scope change via a notification to the TSC, the TSC reserves the
    right to question or discuss the scope adjustment. (ChrisPriceAB,
    15:25:01)
- uli-k adds that the change should be well
    documented on the project page (ChrisPriceAB,
    15:25:17)
- AGREED: the TSC
    agrees to implement the above procedures as a way of managing scope
    change. (ChrisPriceAB,
    15:29:02)
 
 
- Process for archiving projects (ChrisPriceAB, 15:29:16)
  - https://www.opnfv.org/developers/technical-project-governance/project-lifecycle
    current lifecycle document (ChrisPriceAB,
    15:29:56)
- dneary asks how the community might terminate a
    project that has no active members (ChrisPriceAB,
    15:31:42)
- ttallgren outlines the confusion caused by
    having idle projects listed on the OPNFV wiki and creating
    misconceptions of our activity (ChrisPriceAB,
    15:33:02)
- if project steps out of SR,it should be clear
    it is inactive and carrying cost should be near zero (dlenrow,
    15:34:36)
- rpaik found a few projects that were dormant.
    He has discussed archiving with these projects. (ChrisPriceAB,
    15:34:59)
- we naturally split into participating in SR and
    not. This should be solved by rules for remaining active/eligible in
    SR (dlenrow,
    15:35:27)
- Ray basically used bitergia dashboard and
    Debra's project sheets to identify potentially stale projects
    (GeraldK,
    15:36:14)
- Frank proposes after 1 year of no activity, TSC
    should try to contact the project and trigger a decision
    (GeraldK,
    15:37:30)
- rprakash (rprakash,
    15:40:07)
- can we look at Grading projects like OpenStack
    for people to know what are in good standing (rprakash,
    15:40:47)
 
 
- OPNFV Plugfest, needs and support (ChrisPriceAB, 15:40:57)
  - Uli-K proposed to discuss technical-related
    topic from Board meetings within TSC (GeraldK,
    15:43:16)
- Chris raised concern that Board discussions are
    closed (GeraldK,
    15:43:27)
- if BOD is considering major change in technical
    content of project, it would be nice for them to invite TSC to a
    (closed) meeting to discuss... (dlenrow,
    15:44:51)
- Uli-K proposes that Chris should request to
    have such technical topics be declared open by the board when
    possible (GeraldK,
    15:44:56)
- +1 to TSC deciding technical scope of the
    OPNFV (bryan_att,
    15:46:57)
- https://www.sdxcentral.com/artiles/news/opnfv-opens-a-vote-on-nfv-mano/2015/11
    ? (ttallgren,
    15:47:15)
- The board has a significant voice and the TSC
    should consider it's guidance carefully, but the life of the
    community is based upon the interest of the members at a technical
    level, and that includes new areas of scope. (bryan_att,
    15:47:50)
- for example, I will soon propose that the C
    release include projects addressing VNFM/NFVO functionality
    explicitly based upon upstream projects; I don't believe that we
    need the board to bless the scope of such projects in
    advance. (bryan_att,
    15:49:13)
- that scope was clearly on the table for OPNFV
    at organizational creation; it's up to the TSC to determine when and
    how to address functionality in the overall scope of NFV/SDN.
    (bryan_att,
    15:50:12)
- this is just an example - others may be more
    problematic. but the TSC needs to drive the technical content,
    especially if it's the only "open" forum for scope
    discussion. (bryan_att,
    15:51:02)
- could we (Chris) ask for a joint  BOD/TSC
    meeting to discuss  technical aspects of  changes w/ BOD?
    (dlenrow,
    15:51:26)
- info uli-k requests that TSC chair can request
    for more time to the board to collect TSC input (rpaik,
    15:53:07)
 
 
- Wiki migration plans (ChrisPriceAB, 15:54:15)
  - rpaik outlines the plans for the confluence
    migration. (ChrisPriceAB,
    15:54:37)
- aricg is setting up the wiki hosting for
    confluence, it is expected that a 2 week lead time will be required
    before we start the migration process. (ChrisPriceAB,
    15:55:23)
- both sites wil be kept up for 2 weeks prior to
    final cut-over for review and formatting. (ChrisPriceAB,
    15:56:03)
- aricg asks if we can update Jira to Jira
    7 (ChrisPriceAB,
    15:57:16)
- no reason to reject (Julien-zte,
    15:57:49)
- ChrisPriceAB requests Confluence migration to
    start after Dec. 1 (Brahmaputra Milestone-D) (rpaik,
    15:59:00)
 
Meeting ended at 16:00:40 UTC
(full logs).
Action items
  - (none)
People present (lines said)
  - ChrisPriceAB (44)
- GeraldK (21)
- bryan_att (9)
- dlenrow (7)
- collabot (6)
- ttallgren (4)
- rpaik (4)
- uli-k (3)
- frankbrockners (2)
- rprakash (2)
- Julien-zte (2)
- ildikov (2)
- dku (1)
- VikramDham (1)
- morgan_orange (1)
- Mike_Lynch (1)
- Parviz (1)
- dneary (1)
- bjskerry (1)
- edgarstp (1)
Generated by MeetBot 0.1.4.