#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 14:59:31 UTC (full logs).

Meeting summary

  1. Roll Caall (ChrisPriceAB, 14:59:37)
    1. Chris Price (ChrisPriceAB, 14:59:47)
    2. Frank Brockners (frankbrockners, 14:59:48)
    3. Gerald Kunzmann (GeraldK, 15:00:05)
    4. DENG Hui (DENG, 15:00:10)
    5. Uli Kleber (uli-k, 15:00:16)
    6. Bryan Sullivan (bryan_att, 15:00:28)
    7. Jie Hu (ZTE) (hujie, 15:00:42)
    8. Dirk Kutscher (dku, 15:00:59)
    9. Tapio Tallgren (TapioT, 15:01:01)

  2. Approval of previous minutes of meeting (ChrisPriceAB, 15:01:24)
    1. https://wiki.opnfv.org/wiki/tsc#december_1_2015 previous meeting agenda and minutes (ChrisPriceAB, 15:01:32)
    2. Edgar StPierre (edgarstp, 15:01:36)
    3. previous minutes approved (ChrisPriceAB, 15:02:16)

  3. Agenda Bashing (ChrisPriceAB, 15:02:25)
    1. https://wiki.opnfv.org/wiki/tsc#december_8_2015 current agenda (ChrisPriceAB, 15:02:40)
    2. Vikram Dham (VikramDham, 15:03:21)
    3. Chris Wright (cdub, 15:04:01)

  4. action points (ChrisPriceAB, 15:04:14)
    1. the action on chrispriceab to send a call to arms for the plugfest was fulfilled this morning. Not enough time to report on the outcome. (ChrisPriceAB, 15:05:18)
    2. the action on the poll for the Q1 plugfest is complete. We have 18 votes for Tahoe and 15 votes for ONS. (ChrisPriceAB, 15:05:48)
    3. rpaik proposes we do a one day meeting at the ONS focused on development. And a one day "planning event" and board colabrotaion at Tahoe. (ChrisPriceAB, 15:06:18)
    4. Brian Skerry (bjskerry, 15:06:27)
    5. Morgan Richomme (IRC only) (morgan_orange, 15:06:49)
    6. dlenrow (dlenrow, 15:07:19)
    7. the collab summit creates issues with the IETF running the following week. (ChrisPriceAB, 15:10:49)
    8. VOTE: Voted on "Shall the TSC relocate the Q1 hackfest to the ONS in Santa Clara?" Results are, 0: 1, +1: 11 (ChrisPriceAB, 15:12:14)
    9. AGREED: the TSC votes to move the Q1 hackfest to the ONS. (ChrisPriceAB, 15:12:28)
    10. ONS starts on March 15th (Tues) (rpaik, 15:13:07)
    11. proposal is for the hackfest to start on the 14th (Mon) (rpaik, 15:13:24)

  5. Removal of OPNFV's initial scope constraints (ChrisPriceAB, 15:13:34)
    1. trevor_intel (trevor_intel, 15:13:53)
    2. https://www.opnfv.org/developers/technical-project-governance/tsc-policy (GeraldK, 15:16:40)
    3. question to TSC on whether the TSC policy should be updated as a result of the Board decision? (GeraldK, 15:17:11)
    4. Prodip notes that concerns expressed were mostly around timing (not necessarily on removing scope constraints) (rpaik, 15:17:21)
    5. many TSC members would like to see more transparency from Board (GeraldK, 15:22:54)
    6. Gerald comments that the NO votes had been more than "timing" (GeraldK, 15:27:25)
    7. https://www.opnfv.org/developers/technical-project-governance/tsc-policy TSC Policy (cdub, 15:29:53)
    8. The scope of projects chosen by the TSC will focus on the following NFV architecture functional blocks, reference points and tools or infrastructure to support the scope. Additional details about these architecture functional blocks and reference points can be found in the ETSI NFV E2E Architectural Framework [1]: (cdub, 15:30:49)
    9. Chris mentions that the TSC policy only gives a "focus" but does not put a constraint, so he believes there is no need to update the policy (GeraldK, 15:30:55)
    10. Functional Blocks: Virtualised Infrastructure Manager (VIM), Network Functions Virtualisation Infrastructure (NFVI) (cdub, 15:31:47)
    11. Reference Points: Or-Vi: The reference point in between the Orchestrator and the VIM, Nf-Vi: The reference point in between the VIM and the NFVI, ... (cdub, 15:32:12)
    12. Policy doc should make clear that our scope includes MANO, etc. Needs update (dlenrow, 15:32:14)
    13. Openstack seems to manage just fine with open board meetings (RayNugent_, 15:32:28)
    14. frankbrockners asks if tsc policy needs to be re-wrote by board and ratified by tsc, or other way around? (cdub, 15:33:56)
    15. rpaik notes that tsc policy doc is fully w/in TSC puview (cdub, 15:34:35)
    16. Gerald comments that as long as TSC is clear about the intention and will e.g. not object projects approval due to this, there is no strong need to update the TSC policy document (GeraldK, 15:34:42)
    17. I would be happy to take a cut at updating that document for next weeks TSC (dlenrow, 15:34:53)
    18. Gerald comments that in case we are going to change the policy document, we should ensure we keep the reference to ETSI NFV and ensure we are working along the building blocks and reference points defined there (GeraldK, 15:36:23)
    19. ACTION: dlenrow and bjskerry to establish a working group and propose an amendment of the TSC policy for TSC review. (ChrisPriceAB, 15:37:09)

  6. Brahmaputra milestone D report (ChrisPriceAB, 15:37:25)
    1. debra outlines the Milestone D report (ChrisPriceAB, 15:38:19)
    2. 32 project reported - green API and features frozen - at milestone D (ChrisPriceAB, 15:38:44)
    3. 3 projects have not reported for Milestone D (ChrisPriceAB, 15:38:56)
    4. out of 39 projects; 4 are "red" (no report received for 3) (GeraldK, 15:39:08)
    5. project reporting have shared concerns and unknown items when approaching milestone E (ChrisPriceAB, 15:40:25)
    6. Milestone E: 18 green, 4 red, 13 yellow, 4 orange (GeraldK, 15:41:00)
    7. 18 projects report green for projected milestone E while others share concerns achieving code freeze in time due to CI unknowns, resource challenges and installer interation. (ChrisPriceAB, 15:41:13)
    8. debra will be following up on open issues in the next Brahmaputra planning meeting. She wants to run to completion on many issues on todays meeting. (ChrisPriceAB, 15:42:09)
    9. ChrisPriceAB adds that in the future more information on milestone criteria maybe helpful (rpaik, 15:48:35)
    10. dneary asks if there is a set of must-have projects (rpaik, 15:49:40)
    11. debrascott notes that projects in Arno (e.g. Functest, installer, docs, etc.) are good examples, but that also can be re-visited (rpaik, 15:50:55)

  7. TSC meetings rest of the year (ChrisPriceAB, 15:51:25)
    1. 5th Jan is important as this is milestone E (GeraldK, 15:53:18)
    2. there will not be a TSC on the 29th (ChrisPriceAB, 15:53:22)
    3. a TSC call will be held on the 22nd, regardless of quorum (ChrisPriceAB, 15:53:36)

  8. OPNFV input at Jan 13-14 ETSI NFV-ISG Inter-SDO Information Modeling Workshop (ChrisPriceAB, 15:54:01)
    1. bryan_att has sent e-mails to the list about an upcoming workshop. Bryan will be bringing a deck from OPNFV and is looking for community support on providing input from OPNFV. (ChrisPriceAB, 15:54:42)
    2. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-December/006807.html link to the email (ChrisPriceAB, 15:55:02)

  9. Artifact page updates, approval of budget (ChrisPriceAB, 15:55:22)
    1. VOTE: Voted on "TSC to approve the budget allocation to improve the artifacts page for Brahmaputra?" Results are, 0: 1, +1: 9 (ChrisPriceAB, 15:59:17)
    2. ACTION: fdegir to send an email to mailing lists to get feedback on the design of the new artifacts page (rpaik, 15:59:23)
    3. ACTION: fdegir to start a community thread on updates to the artifacts page. (ChrisPriceAB, 16:00:21)
    4. the vote results were 13 +1 votes to update the artifact page, and one abstention. (ChrisPriceAB, 16:01:23)


Meeting ended at 16:01:29 UTC (full logs).

Action items

  1. dlenrow and bjskerry to establish a working group and propose an amendment of the TSC policy for TSC review.
  2. fdegir to send an email to mailing lists to get feedback on the design of the new artifacts page
  3. fdegir to start a community thread on updates to the artifacts page.


Action items, by person

  1. bjskerry
    1. dlenrow and bjskerry to establish a working group and propose an amendment of the TSC policy for TSC review.
  2. dlenrow
    1. dlenrow and bjskerry to establish a working group and propose an amendment of the TSC policy for TSC review.
  3. UNASSIGNED
    1. fdegir to send an email to mailing lists to get feedback on the design of the new artifacts page
    2. fdegir to start a community thread on updates to the artifacts page.


People present (lines said)

  1. ChrisPriceAB (44)
  2. collabot (17)
  3. GeraldK (14)
  4. TomNadeau (11)
  5. cdub (11)
  6. bryan_att (9)
  7. rpaik (9)
  8. dlenrow (6)
  9. hujie (4)
  10. bjskerry (4)
  11. edgarstp (4)
  12. frankbrockners (4)
  13. uli-k (4)
  14. dku (4)
  15. StuartMackie (3)
  16. ildikov (3)
  17. DENG (2)
  18. RayNugent_ (2)
  19. TapioT_ (2)
  20. ljlamers___ (1)
  21. TapioT (1)
  22. morgan_orange (1)
  23. VikramDham (1)
  24. B_Smith (1)
  25. Wenjing (1)
  26. trevor_intel (1)
  27. geraldk (0)


Generated by MeetBot 0.1.4.