#opnfv-sfc: weekly OPNFV SFC meeting

Meeting started by ebrjohn at 15:00:31 UTC (full logs).

Meeting summary

    1. Brady Johnson (ebrjohn, 15:00:46)
    2. Vijayendra Radhakrishna (Vijayendra, 15:01:10)
    3. Juan Vidal (jvidal, 15:01:30)
    4. George Paraskevopoulos (geopar, 15:01:42)
    5. Larry Lamers (ljlamers_, 15:01:46)
    6. https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-December/014104.html meeting agenda (ebrjohn, 15:01:55)

  1. ETSI PlugTest (ebrjohn, 15:02:54)
    1. http://www.etsi.org/news-events/events/1104-1st-nfv-plugtests ETSI PlugTest (ebrjohn, 15:03:08)
    2. Will be held in Madrid, Spain January 2017 (ebrjohn, 15:03:46)
    3. we will deploy at least one server with OPNFV SFC and make it available for MANO providers to test with SFC (ebrjohn, 15:03:54)

  2. Testing different topologies (ebrjohn, 15:05:00)
    1. https://lists.opendaylight.org/pipermail/netvirt-dev/2016-December/002477.html Yesterday Manuel reported this problem (ebrjohn, 15:05:19)
    2. netvirt only creates classification rules on compute nodes where there are SFs. (ebrjohn, 15:05:31)
    3. Classification rules should probably be created on every compute. Or at least everywhere there's a VM of any type. (ebrjohn, 15:06:11)
    4. We need to make sure we cover additional possibly problematic topologies and/or configurations (ebrjohn, 15:06:30)
    5. Juanma Fernandez (juanmafg, 15:06:59)
    6. https://jira.opnfv.org/browse/SFC-63 (geopar, 15:07:15)
    7. example: Everything on the same compute node: client, SFF, SF, server. I believe this is the first case ever tested. (ebrjohn, 15:07:23)
    8. example: Classifier and SFF on different compute nodes. This is the problem reported above by Manuel (ebrjohn, 15:08:10)
    9. example: SFs on different compute nodes (ebrjohn, 15:08:21)
    10. example: 3 SFs on 2 compute nodes, packets have to go from computeA to computeB and back to computeA (ebrjohn, 15:08:31)
    11. geopar 2 SFs on the same chain or 2 SFs on different chains (ebrjohn, 15:10:49)
    12. we already have a test for symmetric service chains (ebrjohn, 15:11:46)
    13. ACTION: ebrjohn to make sure these scenarios are covered in our test plan (ebrjohn, 15:12:16)

  3. Stateful character of the tests (ebrjohn, 15:12:40)
    1. apparantly the tests arent completely torn down after being run, which could cause problems or hide problems for subsequent tests (ebrjohn, 15:12:53)
    2. By torn down, I mean: classifiers deleted, all [RSPs, SFPs, SFCs, SFFs, SFs] deleted, SF VMs removed (ebrjohn, 15:13:30)
    3. seems like not all flows are deleted when SFC config deleted (ebrjohn, 15:15:37)
    4. if this is the case, then its an ODL SFC bug that we need to get fixed (ebrjohn, 15:16:04)
    5. juanmafg asks if some of the flows are from security groups that Manuel manually creates (ebrjohn, 15:16:23)
    6. geopar suggests we can cycle through the different test cases, one per day (ebrjohn, 15:17:56)
    7. ebrjohn suggests to use this as a work-around until we get all flows deleted in ODL (ebrjohn, 15:18:48)
    8. ACTION: geopar: send a mail to netvirt-dev / sfc-dev about cleanup (geopar, 15:19:40)
    9. geopar will send an email tomorrow about ODL flow cleanup (ebrjohn, 15:20:27)
    10. juanmafg asks if we also delete floating IPs (ebrjohn, 15:23:01)
    11. ebrjohn not sure, but thinks it should be checked and also deleted (ebrjohn, 15:23:15)

  4. AOB (Any Other Business) (ebrjohn, 15:23:25)
    1. geopar asks when do we want to move to Tacker upstream (ebrjohn, 15:24:02)
    2. ebrjohn is not sure when, but it mainly depends on the impacts involved, mainly if upstream Tacker is using Networking SFC (ebrjohn, 15:25:12)
    3. ACTION: ebrjohn to ask Tim Rozet what's involved with switching to Tacker upstream (ebrjohn, 15:27:20)
    4. Vijayendra says Fuel already has a plugin for OVS+dpdk+NSH (ebrjohn, 15:30:19)
    5. Vijayendra suggests using the same test cases for DPDK (ebrjohn, 15:31:05)
    6. Vijayendra says he would be willing to help contribute to DPDK testing (ebrjohn, 15:32:03)
    7. ACTION: ebrjohn to check when the ODL SFC DPDK patch was added and if its in Boron (ebrjohn, 15:32:53)
    8. ebrjohn thinks the ODL SFC DPDK patch has already been included in Boron SR1 (ebrjohn, 15:35:07)
    9. OVS 2.6.1 with NSH from Yi Yang has been tested by Manuel and George and it seems to be working (ebrjohn, 15:37:03)
    10. Manuel got the VXLAN tunnel port problem fixed in OVS 2.6.1 (ebrjohn, 15:37:36)


Meeting ended at 15:38:21 UTC (full logs).

Action items

  1. ebrjohn to make sure these scenarios are covered in our test plan
  2. geopar: send a mail to netvirt-dev / sfc-dev about cleanup
  3. ebrjohn to ask Tim Rozet what's involved with switching to Tacker upstream
  4. ebrjohn to check when the ODL SFC DPDK patch was added and if its in Boron


Action items, by person

  1. ebrjohn
    1. ebrjohn to make sure these scenarios are covered in our test plan
    2. ebrjohn to ask Tim Rozet what's involved with switching to Tacker upstream
    3. ebrjohn to check when the ODL SFC DPDK patch was added and if its in Boron
  2. geopar
    1. geopar: send a mail to netvirt-dev / sfc-dev about cleanup


People present (lines said)

  1. ebrjohn (44)
  2. geopar (3)
  3. collabot (3)
  4. Vijayendra (2)
  5. priya (2)
  6. jvidal (1)
  7. juanmafg (1)
  8. ljlamers_ (1)


Generated by MeetBot 0.1.4.