#opnfv-testperf: Functest weekly meeting December 1st

Meeting started by morgan_orange at 08:00:19 UTC (full logs).

Meeting summary

    1. Juha Kosonen (juhak, 08:00:25)
    2. Morgan Richomme (morgan_orange, 08:00:26)
    3. Arturo Martin (ArturoM, 08:00:48)
    4. agenda: https://wiki.opnfv.org/functest_meeting (morgan_orange, 08:01:56)

  1. follow up of action points (morgan_orange, 08:02:14)
    1. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2015/opnfv-testperf.2015-11-24-08.00.html (morgan_orange, 08:02:21)
    2. morgan_orange: declaration of Onos not done yet, wonder if I shall create a dedicated project or just a case onos within functest (morgan_orange, 08:03:16)
    3. Peter Bandzi (pbandzi, 08:04:25)
    4. Ahmed Maged (amaged__, 08:04:42)
    5. next AP: viktor on Tempest => update done (morgan_orange, 08:05:20)
    6. next AP: juhak also done => we will have a dedicated topic (morgan_orange, 08:05:40)
    7. next AP: morgan_orange implement status for dashboard not done...hopefully this week (morgan_orange, 08:05:58)

  2. B Release Functest status (morgan_orange, 08:06:26)
    1. https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59&view=detail&selectedIssue=FUNCTEST-63 (morgan_orange, 08:06:34)
    2. Jose Lausuch (jose_lausuch, 08:06:51)
    3. Viktor Tikkanen (viktor_nokia, 08:07:01)
    4. status provided to Debra (morgan_orange, 08:07:01)
    5. David Blaisonneau (David_Orange, 08:07:11)
    6. I would say we are on track...or almost (morgan_orange, 08:07:18)
    7. almost all testcases of companion projects declared (OVNO, SDNVPN, Promise) (morgan_orange, 08:07:49)
    8. OVNo (Open Contrail) (morgan_orange, 08:07:56)
    9. last project we need to get info: Doctor and Copper (morgan_orange, 08:08:18)
    10. ACTION: morgan_orange contact Bryan (Copper) and Ryota (Doctor) for status testcases (morgan_orange, 08:09:40)
    11. pbandzi like for ONOS, do we stay on 1 global controller testcase for ODL? (morgan_orange, 08:10:05)
    12. no specific odl project, so odl testcases are declared in functest (morgan_orange, 08:14:42)
    13. for the moment odl testcase declared, we may add some testcases e.g. odl-gbp if we need more details (morgan_orange, 08:15:11)
    14. back to JIRA and open tasks, there lots of // work (morgan_orange, 08:15:40)
    15. 1) deploy functest on the target lab (see mail from Fatih https://wiki.opnfv.org/octopus/brahmaputra_ci_process) (morgan_orange, 08:16:06)
    16. 2)extend ODL (we will come back to this point) (morgan_orange, 08:16:23)
    17. 3) integrate feature projects (morgan_orange, 08:16:35)
    18. 4) tune existing internal testcases (morgan_orange, 08:16:45)
    19. numbering is not the order of priority... (morgan_orange, 08:17:30)
    20. concerning 1, for the moment we have 1 target Lab (Fuel on LF POD2) (morgan_orange, 08:17:52)
    21. https://build.opnfv.org/ci/view/functest/job/functest-fuel-master/ (morgan_orange, 08:18:06)
    22. Fuel but without ODL or any controller (pure Neutron) (morgan_orange, 08:18:17)
    23. restricted access (as any CI production lab) (morgan_orange, 08:18:33)
    24. other labs mentioned but not available yet (morgan_orange, 08:18:42)
    25. Apex not available for Functest yet (deployement failling for couple of days) (morgan_orange, 08:19:58)
    26. https://build.opnfv.org/ci/view/apex/job/apex-daily-master/63/ (latest deploy today) (jose_lausuch, 08:20:41)
    27. ACTION: morgan_orange contact Meimei and Huawei contributors to get info on Compass target solution (morgan_orange, 08:21:50)
    28. previous ones failed, so no chance for functest to be triggered, but the jjob is created to run after deployment (jose_lausuch, 08:21:57)
    29. for joid, we have to discuss with joid team, but we should have a dev lab ready (with a beta version) (morgan_orange, 08:22:45)
    30. opnfv-fr-orange-pod2 is available for first tests (morgan_orange, 08:23:09)
    31. I was able to run vPing, ODL (partially), tempest and Rally (morgan_orange, 08:23:26)
    32. ACTION: morgan_orange create jenkins job (morgan_orange, 08:23:41)
    33. juhak and viktor_nokia We reveived your key and shall be able to grant access to the lab (morgan_orange, 08:24:02)
    34. the contact for joid lab access is David (morgan_orange, 08:24:14)
    35. the contact for joid access is David_Orange (morgan_orange, 08:24:33)
    36. target for next week: 2 installers covered from Jenkins (Fuel/joid) + info on the last 2 ones (morgan_orange, 08:27:10)
    37. joid: David_Orange assigned to created joid deployment jenkins script (based on what we experienced on Orange pod) (morgan_orange, 08:29:08)
    38. goal is to apply this script towards Intel POD 5 or 6 (need joid feedback) (morgan_orange, 08:29:30)
    39. ODL test extension: Peter sent a mail explaining the the approach (morgan_orange, 08:30:02)
    40. I see as most relevant option is to continue the way we started to use bash script for ODL tests. (pbandzi, 08:31:56)
    41. unfortunately we canot jjb scripts directly from odl as they are mostly used for confuguration of ODL which we do differentlt (pbandzi, 08:32:50)
    42. pbandzi's script for ODL (used to import ODL upstream robot tests) will be used by external projects (dealing with ODL and wanting to import their specific testcases in OPNFV) (morgan_orange, 08:33:08)
    43. refactoring of ODL scripts coordinated by pbandzi with support of amaged__ and raghavendrachari (morgan_orange, 08:35:41)

  3. Rally evolution (morgan_orange, 08:45:01)
    1. for the moment we hardcode lots of things in Rally, new certiffication feature allows some scaling to get a qualification of OpenStack through Rally (morgan_orange, 08:47:26)
    2. Qinglong Lan (Qinglong, 08:49:41)
    3. ACTION: morgan_orange check list of supported OpenStack services in Brahmaputra (morgan_orange, 08:54:04)

  4. ONOS (morgan_orange, 08:55:38)
    1. Lab is still under debug (Qinglong, 08:56:22)
    2. The Lab is in shanghai (lixiaoguang, 08:58:59)
    3. and I know who is contact (lixiaoguang, 08:59:51)
    4. https://gerrit.opnfv.org/gerrit/#/c/3453/ (jose_lausuch, 09:03:31)
    5. http://213.77.62.197/test_projects (morgan_orange, 09:05:30)
    6. http://213.77.62.197/test_projects/functest/cases (morgan_orange, 09:05:52)
    7. Onos test suite already declared (morgan_orange, 09:08:00)
    8. https://wiki.opnfv.org/onos_test_suite (morgan_orange, 09:08:04)
    9. https://wiki.opnfv.org/functest_onos (Qinglong, 09:08:19)
    10. https://wiki.onosproject.org/plugins/viewsource/viewpagesrc.action?pageId=4163875 (jose_lausuch, 09:08:38)
    11. ACTION: morgan_orange create onos testcase (morgan_orange, 09:10:33)
    12. this suite cover the basics (like odl) create nets, subnets,ports, and delete them (morgan_orange, 09:10:55)


Meeting ended at 09:12:41 UTC (full logs).

Action items

  1. morgan_orange contact Bryan (Copper) and Ryota (Doctor) for status testcases
  2. morgan_orange contact Meimei and Huawei contributors to get info on Compass target solution
  3. morgan_orange create jenkins job
  4. morgan_orange check list of supported OpenStack services in Brahmaputra
  5. morgan_orange create onos testcase


Action items, by person

  1. morgan_orange
    1. morgan_orange contact Bryan (Copper) and Ryota (Doctor) for status testcases
    2. morgan_orange contact Meimei and Huawei contributors to get info on Compass target solution
    3. morgan_orange create jenkins job
    4. morgan_orange check list of supported OpenStack services in Brahmaputra
    5. morgan_orange create onos testcase


People present (lines said)

  1. morgan_orange (153)
  2. jose_lausuch (87)
  3. Qinglong (15)
  4. juhak (14)
  5. pbandzi (8)
  6. lixiaoguang (8)
  7. collabot (6)
  8. raghavendrachari (5)
  9. amaged__ (4)
  10. fdegir (3)
  11. David_Orange (3)
  12. viktor_nokia (2)
  13. ArturoM (1)
  14. Malla_ (1)


Generated by MeetBot 0.1.4.