#opnfv-testperf: Testing working group weekly meeting March 2nd

Meeting started by morgan_orange at 15:00:14 UTC (full logs).

Meeting summary

    1. Trevor Cooper (trevc, 15:00:39)

  1. call role (morgan_orange, 15:01:14)
    1. Morgan Richomme (morgan_orange, 15:01:19)
    2. Jack (JackChan_, 15:01:34)
    3. agenda for today (morgan_orange, 15:01:47)
    4. Rex (Mingjiang, 15:02:28)
    5. https://wiki.opnfv.org/display/meetings/TestPerf (morgan_orange, 15:02:39)

  2. action point follow-up (morgan_orange, 15:02:59)
    1. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2017/opnfv-testperf.2017-02-23-15.01.html (morgan_orange, 15:03:08)
    2. AP1 morgan_orange prepare short presentation on how scenario name, installer, pod information are provided in jenkins job (info used to push results in the DB) => DOne see next topic (morgan_orange, 15:03:33)
    3. AP2 morgan_orange to create first templates for StorPerf and VSPerf (morgan_orange, 15:03:47)
    4. http://testresults.opnfv.org/reporting/danube.html (morgan_orange, 15:03:59)
    5. Bryan Sullivan (bryan_att, 15:05:44)
    6. Gabriel Yu (yuyang_gabriel, 15:06:14)

  3. Test milestones for E-rls (David McBride) (morgan_orange, 15:09:35)
    1. shall we have a framework complete milestones? (morgan_orange, 15:11:19)
    2. kubi (kubi001, 15:19:44)
    3. question from frankbrockners could we imagine to decouple test framework and release roadmap (morgan_orange, 15:19:46)
    4. Jose Lausuch (jose_lausuch, 15:23:38)
    5. maybe some definition or precision shall be done on the milestones (morgan_orange, 15:30:25)
    6. feature from a test framework follows standard milestones (morgan_orange, 15:30:48)
    7. feature integration of feature projects needs time for framework to be integrated (morgan_orange, 15:31:29)

  4. documentation (morgan_orange, 15:31:38)
    1. ACTION: David will get back to Test Group with a proposal for test project milestones (trevor_intel, 15:32:05)
    2. Mark Beierl - joining late, sorry (mbeierl, 15:34:09)
    3. structure agreed (morgan_orange, 15:39:44)

  5. D priorities status (morgan_orange, 15:40:03)
    1. landing page (front and back end available) (morgan_orange, 15:42:00)
    2. http://testresults.opnfv.org/test/api/v1/projects (jose_lausuch, 15:43:29)
    3. http://testresults.opnfv.org/test/api/v1/projects/vsperf/cases (jose_lausuch, 15:43:48)
    4. discussion on agreement on sentence on Testing community for Danube (morgan_orange, 15:50:31)
    5. mail sent to the mailing list this morning (morgan_orange, 15:50:45)

  6. CI/CD env variables retrieval to push result (morgan_orange, 15:54:05)
  7. CI env variable for results (morgan_orange, 16:02:40)
    1. https://wiki.opnfv.org/display/meetings/TestPerf?preview=/2926539/10290202/testing_ci_values.pdf (morgan_orange, 16:03:02)
    2. if testcases are not executed after a fresh install, the variables are not known => need a statiic definition and knowledge of the SUT (scenarion, installer) (morgan_orange, 16:03:47)
    3. which is usually the case (morgan_orange, 16:03:53)
    4. remark from mbeierl it would be a great feature to be able to get such info from the installer (morgan_orange, 16:04:19)
    5. could be possible with the scenario evolution and scenario yml file (morgan_orange, 16:05:03)
    6. ACTION: morgan_orange ask jmorgan1 if it could be a E feature (API providing SUT information) (morgan_orange, 16:05:32)

  8. AoB (morgan_orange, 16:05:43)
    1. out of time for plugfest discussion and E release discussion (morgan_orange, 16:05:55)
    2. for E release => a wiki page is available => do not hesitate to put what you would like to see in E release from a testing community perspective (morgan_orange, 16:06:27)
    3. ACTION: Prkas & bryan_att rpopose a slot on MANO testing in next meeting (morgan_orange, 16:07:11)
    4. next test meeting is APAC slot !!!!!!! see you on the 8th (morgan_orange, 16:07:33)


Meeting ended at 16:07:40 UTC (full logs).

Action items

  1. David will get back to Test Group with a proposal for test project milestones
  2. morgan_orange ask jmorgan1 if it could be a E feature (API providing SUT information)
  3. Prkas & bryan_att rpopose a slot on MANO testing in next meeting


Action items, by person

  1. bryan_att
    1. Prkas & bryan_att rpopose a slot on MANO testing in next meeting
  2. morgan_orange
    1. morgan_orange ask jmorgan1 if it could be a E feature (API providing SUT information)


People present (lines said)

  1. morgan_orange (41)
  2. collabot` (8)
  3. jose_lausuch (4)
  4. yuyang_gabriel (3)
  5. kubi001 (3)
  6. trevor_intel (2)
  7. JackChan_ (2)
  8. Mingjiang (1)
  9. trevc (1)
  10. bryan_att (1)
  11. mbeierl (1)


Generated by MeetBot 0.1.4.