#opnfv-testperf: Testing working group weekly meeting July 29th

Meeting started by morgan_orange at 15:00:41 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 15:00:44)
    1. gabriel_yuyang (gabriel_yuyang, 15:00:46)
    2. Morgan Richomme (morgan_orange, 15:00:48)
    3. Mark Beierl (mbeierl, 15:00:49)
    4. Yujun Zhang, IRC only (yujunz, 15:01:10)
    5. Jack (JackChan, 15:01:28)

  2. action point follow up (morgan_orange, 15:01:32)
    1. Ace (Ace__, 15:01:39)
    2. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2017/opnfv-testperf.2017-06-22-15.00.html (morgan_orange, 15:01:52)
    3. Linda Wang (LindaWang, 15:01:55)
    4. AP1: morgan_orange ask for a 10 minutes slot to discuss this during TSC meeting (morgan_orange, 15:02:00)
    5. done no time during last TSC but presentation done 2 hours ago in Tech meeting, slot for TSC planned (morgan_orange, 15:02:10)
    6. AP2: trevor_intel initiate wiki page on authenticaiton needs for Dovetail (morgan_orange, 15:02:40)
    7. done (morgan_orange, 15:02:54)
    8. Al Morton (acm, 15:02:57)
    9. https://wiki.opnfv.org/display/dovetail/Dovetail+Authenticating+for+Report (morgan_orange, 15:03:01)

  3. feedback from TSC on infra needs (morgan_orange, 15:03:44)
    1. Jose Lausuch (jose_lausuch, 15:03:49)
    2. presentation done today, question on how release cycle match with this strategy (morgan_orange, 15:04:10)
    3. quesiton on feedback for bug management , release maintenance (morgan_orange, 15:04:21)
    4. remark from Bryan to review stress/resiliency scope and include new test cases (morgan_orange, 15:05:46)
    5. TSC meeting planned beginning of July: time for sync with infra and dmcbride (morgan_orange, 15:08:13)

  4. Bitergia sync point (morgan_orange, 15:08:24)
    1. Bitergia asked for several test APi evolutions (pagination, memory bug, ..) (morgan_orange, 15:10:28)
    2. changes done (morgan_orange, 15:10:32)
    3. elasticsearch dataset under construction (morgan_orange, 15:11:03)

  5. Status on test case catalog & landing page (morgan_orange, 15:11:27)
    1. test case catalog almost ready: minor adaptations for yardstick, description for the VSPERF (morgan_orange, 15:18:47)
    2. ACTION: morgan_orange change swagger login/password (publically available in the book...) (morgan_orange, 15:19:11)
    3. ACTION: add better mechanism to track access to the API (morgan_orange, 15:20:50)
    4. on the landing page => wtill work to be done (morgan_orange, 15:32:25)
    5. ACTION: morgan_orange send a mail for a status (morgan_orange, 15:32:37)

  6. Tooling catalog (morgan_orange, 15:32:51)
    1. need for a tooling wiki page (morgan_orange, 15:36:25)
    2. ACTION: morgan_orange initiate a wiki page on tooling (morgan_orange, 15:36:31)
    3. tooling = traffic generators, framework, ... (morgan_orange, 15:36:50)
    4. could be interesting to indicate support x86 / aarch64 (morgan_orange, 15:37:08)
    5. once wiki solution => move to landing page / reporting docker (morgan_orange, 15:41:33)
    6. https://github.com/opnfv/functest/blob/stable/danube/functest/opnfv_tests/openstack/tempest/custom_tests/blacklist.txt (jose_lausuch, 15:42:16)

  7. Case exception / installers (morgan_orange, 15:42:37)
    1. on tempest => blacklist of cases per scenario/installers (morgan_orange, 15:44:02)
    2. not always the same case per installer => could be unfair as we shall have the same scope (morgan_orange, 15:49:03)
    3. note it only deals with Tempest/Rally (not the case for Refstack) (morgan_orange, 15:49:54)
    4. these restrictions have been included by the scenario owners...and probably not systematically reviewed from version N to version N+1 (morgan_orange, 15:50:30)
    5. some restrictions still make full sense ...Temepst test dealing with qemu on lxd scenario will never work... (morgan_orange, 15:51:29)
    6. ACTION: jose_lausuch start a email thread to see if we should reset the black list for each new versions / up to scenario owners / exceptios shall be validated by TSC? (morgan_orange, 15:51:31)

  8. LaaS OPNFV/ONAP (morgan_orange, 15:51:48)
    1. https://wiki.opnfv.org/display/INF/Lab+as+a+Service (morgan_orange, 16:01:20)

  9. aOB (morgan_orange, 16:01:48)


Meeting ended at 16:02:03 UTC (full logs).

Action items

  1. morgan_orange change swagger login/password (publically available in the book...)
  2. add better mechanism to track access to the API
  3. morgan_orange send a mail for a status
  4. morgan_orange initiate a wiki page on tooling
  5. jose_lausuch start a email thread to see if we should reset the black list for each new versions / up to scenario owners / exceptios shall be validated by TSC?


Action items, by person

  1. jose_lausuch
    1. jose_lausuch start a email thread to see if we should reset the black list for each new versions / up to scenario owners / exceptios shall be validated by TSC?
  2. morgan_orange
    1. morgan_orange change swagger login/password (publically available in the book...)
    2. morgan_orange send a mail for a status
    3. morgan_orange initiate a wiki page on tooling


People present (lines said)

  1. morgan_orange (44)
  2. collabot` (5)
  3. jose_lausuch (3)
  4. LindaWang (1)
  5. gabriel_yuyang (1)
  6. acm (1)
  7. JackChan (1)
  8. Ace__ (1)
  9. mbeierl (1)
  10. yujunz (1)


Generated by MeetBot 0.1.4.