#opnfv-testperf: Testing working group weekly meeting 6th of July

Meeting started by morgan_orange at 15:00:43 UTC (full logs).

Meeting summary

  1. call roll (morgan_orange, 15:00:54)
    1. Morgan richomme (morgan_orange, 15:01:01)
    2. https://global.gotomeeting.com/join/819733085 (mbeierl, 15:01:13)
    3. Mark Beierl (mbeierl, 15:01:22)
    4. Yujun Zhang (yujunz-zte, 15:01:26)
    5. Jack (JackChan, 15:01:45)

  2. action point follow up (morgan_orange, 15:03:23)
    1. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2017/opnfv-testperf.2017-06-29-15.00.html (morgan_orange, 15:03:43)
    2. AP1: organ_orange change swagger login/password (publically available in the book...) (morgan_orange, 15:04:10)
    3. ACTION: morgan_orange update status to amar (morgan_orange, 15:06:26)
    4. AP2 add better mechanism to track access to the API (morgan_orange, 15:06:51)
    5. work in progress through web protal /API (morgan_orange, 15:07:01)
    6. morgan_orange send a mail for a status (morgan_orange, 15:07:09)
    7. ACTION: morgan_orange send a mail for a status on landing page (morgan_orange, 15:07:24)
    8. AP4 morgan_orange initiate a wiki page on tooling (morgan_orange, 15:07:37)
    9. started see next slot (morgan_orange, 15:07:42)
    10. AP5 jose_lausuch start a email thread to see if we should reset the black list for each new versions / up to scenario owners / exceptios shall be validated by TSC? (morgan_orange, 15:07:53)
    11. discussions related to Danube 3.0 - main concern is on the failed temepst cases (morgan_orange, 15:08:46)
    12. a reste for Euphrates has been done to clean the black list (all installers/all scenarios) (morgan_orange, 15:09:07)

  3. Short status On EnergyAaS activity (morgan_orange, 15:10:17)
    1. presentation of the work done by Benoit around Energy consumption (morgan_orange, 15:11:34)
    2. google knows which application is consuming too much power on smartphone, the idea was to start doing something similar on NFVI (which VNF / application / ) consumes what (morgan_orange, 15:12:29)
    3. possible to leverage OPNFV Pharos federation, with deterministic runs thanks to CI pipelines (morgan_orange, 15:13:02)
    4. https://wiki.opnfv.org/display/testing/Power+consumption+monitoring (morgan_orange, 15:13:29)
    5. presentaiton during the summit on benoit's work (morgan_orange, 15:14:10)
    6. https://www.youtube.com/watch?v=jVc9Z5OuIYY&list=PLiM029E-zvrtlTmH0h0mHt_-g8B-6609P&t=16s&index=25 (morgan_orange, 15:14:13)
    7. first results (first PODs equiped) (morgan_orange, 15:17:28)
    8. http://opnfv.fr:3000 (morgan_orange, 15:17:33)
    9. on E//, LF POD2 it is possible to see the whole CI cycles (morgan_orange, 15:18:50)
    10. on Orange-POD3 Benoit added the possibility to get more details through the SDK for specific use (morgan_orange, 15:19:26)
    11. question from Mark where shall we integrate it for stress tests (Bottlenecks?) (morgan_orange, 15:26:57)
    12. for the moment collector code is not yet in OPNFV ... need to figure out where to put it (morgan_orange, 15:27:32)
    13. ACTION: benoit send a mail to the community to evaluate the need for such activity around Energy (morgan_orange, 15:32:33)
    14. New project or could it be hosted in Pharos see with jack Morgan? (morgan_orange, 15:32:38)
    15. trevor_intel mentioned that Energy monitoring could be interesting for security topics (morgan_orange, 15:34:39)
    16. discussions on collector (IPMI, Redfish, HUI scrapping) (morgan_orange, 15:37:17)

  4. Bitergia sync point (morgan_orange, 15:39:54)
    1. synchro next week (morgan_orange, 15:40:12)
    2. Jesus "We have some data collected in an enriched in Kibana" (morgan_orange, 15:41:53)
    3. https://opnfv.biterg.io:443/goto/93ebe8aca496facba752ced47379e1b4 (morgan_orange, 15:42:03)
    4. The index has only some data because the data retrieval from the API failed when retrieving a longer time frame. Álvaro already reported the problem. (morgan_orange, 15:42:11)
    5. There is a very preliminar version of a panel for visualizing the data. Even when it still needs some work, and it is showing a small dataset (because of the above problem) you can start commenting on it, if you want (at least to know if you feel we're on the right direction or not). (morgan_orange, 15:42:20)
    6. https://opnfv.biterg.io:443/goto/dd9aa660f1fa5d8dd63f7f455609aa80 (morgan_orange, 15:42:31)

  5. Tooling catalog (morgan_orange, 15:43:41)
    1. work initiated (morgan_orange, 15:43:51)
    2. https://wiki.opnfv.org/display/testing/Testing+tooling+catalog (morgan_orange, 15:44:06)
    3. remark from yujunz: list only the external tools or indicate python requirements? (morgan_orange, 15:44:29)
    4. ACTION: everybody complete the table..we will discuss next week (morgan_orange, 15:44:43)

  6. Dockerfile discussion (morgan_orange, 15:44:58)
    1. more than one dockerfile (for compose) per project, and can we use merge jobs to trigger docker push instead of timer? (morgan_orange, 15:45:08)
    2. yujunz-zte suggests if we want to include python requirements, we can do it automatically by writing a script to pull all requirement.txt from different projects (morgan_orange, 15:47:25)
    3. https://docs.docker.com/docker-hub/builds/ (yujunz-zte, 15:48:49)
    4. for the moment the logic to build docker file is in releng, docker file is in the project repos (morgan_orange, 15:50:47)
    5. https://git.opnfv.org/releng/tree/jjb/releng/opnfv-docker-arm.yml https://git.opnfv.org/releng/tree/jjb/releng/opnfv-docker.yml (jose_lausuch, 15:52:46)
    6. https://git.opnfv.org/releng/tree/jjb/releng/opnfv-docker.yml#n130 (jose_lausuch, 15:55:26)
    7. ACTION: jose_lausuch mbeierl review changes needed to support multiple docker in releng (morgan_orange, 15:57:56)
    8. ACTION: mbeierl jose_lausuch evaluate moving from cron to post merge mechanism for docker production (morgan_orange, 15:58:13)

  7. AoB (morgan_orange, 15:58:24)
    1. Can anyone think of a good way to deliver docker-compose.yaml files to end users? (mbeierl, 15:58:49)
    2. next meeting APAC slot 12th of July (morgan_orange, 15:58:57)
    3. https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2017-June/016857.html (yujunz-zte, 16:01:41)


Meeting ended at 16:01:59 UTC (full logs).

Action items

  1. morgan_orange update status to amar
  2. morgan_orange send a mail for a status on landing page
  3. benoit send a mail to the community to evaluate the need for such activity around Energy
  4. everybody complete the table..we will discuss next week
  5. jose_lausuch mbeierl review changes needed to support multiple docker in releng
  6. mbeierl jose_lausuch evaluate moving from cron to post merge mechanism for docker production


Action items, by person

  1. jose_lausuch
    1. jose_lausuch mbeierl review changes needed to support multiple docker in releng
    2. mbeierl jose_lausuch evaluate moving from cron to post merge mechanism for docker production
  2. mbeierl
    1. jose_lausuch mbeierl review changes needed to support multiple docker in releng
    2. mbeierl jose_lausuch evaluate moving from cron to post merge mechanism for docker production
  3. morgan_orange
    1. morgan_orange update status to amar
    2. morgan_orange send a mail for a status on landing page
  4. UNASSIGNED
    1. benoit send a mail to the community to evaluate the need for such activity around Energy
    2. everybody complete the table..we will discuss next week


People present (lines said)

  1. morgan_orange (60)
  2. yujunz-zte (12)
  3. collabot` (6)
  4. rbbratta (4)
  5. mbeierl (4)
  6. jose_lausuch (2)
  7. JackChan (1)
  8. trevor_intel (0)
  9. gabriel_yuyang (0)
  10. kubi001 (0)


Generated by MeetBot 0.1.4.