#opnfv-vswitchperf: vswitchperf

Meeting started by SRao at 16:02:57 UTC (full logs).

Meeting summary

  1. Development Update (SRao, 16:03:08)
    1. 2 Patches from Sridhar and Parth are Merged. (SRao, 16:03:20)
    2. Ancuta: Able to run changes on the server, ready to commit. (SRao, 16:03:48)

  2. CN-Benchmarking (SRao, 16:11:04)
    1. Federica: Student is found. He has started looking at it. (SRao, 16:12:10)
    2. ACTION: : Sridhar to send other project plans to Federica. (SRao, 16:13:55)
    3. 1st Step: Automate the deployment of Kubernetes Cluster with Multus [Kubespray] (SRao, 16:17:47)
    4. Inputs: [Node IPs, Login/Passwds of the node, Roles] (SRao, 16:19:23)
    5. Novelty: Multiple Data-Interfaces Performance benchmarking. (SRao, 16:20:15)
    6. Tomofumi Hayashi and Doug Smith or Redhat are more than willing to help us - if we are stuck. (SRao, 16:22:09)
    7. DanM Vs Multus is not considered for now. (SRao, 16:22:47)
    8. Intel Multus team can also help us. (SRao, 16:23:14)
    9. Slack is preferred channel. (SRao, 16:23:42)
    10. Action Items for emanuele: Registration, Jira for Pod12 VPN access (SRao, 16:25:56)
    11. (1) Work with Parth in automating Kubernetes Deployment. (SRao, 16:26:15)
    12. ACTION: Sridhar to share "Tentative Configuration File" That will be given as input to Automation-script. (SRao, 16:27:12)
    13. (2) L2FwD-with-dpdk container (SRao, 16:28:41)
    14. L2Fwd Is simple vnf (dpdk application) which forward packets from one I/F to another .. In container. (SRao, 16:29:32)
    15. (3) Finalize the Testcases. (SRao, 16:30:03)
    16. (4) Implement this in VSPERF (for all TGens). (SRao, 16:31:09)
    17. (5) Info Collection: End-Of-test Results, Live-Results Tgen, Infra-Metrics (container-metrics), Environment Information ---- We want to Correlation. (SRao, 16:33:09)
    18. Plugin Choices (vswitch-based like ovs) and L3-based (Calico), ... Container Choices (L2Fwd,...). (SRao, 16:35:20)
    19. Al Morton (acmacm, 16:35:35)
    20. https://parthyadav.netlify.com/getting-started-with-multus/ (SRao, 16:45:58)

  3. VSPERF-CNTT (SRao, 16:46:15)
    1. Bring VSPERF Testing Between "Baremetal Provisioning" and "Openstack-Deployment" (SRao, 16:47:59)
    2. Dataplane performance benchmarking: Shaker, VMTP, NFVBench, Rapid-Prox, Yardstick-NSB. (SRao, 16:53:24)
    3. Should we compete With these 5? (SRao, 16:54:39)
    4. Al: YES, with Integration with XTesting. (SRao, 16:54:53)
    5. ACTION: Sridhar to update the VSPERF-CNTT page. (SRao, 16:57:13)


Meeting ended at 16:59:29 UTC (full logs).

Action items

  1. : Sridhar to send other project plans to Federica.
  2. Sridhar to share "Tentative Configuration File" That will be given as input to Automation-script.
  3. Sridhar to update the VSPERF-CNTT page.


People present (lines said)

  1. SRao (31)
  2. collabot` (3)
  3. acmacm (1)


Generated by MeetBot 0.1.4.