#opnfv-yardstick: Breakout session testing projects

Meeting started by anac at 23:19:41 UTC (full logs).

Meeting summary

    1. Agenda on Etherpad https://etherpad.opnfv.org/p/OPNFV_Design_Summit_2015 (anac, 23:20:30)
    2. important to diferentiate between CI resources for testing and resources for platform ci (anac, 23:24:21)
    3. suggestion to run 2 builds per day (anac, 23:34:22)
    4. only stable version of installer should be delopyed for testing the platform (anac, 23:36:34)

  1. common objects for all test projects (anac, 23:38:58)
    1. test result API - not mandatory to use it, to use it - the project needs to be added to the database (anac, 23:40:05)
    2. Functest and Yardstick use it, Vsperf on the way (anac, 23:40:35)
    3. test case definition - high level decription to produce test documents, there is a field for url (anac, 23:41:35)
    4. AGREED: test cases advertized in release B should be in the database (anac, 23:42:25)
    5. suggestion that the test cases should register their test cases in yardstick (anac, 23:48:13)
    6. suggestion that a test case shall be documented, clearly stated what installer it works in (ideally all installers) (anac, 23:58:03)
    7. criteria for B-release: matrix (installer/test cases), test case documented, run functest and yardstick, 4 iterations in CI are run (anac, 00:01:05)
    8. will there be iso for the release? installer needs to provide scripts (mimimum), iso production is up to the installer project (anac, 00:03:33)
    9. SDN controller tests are included in Functest (anac, 00:10:11)
    10. a comment was made that stability testing is missing in the testing scope (anac, 00:13:47)
    11. proposal to plan for stability test in release C (anac, 00:15:18)
    12. for C-release: elaborate on loops of tests (anac, 00:18:58)
    13. suggestion to run vsperf and qtip on a system installed with base-OS (anac, 00:41:02)
    14. who is responsible for troubleshooting? (anac, 00:41:34)


Meeting ended at 00:44:00 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. anac (24)
  2. collabot (4)


Generated by MeetBot 0.1.4.