#acumos-meeting: Acumos TSC

Meeting started by bryan_att at 13:01:40 UTC (full logs).

Meeting summary

    1. Nat TechM (bryan_att, 13:01:51)
    2. Bryan Sullivan (bryan_att, 13:02:37)
    3. Michael Rooke, Nokia (NokMikeR, 13:03:57)
    4. valderrv (valderrv, 13:06:40)

  1. RollCall (bryan_att, 13:08:58)
    1. Michael Rookke (bryan_att, 13:09:33)

  2. Review Meeting Minutes (aimeeu, 13:13:04)
    1. - Scott: we don't have a quorum, so minutes approval is moved to next week (aimeeu, 13:13:33)

  3. Agenda Bashing (aimeeu, 13:13:41)
    1. Scott Nichols (LF) reviews agenda (aimeeu, 13:14:17)

  4. Status of Open Action Items (aimeeu, 13:14:29)
    1. Pantelis is absent, so release naming update will be next week (aimeeu, 13:15:06)
    2. Etherpad update: Vanessa gives update: installation in about 2 weeks (aimeeu, 13:16:36)

  5. Technical Community Document review (aimeeu, 13:18:30)
    1. document was created and sent to the TSC private list as a way to reach all the TSC members (aimeeu, 13:19:53)
    2. ACTION: Aimee will add document and link to TSC page (aimeeu, 13:20:09)
    3. Scott reminds everyone where the Acumos Technical Charter can be found #link https://www.acumos.org/wp-content/uploads/sites/61/2018/03/charter_acumos_mar2018.pdf (aimeeu, 13:21:21)
    4. discussion on whether to have more review discussion (aimeeu, 13:22:22)
    5. Paul-Andre Raymond suggests sharing the document with the Community for wider input (aimeeu, 13:22:43)

  6. Subcommittees (aimeeu, 13:23:10)
    1. Bryan summarizes subcommittee kickoff call (aimeeu, 13:23:26)
    2. Bryan reviews where subcommittee pages are located on the wiki (aimeeu, 13:25:02)
    3. Scott asks if 8 PDT is the regular time for the Architecture subcommittee meeting; Bryan says no and mentions creating Doodle polls to determine optimal times (aimeeu, 13:26:01)
    4. Scott asks if there are subcommittee members ; Bryan answers that subcommittee members have not stepped forward and the Community is in the process of organizing membership in those committees (aimeeu, 13:27:29)

  7. New Agenda Items (aimeeu, 13:27:55)
  8. Open discussion with greater TSC on Release (aimeeu, 13:28:16)
    1. Bryan mentions that this item originated with Pantels (aimeeu, 13:28:48)
    2. correction: Pantelis (aimeeu, 13:28:57)
    3. Bryan shows summary of subcommittee kickoff meeting on Architecture page #link https://wiki.acumos.org/display/AR/Meetings (aimeeu, 13:30:20)
    4. discussion on need to formalize subcommittee mandates and rolls (aimeeu, 13:30:44)
    5. Scott observes that subcommittee names should be focused on end user experience (aimeeu, 13:31:53)
    6. Bryan: for Product subcommitte: what do we want the platform to be; Architecture: determines architecture; Product and Architecture committees work together to define release plan (aimeeu, 13:33:22)
    7. Scott; where are we with formation of the committees; does TSC have requests? (aimeeu, 13:33:52)
    8. Bryan: review the subcommittee information on the wiki and Community members propose people from their companies to be active subcommittee members (aimeeu, 13:34:49)
    9. https://wiki.acumos.org/display/TSC/Subcommittees charters from TSC (aimeeu, 13:35:17)
    10. https://wiki.acumos.org/display/ACCOM Acumos.org/Product subcommittee (aimeeu, 13:35:43)
    11. https://wiki.acumos.org/display/AR Architecture subcommittee (aimeeu, 13:35:59)
    12. https://wiki.acumos.org/display/SEC Security subcommittee (aimeeu, 13:36:12)

  9. Update to Project/Repo proposed mapping (aimeeu, 13:36:33)
    1. https://wiki.acumos.org/display/AC/Acumos+Architecture+Mapping+to+Repos+Jira+etc (aimeeu, 13:36:55)
    2. Bryan summarizes the need to correctly map the current repos into the approved projects (aimeeu, 13:37:38)
    3. Bryan: the Community needs to understand the process for shifting component repos between projects (aimeeu, 13:39:17)
    4. Bryan: the Community needs to have a team approach to finalizing component repos into the Projects (aimeeu, 13:39:55)
    5. Nat: offline discussion and then a separate meeting to realign and finalize the repos into Projects (aimeeu, 13:41:09)
    6. Bryan volunteers to lead effort to finalize repos; asks for which companies will participate in addtion to AT&T and TM (aimeeu, 13:42:26)
    7. ACTION: Bryan will organize additional meeting to discuss repos/Projects finalization (aimeeu, 13:42:58)

  10. License and Security Check on Models (aimeeu, 13:43:35)
    1. Bryan: the Community needs TSC input on whether models contributed to the Acumos marketplace need to be scanned for vulnerabilities and also have an appropriate license (aimeeu, 13:44:41)
    2. Scott: when you look at a model contributed to the platform, what essentially are we looking at? code? documentation? (aimeeu, 13:46:09)
    3. Bryan: both (aimeeu, 13:46:15)
    4. Bryan shows the contents of a model downloaded from the portal marketplace (aimeeu, 13:46:59)
    5. the model could be a combo of code, data, and docs (aimeeu, 13:47:31)
    6. Scott: concern with license models; code would fall under Apache 2.0; docs would fall under Creative Commons (see Technical Charter); in other cases, the TSC can approve alternate licenses; approach how models are covered by first looking at the Technical Charter (aimeeu, 13:49:27)
    7. Ofer: +1 to addressing licensing of contributed models; should be discussed by the Product subcommittee (aimeeu, 13:50:06)
    8. Bryan: assumption that Technical Charter applied to code contributed to the platform, not to models, and asks for clarifictiaon (aimeeu, 13:51:16)
    9. Scott: applies to models contributed to the public marketplace (the LF instance) (aimeeu, 13:51:54)
    10. Bryan: are the models that are published to the LF instance are subject to the licenses in the Technical Charter? (aimeeu, 13:53:09)
    11. that is Scott's understanding; again, if the TSC thinks that's not the right outcome, Community needs to work together to resolve (aimeeu, 13:54:23)
    12. Paul-Andre: different understanding of contributed models: pieces of code contributed by users may be open source or have a different license; may be imported from federated instance; the user model is very different than contributing code to the platform; point: needs to be more debate on this subject (aimeeu, 13:55:40)
    13. : Ofer +1 (aimeeu, 13:55:47)
    14. Scott asks how to move conversation forward (aimeeu, 13:56:35)
    15. Paul-Andre asks if this is for the Product committee to discuss (aimeeu, 13:57:02)
    16. consensus is to have this discussed in the Product committee (aimeeu, 13:57:30)
    17. Bryan: do we expect this ecosystem to take steps to NOT propagate malware in models? (aimeeu, 13:58:15)
    18. Bryan: Product committee should also discuss safety of contributed models (aimeeu, 13:59:00)
    19. ACTION: Product committee should discuss the above items (aimeeu, 13:59:43)

  11. Planning for Next Meeting (aimeeu, 14:00:05)
    1. mapping of project to release 1 - this can be discussed by the Product committee (aimeeu, 14:00:27)
    2. question on if release plan for release 1 has been decided? (aimeeu, 14:01:00)
    3. this has not occurred yet; this will be discussed in the Product committee (aimeeu, 14:01:21)
    4. Jamil: asks when the release date is? (aimeeu, 14:01:43)
    5. release date is scheduled for Nov 7, 2018 (aimeeu, 14:02:02)
    6. Jamil: when will a release plan be finalized? (aimeeu, 14:02:16)
    7. Community is still at the stage of soliciting input for the next release (aimeeu, 14:02:58)
    8. we should come to an agreement by next week what components will in release 1 (aimeeu, 14:03:45)


Meeting ended at 14:05:08 UTC (full logs).

Action items

  1. Aimee will add document and link to TSC page
  2. Bryan will organize additional meeting to discuss repos/Projects finalization
  3. Product committee should discuss the above items


People present (lines said)

  1. aimeeu (72)
  2. bryan_att (6)
  3. collabot` (4)
  4. valderrv (1)
  5. NokMikeR (1)
  6. ofer (1)


Generated by MeetBot 0.1.4.