#acumos-meeting: Acumos OA&M Project

Meeting started by bryan_att at 15:08:25 UTC (full logs).

Meeting summary

    1. attendees Bryan, Krish, Nat, Parichay (aimeeu, 15:09:50)
    2. conflicts, so Bryan will send out a doodle poll to determine optimal meeting time (aimeeu, 15:11:14)
    3. #link https://wiki.acumos.org/display/OAM/Meetings (aimeeu, 15:12:20)
    4. Krish: do we need any other repos? or will the existing 2 repos be sufficient? (aimeeu, 15:12:52)
    5. Bryan: system-integration will be for platform deployment, platform-oam will be for associated tools such as logging (aimeeu, 15:14:02)
    6. Krish: should reports and/or a reporting tool be part of platform-oam (aimeeu, 15:15:31)
    7. Parichay: backup and disaster recovery should be part of platform-oam (aimeeu, 15:15:49)
    8. Bryan: good scope; we will evolve as more items are incoporated (aimeeu, 15:17:02)
    9. Bryan shows list of not-closed Jira items for system-integration and platform-oam (aimeeu, 15:17:54)
    10. Krish: let's focus on prioritizing - let's focus on the High items (aimeeu, 15:20:33)
    11. Vishnu (vrov) joined the meeting (aimeeu, 15:21:11)
    12. #link https://jira.acumos.org/browse/ACUMOS-1043 (aimeeu, 15:21:59)
    13. this encompasses back end; different companies may wish to use different DBs; we should provide different options, not exclude, and let operator decide what back-end components to use (aimeeu, 15:23:35)
    14. Bryan: AIO script has ability to specify pre-existing components, such as database, so database wouldn't be installed (aimeeu, 15:24:27)
    15. AIO script lacks upgrade/migration (aimeeu, 15:24:46)
    16. Krish: Parichay - what type of storage do we support, how do we specify different storage types - we need to work through and create a good solution (aimeeu, 15:25:40)
    17. Bryan: k8s - important to have data live outside the Docker containers (aimeeu, 15:26:16)
    18. persistent volumes (aimeeu, 15:26:31)
    19. Krish: some platforms, like Azure, provide load balancing; Acumos needs to be more generic in how it uses a load balancer (aimeeu, 15:27:10)
    20. Bryan: need to provide clear guidance; not all load balancers support Kong - need to solve this reverse proxy with different load balancers (aimeeu, 15:28:27)
    21. Krish: Parichay has been working on kong with k8s (aimeeu, 15:29:18)
    22. Bryan: problem with kong in k8s cluster is that you can't expose 8080 or 443 (aimeeu, 15:29:51)
    23. Bryan explains (aimeeu, 15:29:57)
    24. Krish - we've been working on this - need to sync up (aimeeu, 15:30:24)
    25. Krish provides details (aimeeu, 15:30:43)
    26. discussion between Bryan and Krish; implication is that the installation must have a load-balancer (aimeeu, 15:31:54)
    27. Krish: goal is to provide complete k8s with nothing running outside (on docker ce for example) (aimeeu, 15:33:27)
    28. Kirsh: for k8s, should we pick a single environment (Azure, bare metal, etc) and then expand to other environments? (aimeeu, 15:34:42)
    29. Krish: for k8s, should we pick a single environment (Azure, bare metal, etc) and then expand to other environments? (aimeeu, 15:35:03)
    30. Bryan: k8s deployment of the platform should not differ based on environment (aimeeu, 15:35:44)
    31. standing up a load-balancer may be environment dependent but that's out of scope (aimeeu, 15:36:14)
    32. Krish points out that an environment such as Azure provides a lot already set up compared to bare metal (aimeeu, 15:37:01)
    33. Bryan: we should be pure cloud native - doesn't matter where it's deployed, process should be the same (aimeeu, 15:37:52)
    34. Bryan: we will work collaboratively to address these issues (aimeeu, 15:38:09)
    35. https://jira.acumos.org/browse/ACUMOS-1091 (aimeeu, 15:38:34)
    36. #link https://jira.acumos.org/browse/ACUMOS-1091 (aimeeu, 15:38:51)
    37. Krish: we need get some of the ONAP ELK people to take an active role in Acumos (aimeeu, 15:39:29)
    38. Ken: is this Sponden's area? (aimeeu, 15:39:45)
    39. Ken Kristiansen joined the meeting (aimeeu, 15:40:02)
    40. Krish: currently under platform-oam but if it grows, it could be split into a separate project (aimeeu, 15:40:54)
    41. consensus that Sponden should be involved (aimeeu, 15:41:18)
    42. Parichay has done a lot of work in this ELK area (aimeeu, 15:42:02)
    43. Ken: Sponden has been leading the effort between ONAP and Acumos ELK effort (aimeeu, 15:42:34)
    44. Ken: recommends Bryan have a call with Sponden (aimeeu, 15:43:17)
    45. Bryan will reach out to Sponden to understand what he's done and how he can help drive ELK in Acumos (aimeeu, 15:43:51)
    46. Krish: missing from Jira is functionality to query database to build reports; we need to discuss this further (aimeeu, 15:46:10)
    47. Krish: metrics examples: how many people logged in, how many models uploaded, etc - reports that business managers want (aimeeu, 15:46:52)
    48. Krish: need to be clear that business metrics are needed and that they aren't based on physical resources (aimeeu, 15:47:40)
    49. need to enhance logging capabilities to capture what is currently missing, such as IP addresses of users (aimeeu, 15:48:49)
    50. access logs of client IP addresses (aimeeu, 15:49:04)
    51. Ken: Parichay is already working on these initiatives and is almost done (aimeeu, 15:50:21)
    52. Ken: pulling data directly from database is only temporary until a solution is found (aimeeu, 15:51:22)
    53. Krish: need to set log retention (aimeeu, 15:51:40)
    54. need to give users choice of retention period (aimeeu, 15:51:55)
    55. Bryan asks for help prioritizing Jira tickets (aimeeu, 15:53:22)
    56. Bryan asks for who will focus on what (aimeeu, 15:54:17)
    57. Logging: Parichay (aimeeu, 15:54:27)
    58. Bryan/Krish: Parichay should be made a committer in system-integration (aimeeu, 15:56:22)
    59. Question about Amit Mishra's continuing involvement - he will be back the first week in July (aimeeu, 15:58:06)
    60. ACTION: Bryan will sent out email about meeting times (aimeeu, 16:00:12)


Meeting ended at 16:02:16 UTC (full logs).

Action items

  1. Bryan will sent out email about meeting times


People present (lines said)

  1. aimeeu (68)
  2. bryan_att (3)
  3. collabot_ (3)


Generated by MeetBot 0.1.4.