#acumos-meeting: TSC Weekly Meeting

Meeting started by aimeeu at 13:04:19 UTC (full logs).

Meeting summary

  1. Roll Call (aimeeu, 13:04:27)
    1. TSC Attendees: Ofer (Amdocs), Jack (AT&T), Pantelis (Nokia), Yuxuan (Huawei), Nat (TechM), GuangCong (ZTE) (aimeeu, 13:06:17)

  2. Review and Agree to Minutes of Previous Meetings (aimeeu, 13:07:59)
    1. Jack would like to postpone minutes approval to next week (aimeeu, 13:08:40)

  3. Agenda Bashing (aimeeu, 13:08:54)
    1. Nat brings up extending API Freeze (M3) deadline by a week; this will be covered in 7C (aimeeu, 13:09:34)
    2. Jamil would like to discuss meeting with Microsoft (aimeeu, 13:10:39)

  4. Status of Open Action Items (aimeeu, 13:10:57)
    1. Update from Outreach Committee: Annie sent out a survey last week asking who will be attending Open Source Summit North America to see if TSC meeting can held there (aimeeu, 13:12:11)
    2. Ofer will be attending; possibly TechM (aimeeu, 13:12:37)

  5. Committee Reports (aimeeu, 13:13:35)
    1. Community Committee: frozen set of requirements for Athena (aimeeu, 13:14:00)
    2. Ofer: #link https://wiki.acumos.org/display/ACCOM/Meetings (aimeeu, 13:14:47)
    3. Name for the next release discussed (aimeeu, 13:16:23)
    4. Ofer motion to call the next release 'Boreas' (aimeeu, 13:16:43)
    5. Nat seconds (aimeeu, 13:16:50)
    6. TSC vote on naming the next release Boreas (aimeeu, 13:17:51)
    7. name passes by TSC voice vote (aimeeu, 13:18:12)
    8. discussion on names using only Greek gods or expanding to other mythologies (aimeeu, 13:18:53)
    9. Pantelis: expand to other mythologies (aimeeu, 13:19:38)
    10. motion to adopt naming convention to be mythical gods, not just Greek gods (Pantelis) (aimeeu, 13:20:02)
    11. motion seconded; TSC voice vote to expand names from all mythologies (aimeeu, 13:20:31)
    12. User Stories for next release; ongoing discussion in Community Committee meeting (aimeeu, 13:21:22)
    13. Ofer discusses items on the list #link https://wiki.acumos.org/display/ACCOM/Meetings under '7/17/18' Meeting (aimeeu, 13:22:14)
    14. Jamil raises concerns about integrating model creation tools such as Rapid Miner, Jupyter, etc - be aware of licensing issues (aimeeu, 13:28:53)
    15. Architecture Committee: past 2 weeks the Committee has been reviewing functionality, good progress (aimeeu, 13:31:28)
    16. Need Nat to report on which projects still need to document APIs (aimeeu, 13:32:09)
    17. Detailed reviews with AT&T CMLP team for integrating functionality into Athena release (aimeeu, 13:32:57)
    18. Bring CMLP data sets info Training project (aimeeu, 13:33:23)
    19. AT&T CMLP (Common Machine Learning Platform) is an internal AT&T project; it is an integrated environment of internally developed code as well as open source code, including Acumos; CMLP will be contributing code to the Acumos project (aimeeu, 13:35:24)
    20. Anwar: more items: deploy fix to Federation targeted for first week in August; reviewed OA&M module notification - work for Portal team, need feedback (aimeeu, 13:37:41)
    21. 7/17 Security Committee minutes are at https://wiki.acumos.org/display/SEC/Meetings (bryan_att, 13:39:50)
    22. Security Committee summary: see link above; best practices discussed (aimeeu, 13:40:19)
    23. Nexus-IQ - would like to use this tool, which is part of LF infrastructure; working on process for people to follow (aimeeu, 13:41:02)
    24. platform security hardening is an ongoing discussion item (aimeeu, 13:41:22)

  6. PTL reports or blockers (aimeeu, 13:42:10)
    1. Nat: most PTLs are behind at this point (aimeeu, 13:43:14)
    2. PTLs were asked to mark items in Jira that are in jeopardy (aimeeu, 13:43:37)
    3. biggest blocker/risk is lack of development resources (aimeeu, 13:44:03)
    4. Jack asks if the RM/PTL report should be before the SubCommittee reports (aimeeu, 13:45:13)
    5. Nat suggests putting the RM current release report first during active development phases (aimeeu, 13:46:39)
    6. Jack: need to establish practice/structure for Release Management review to be given to TSC weekly meeting (aimeeu, 13:47:58)
    7. Jack is looking for breakdown of which requirements are being delivered in this release and status of development cycle (aimeeu, 13:48:58)
    8. ACTION: Jack will help Nat contact PTLs for list of finalized list of requirements for this release (aimeeu, 13:49:30)
    9. Manoop: checklists have been created for M1 and M2 but PTLs were not asked to fill those out; should we ask PTLs to fill those out? Also, there is a wiki template that can be used to display overall status for each release (aimeeu, 13:51:22)
    10. Nat: suggests leaving M1, M2 checklists for now and incorporate in next release (aimeeu, 13:52:17)

  7. New Agenda Items (aimeeu, 13:52:49)
  8. Projects without PTLs (aimeeu, 13:53:12)
    1. still need PTLs to lead 2 projects: Licensing and Deployment (aimeeu, 13:53:30)
    2. Jack asks for additional companies to come forward and lead those projects (aimeeu, 13:54:31)
    3. Bryan Sullivan is acting Deployment PTL and will help anyone who would like to take over (aimeeu, 13:55:00)

  9. Athena Release Planning (aimeeu, 13:55:10)
    1. checklists are still a work in progress (aimeeu, 13:55:20)

  10. M2 and M3 milestones (aimeeu, 13:55:35)
    1. need to clearly identify deliverables in M2; we are late in documenting APIs for M3 (aimeeu, 13:56:06)
    2. reason is Release Manager role was filled late; need to drive discussion around M2 and M3 (aimeeu, 13:56:36)
    3. Nat: move M3 to 7/24; M2 was 7/18 but still not complete - should be completed this week (aimeeu, 13:57:34)

  11. Survey of standing up instances with member companies (aimeeu, 13:57:53)
    1. which member companies will stand up instances of Acumos and share models? (aimeeu, 13:58:10)
    2. Jack: asks for all participating companies to join discussions on standing up local instances (aimeeu, 13:59:21)
    3. some models from Dev Challenge may be shared (aimeeu, 13:59:58)
    4. #action Jack will send out email and collect data on which companies will stand up instances (aimeeu, 14:00:47)

  12. Shared Test Environment (aimeeu, 14:01:33)
    1. Scott Nichols: $500/month bandwidth; $2-2500/month infra; $33000/yr expense - need to go to governing board (aimeeu, 14:02:24)
    2. may need to leverage Community (aimeeu, 14:02:43)
    3. Jack: would like to establish Community labs as alternative or parallel effort to Linux Foundation lab; please reach out to Jack Murray (AT&T) if interested (aimeeu, 14:03:39)
    4. Need to create wiki content about lab environment; add to TSC agenda for next week (aimeeu, 14:04:58)
    5. Jack: please add lab infra details to Infrastructure space on wiki (Ken and Chris, AT&T) (aimeeu, 14:06:09)


Meeting ended at 14:06:44 UTC (full logs).

Action items

  1. Jack will help Nat contact PTLs for list of finalized list of requirements for this release


People present (lines said)

  1. aimeeu (70)
  2. collabot (4)
  3. bryan_att (1)


Generated by MeetBot 0.1.4.