#acumos-meeting: Acumos TSC Weekly Meeting

Meeting started by aimeeu at 13:06:11 UTC (full logs).

Meeting summary

  1. Roll Call (aimeeu, 13:06:46)
    1. attendees Daniel Sela (Amdocs), Jack Murray (AT&T), Zheng YuXuan (Huawei), Pantelis Monogioudis (Nokia), Nat Subramanian (TechM), Liu GuangCong (ZTE) (aimeeu, 13:08:43)

  2. Previous Minutes Approval (aimeeu, 13:09:06)
    1. pushed to next meeting (aimeeu, 13:09:50)

  3. Agenda Bashing (aimeeu, 13:09:55)
    1. new item: next week is a holiday in the US so no meeting next week, 3 Sept. The next TSC meeting will be 10 Sept 2018. (aimeeu, 13:12:15)
    2. ACTION: aimeeu will send email to TSC list (aimeeu, 13:12:55)

  4. Standing Agenda ITems (aimeeu, 13:13:06)
  5. Marketing and Outreach (aimeeu, 13:13:25)
    1. update on Acumos activity at the Open Source Summit North America in Vancouver; over 100 registrants, Bryan Sullivan will be presenting (aimeeu, 13:14:08)

  6. Release Manager Update (aimeeu, 13:15:24)
    1. Sprint 3 progress completed 24 August; Jira items 19 closed, 13 delivered, 6 submitted (aimeeu, 13:16:21)
    2. 7 user stories moved to Sprint 4 (aimeeu, 13:16:48)
    3. Overall progress; code freeze in 3 weeks; 4 user stories are at risk; 44% of requirements are still pending and have to be completed in Sprint 4 (aimeeu, 13:18:18)
    4. Nat shares graphs and summaries (aimeeu, 13:18:59)
    5. Nat notes that these reports are posted on the PTL wiki page (aimeeu, 13:19:17)
    6. https://wiki.acumos.org/display/REL/PTL+Meetings (aimeeu, 13:19:36)
    7. Nat shares Boreas Release calendar (aimeeu, 13:19:54)
    8. https://wiki.acumos.org/display/REL/Boreas+Release+Draft+Timeline (aimeeu, 13:20:22)
    9. Nat and Jack encourage feedback on Boreas release timeline (aimeeu, 13:21:37)
    10. Jack encourages more involvement from all interested parties; Boreas release planning will be discussed in the coming weeks and months (aimeeu, 13:23:25)
    11. Nat requests PTLs to please keep Jira updated, please be on the lookout for email from Deepti (PM) (aimeeu, 13:26:02)
    12. Anwar: which component has the most remaining open items for Athena? (aimeeu, 13:26:26)
    13. Nat: Portal has the most (aimeeu, 13:26:36)
    14. a lot of functionality in other components impacts the Portal, so Portal has to wait for other components (aimeeu, 13:27:31)
    15. Anwar: asks if the plan was to have so many items in Sprint 4 (aimeeu, 13:28:00)
    16. Nat: due to a late start, many items were pushed back (aimeeu, 13:28:20)
    17. Jack: going forward, we need to plan a bit better, break up user stories across multiple sprints (aimeeu, 13:29:08)
    18. Nat: Athena is a learning experience; many lessons learned that will be applied going forward; also, new requirements came in late in the development cycle (aimeeu, 13:30:00)
    19. Anwar asks for a review in the next PTL call to determine items that cannot be delivered in Athena (aimeeu, 13:30:37)
    20. The next TSC meeting will be the week of the code freeze, so important for Release Manager to continue moving forward with PTLs (aimeeu, 13:32:45)

  7. PTL reports (aimeeu, 13:34:22)
    1. no PTLs have input at this time (aimeeu, 13:34:57)
    2. Jack reiterates this is the time for PTLs to bring any issues to the TSC (aimeeu, 13:35:40)
    3. Guy Jacobson: Sonar doesn't pick up PowerMockito tests, so how to deal with Sonar not counting tests in its unit test coverage calculation (aimeeu, 13:36:42)
    4. Who is the right person to look into this Sonar issue? (aimeeu, 13:37:13)
    5. Jack asks Chris Lott to track this item so we can discuss who should own this issue (aimeeu, 13:37:38)
    6. ACTION: Chris Lott will track the Sonar/Powermockito issue (aimeeu, 13:38:00)

  8. Test & Integration Planning (aimeeu, 13:38:14)
    1. Chris Lott is standing in for Ken Kristiansen (aimeeu, 13:39:18)
    2. Chris reads out the testing report (aimeeu, 13:39:32)
    3. TLAB test set up is in progress and on target to be completed during Test Sprint 3 (aimeeu, 13:40:31)
    4. code coverage: some components are above 40%, a few remain significantly below (aimeeu, 13:41:06)
    5. Sonar code coverage is not accurate due to the open source code used in Portal (aimeeu, 13:41:40)
    6. Jack asks for follow up with teams who are below the 40% (aimeeu, 13:42:11)
    7. Jacks asks for the list or a link to be sent to the TSC mailing list (aimeeu, 13:42:41)
    8. ACTION: Chris will send the email (aimeeu, 13:42:53)

  9. Community Subcommittee (aimeeu, 13:44:05)
    1. Ofer is on vacation (aimeeu, 13:45:09)

  10. Architecture Subcommittee (aimeeu, 13:45:17)
    1. primarily focusing on B release (aimeeu, 13:45:33)
    2. working with Community committee on Onyx requirements (aimeeu, 13:46:19)
    3. discussions on white box deployment; working with Deployment team on where changes need to be made (aimeeu, 13:46:42)
    4. working on architecture and documentation updates (aimeeu, 13:47:29)
    5. component reviews start this week (aimeeu, 13:47:36)
    6. Bryan created a Jira ticket for white box deployment (aimeeu, 13:48:05)
    7. Anwar: Licensing piece has not yet made it to the Architecture committee (aimeeu, 13:48:27)
    8. Jack emphasizes that licensing needs to be a focus point in Boreas (aimeeu, 13:48:49)
    9. On whitebox support: https://jira.acumos.org/browse/ACUMOS-1640 (bryan_att, 13:48:56)

  11. Security Subcomittee (aimeeu, 13:49:16)
    1. getting ready to start analyzing Nexus IQ reports for platform code (aimeeu, 13:49:40)
    2. will be creating Jira tickets for PTLs to address critical issues (aimeeu, 13:50:01)
    3. model scanning: trying to gather community needs and practices through both Security and Community committees (aimeeu, 13:50:43)

  12. New Agenda Items (aimeeu, 13:51:47)
  13. Training project scope and name change (aimeeu, 13:52:00)
    1. Pantelis agrees to postpone to the next TSC meeting (Pantelis has been on vacation) (aimeeu, 13:52:29)

  14. Planning for next meeting (aimeeu, 13:52:58)
    1. reminder: next meeting is 10 Sept 2018; focus will be dev cycle approaching code freeze (aimeeu, 13:53:29)
    2. discussion will take place on what the release means - branch and trunk management (aimeeu, 13:54:47)
    3. more discussion will take place around Boreas release planning (aimeeu, 13:55:06)
    4. Jack asks everyone to review Boreas timeline for country-specific holidays as well as anything else that could impact the schedule (aimeeu, 13:56:18)

  15. Any other business (aimeeu, 13:56:43)
    1. Jamil (Orange) asks if there will be an Acumos planning event after the release (aimeeu, 13:57:01)
    2. Jack: needs further discussion (aimeeu, 13:57:25)
    3. discussion has been started with LF (aimeeu, 13:57:38)
    4. Scott: Acumos Day is planned for 7 Nov (aimeeu, 13:58:02)
    5. Jack: add discussion around an Acumos face to face event to the 10 Sept TSC agenda (aimeeu, 13:58:43)


Meeting ended at 14:00:34 UTC (full logs).

Action items

  1. aimeeu will send email to TSC list
  2. Chris Lott will track the Sonar/Powermockito issue
  3. Chris will send the email


Action items, by person

  1. aimeeu
    1. aimeeu will send email to TSC list
  2. UNASSIGNED
    1. Chris Lott will track the Sonar/Powermockito issue
    2. Chris will send the email


People present (lines said)

  1. aimeeu (78)
  2. collabot` (3)
  3. bryan_att (1)


Generated by MeetBot 0.1.4.