#acumos-meeting: architecture weekly

Meeting started by farheen at 13:57:46 UTC (full logs).

Meeting summary

  1. Code freeze checklist (Bryan/Manoop) (farheen, 14:04:51)
  2. Design Studio Athena release (Kazi) (farheen, 14:05:37)
    1. Kazi Farooqui reviewed his work in progress DS developer and user guides. Available on #link https://docs.acumos.org/en/latest/submodules/design-studio/docs/developer-guide.html#read-complete-solution-graph-from-nexus (farheen, 14:13:46)
    2. this is a very detailed design studio developer guide includes API. (farheen, 14:14:53)
    3. 0.0.36 version of DS has improved the performance of the cache of the matching models (farheen, 14:17:00)
    4. if there is a delay then inform the user that DS is retrieving matching model. (farheen, 14:17:48)
    5. ACTION: farheen add DS composite solution deployment in future agenda. (farheen, 14:18:34)
    6. The data broker will be in the ds user guide. Yet to be added. (farheen, 14:19:41)
    7. ACTION: Kazi add data broker and probe instructions in the DS user guide. Work with Chris Lott. (farheen, 14:20:42)
    8. ACTION: kazi schedule the data broker and probe next week. (farheen, 14:23:17)
    9. ACTION: kazi concentrate on documenting the data broker and probe and apis. (farheen, 14:25:03)
    10. intial target of this integration is to bring in clean code into acumos repositories. Integrate thos pieces into des (farheen, 14:26:05)
    11. there is no architecture impact in Athena release in DS. (farheen, 14:27:28)
    12. ACTION: Manoop forward CMLP calls to Bryan. For Athena release scan code then allow CMLP to contribute. (farheen, 14:28:10)
    13. however the CMLP discussion and design is starting now but will not be included in the Athena release. (farheen, 14:29:16)

  3. Portal Marketplace review. Used a power point deck. (farheen, 14:31:49)
    1. Mukesh covered the architecture of the approver role and the workflow of a user moving her model from private to public. (farheen, 14:39:58)
    2. ACTION: Mukesh send slides to Manoop and Anwar. Aimee will assist with placing on the wiki. (farheen, 14:45:44)
    3. you touched upon federation and the publisher role. Are you on track with that? (farheen, 14:46:37)
    4. yes it will be in this release. Regarding white box deployment it will be ready for next release. (farheen, 14:47:42)
    5. Bryan we need a goal for message flows documentation. We want this to be automated. (farheen, 14:49:46)
    6. Bryan: I'm not talking about components. When I do an architectural design on key design tool is to understand the flows across the platform. (farheen, 14:50:41)
    7. ACTION: Anwar and Bryan spend time reviewing documentation of message flow documentation. (farheen, 14:52:54)
    8. next week we will go over remaining items. (farheen, 14:53:44)
    9. ACTION: Chris, Guy, and Phillipe prepare to present probe, data broker, CDS, Onboarding, Common Services, Federation and Catalog. (farheen, 14:54:37)

  4. Ofer discussed 9/21/18 face to face meeting. (farheen, 14:56:32)
    1. we are planning a full or half day workshop in Bedminster. We will also broadcast in zoom. (farheen, 14:57:00)
    2. goal is to review the different requirements for the Boreas release and discuss amongst ourselve the scope for the next release. (farheen, 14:57:25)
    3. when can we share a high level agenda? Start working on it tomorrow. (farheen, 14:58:00)
    4. ACTION: Ofer prepare an agenda for the 9/21 meeting. (farheen, 14:58:25)

  5. Code Freeze checklist (farheen, 14:58:42)
    1. bryan prepared it for the deployment project. Will have discussions on questions. (farheen, 14:59:09)
    2. you can mark questions as not applicable if they dont pertain to your project. (farheen, 14:59:36)
    3. be sure to put comments for better communications. (farheen, 14:59:50)
    4. Ken reminded that all critical and high defects have to be closed. (farheen, 15:00:21)
    5. ACTION: Nat can not guarantee that the critical and high defects are going to be closed. It is up to the PTL. (farheen, 15:01:22)
    6. ACTION: Nat bring up the topic specifically on the PTL call. (farheen, 15:01:57)
    7. the request was sent to the PTLs and is waiting for a response. (farheen, 15:02:43)

  6. We have a new component for licensing. PTL will be Michelle. (farheen, 15:03:19)
    1. Ofer tried to contact Michelle on the product call and she is out for the next two weeks. (farheen, 15:03:43)


Meeting ended at 15:04:10 UTC (full logs).

Action items

  1. farheen add DS composite solution deployment in future agenda.
  2. Kazi add data broker and probe instructions in the DS user guide. Work with Chris Lott.
  3. kazi schedule the data broker and probe next week.
  4. kazi concentrate on documenting the data broker and probe and apis.
  5. Manoop forward CMLP calls to Bryan. For Athena release scan code then allow CMLP to contribute.
  6. Mukesh send slides to Manoop and Anwar. Aimee will assist with placing on the wiki.
  7. Anwar and Bryan spend time reviewing documentation of message flow documentation.
  8. Chris, Guy, and Phillipe prepare to present probe, data broker, CDS, Onboarding, Common Services, Federation and Catalog.
  9. Ofer prepare an agenda for the 9/21 meeting.
  10. Nat can not guarantee that the critical and high defects are going to be closed. It is up to the PTL.
  11. Nat bring up the topic specifically on the PTL call.


Action items, by person

  1. farheen
    1. farheen add DS composite solution deployment in future agenda.
  2. UNASSIGNED
    1. Kazi add data broker and probe instructions in the DS user guide. Work with Chris Lott.
    2. kazi schedule the data broker and probe next week.
    3. kazi concentrate on documenting the data broker and probe and apis.
    4. Manoop forward CMLP calls to Bryan. For Athena release scan code then allow CMLP to contribute.
    5. Mukesh send slides to Manoop and Anwar. Aimee will assist with placing on the wiki.
    6. Anwar and Bryan spend time reviewing documentation of message flow documentation.
    7. Chris, Guy, and Phillipe prepare to present probe, data broker, CDS, Onboarding, Common Services, Federation and Catalog.
    8. Ofer prepare an agenda for the 9/21 meeting.
    9. Nat can not guarantee that the critical and high defects are going to be closed. It is up to the PTL.
    10. Nat bring up the topic specifically on the PTL call.


People present (lines said)

  1. farheen (43)
  2. collabot (4)
  3. talasila (0)


Generated by MeetBot 0.1.4.