#acumos-meeting: Acumos Architecture Committee

Meeting started by farheen_att at 14:02:43 UTC (full logs).

Meeting summary

  1. Acumos CMLP Predictor (farheen_att, 14:06:23)
    1. Ryan Hull presenting slides (farheen_att, 14:08:29)
    2. Model Runner does the prediction calls the Model Manager and the manager will download the model and store it. (farheen_att, 14:10:36)
    3. Ryan drawing on Paint white board. (farheen_att, 14:11:46)
    4. bryan: question: It seems like your goal is to have acumos play the role of the lifecycle manager. (farheen_att, 14:12:29)
    5. Not really training. (farheen_att, 14:12:51)
    6. Bryan: production is a better description. (farheen_att, 14:13:05)
    7. bryan: retrieving things from source is not covered by Acumos. (farheen_att, 14:13:49)
    8. bryan: what's covered is building a ms but not to building from source. (farheen_att, 14:14:16)
    9. bryan: model runner stored in nexus in acumos. (farheen_att, 14:14:59)
    10. ryan: is the model trained? (farheen_att, 14:15:38)
    11. anwar: What is the best place to store or integrate? (farheen_att, 14:17:09)
    12. bryan: Provide access to repo and source code and use that as a process of creating a ms in acumos platform. (farheen_att, 14:17:39)
    13. ryan: Model manager pushes and pulls from Nexus. My question is where should we put it? (farheen_att, 14:19:03)
    14. anwar: if he current model manager also takes care of the source code then that is something acumos doesn't provide. (farheen_att, 14:19:30)
    15. ryan: CMLP doesn't store source of the model (farheen_att, 14:20:01)
    16. ryan: Model manager updates a new version of the model and model history primarily used by the model runner. (farheen_att, 14:20:37)
    17. this functionality resides within CMLP so please meet with the team to do a deep dive into model runner. (farheen_att, 14:22:13)
    18. bryan: sounds like to me what you're talking about are things Acumos already does. (farheen_att, 14:23:38)
    19. ryan: yes, that sounds like there is a lot of similarities (farheen_att, 14:25:27)
    20. guy: We support many different types of toolkits. (farheen_att, 14:26:14)
    21. ryan: in the cmlp world there is a one to one relationship between the model runner and the model. (farheen_att, 14:26:48)
    22. mukesh: isn't updating a model training the model? (farheen_att, 14:27:19)
    23. ryan: user gets a key to run the model runner again. (farheen_att, 14:27:44)
    24. mukesh: Does the key update the model? (farheen_att, 14:28:15)
    25. ryan: yes (farheen_att, 14:28:21)
    26. ryan: two different approaches Model Manager and Model Runner (farheen_att, 14:28:46)
    27. ACTION: ryan, bryan, guy and Phillipe get together this week and do a deep dive. What and How (farheen_att, 14:29:40)
    28. bring it back next week so we can review your results. (farheen_att, 14:30:06)

  2. Documentation (farheen_att, 14:30:30)
    1. bryan presenting docs.acumos.org: No open reviews to the documentation project. (farheen_att, 14:31:07)
    2. bryan: looking for commits. (farheen_att, 14:31:16)
    3. I have updated diagrams from the wiki. The scope is adequate. (farheen_att, 14:31:57)
    4. bryan: We need descriptions of the E interfaces from the PTLs. (farheen_att, 14:33:10)
    5. ACTION: bryan will take the lead on getting the gaps filled in (farheen_att, 14:37:13)

  3. Licensing (farheen_att, 14:37:39)
    1. michelle presenting model licensing slide. (farheen_att, 14:38:20)
    2. License Artifact responsibility falls into the data scientist and data analyst. (farheen_att, 14:39:10)
    3. All of the user personas we have identified will be using License Tracking. (farheen_att, 14:39:43)
    4. We need a way to gather tracking information and then (farheen_att, 14:40:16)
    5. report on it through metrics and analytics. (farheen_att, 14:40:39)
    6. We've identified the user personas and the key actions. Now we have to trace it through and who. (farheen_att, 14:41:44)
    7. ACTION: we need to put a team together for the 18 features because we will be getting started with the boreas work. (farheen_att, 14:43:05)
    8. michelle we have been talking with deployment and training. (farheen_att, 14:44:21)
    9. anwar: Portal will be central to ux/ui. Although I suggest we develop the ux outside of the development team. (farheen_att, 14:45:02)
    10. question: Does the model tracker receive information? (farheen_att, 14:46:09)
    11. we are not going to be policing but we are reporting on the use of the models. (farheen_att, 14:46:24)
    12. we are not proposing to take action. (farheen_att, 14:46:33)
    13. anand: take the burden off the user to maintain the licenses. (farheen_att, 14:47:40)
    14. AT&T will have Ericsson on site for next week on 17th 9AM morning have the TSC memebers join. (farheen_att, 14:49:49)
    15. ACTION: if you are interested cotact Larry Uno morning 9AM October 17 with Ericsson at AT&T Bedminster location. (farheen_att, 14:50:28)

  4. Roundtable (farheen_att, 14:51:24)
    1. bryan: Kubeflow has 1/10th of the developers on the project and if acumos was supporting kubeflow it may give us an opportunity bring technology to this project. (farheen_att, 14:52:11)
    2. anwar: I agree if we join hands with them it will but acumos in high gear. (farheen_att, 14:52:35)
    3. hopefully something good will come out of the partnership with Kubeflow. (farheen_att, 14:52:57)
    4. Chris Lott: Kubeflow seems to do the deployment and training. (farheen_att, 14:54:37)
    5. farheen: acumos needs in the model building aspect. (farheen_att, 14:57:05)
    6. : guy: kubeflow is good for compound deployments. (farheen_att, 14:57:29)
    7. kazi: It is purely a deployment tool. (farheen_att, 14:58:24)
    8. kazi: They are deploying all components from data ingestion to output of the ML model. (farheen_att, 14:59:09)
    9. The output of our DS would be feeding into their deployment engine. (farheen_att, 14:59:25)
    10. michelle: I liked that he was interested in data rights management. I liked that there was somebody interested in license management. (farheen_att, 15:02:06)

  5. Release (farheen_att, 15:02:35)
    1. one critical defect in an open state. Bryan is looking into it. (farheen_att, 15:03:54)

  6. Major things due (farheen_att, 15:05:15)
    1. make sure the documentation and athena is fully tested. (farheen_att, 15:05:29)


Meeting ended at 15:05:33 UTC (full logs).

Action items

  1. ryan, bryan, guy and Phillipe get together this week and do a deep dive. What and How
  2. bryan will take the lead on getting the gaps filled in
  3. we need to put a team together for the 18 features because we will be getting started with the boreas work.
  4. if you are interested cotact Larry Uno morning 9AM October 17 with Ericsson at AT&T Bedminster location.


People present (lines said)

  1. farheen_att (69)
  2. collabot (3)


Generated by MeetBot 0.1.4.