#acumos-meeting: Architecture Committee

Meeting started by farheen_att at 14:02:37 UTC (full logs).

Meeting summary

  1. Athena architecture - Anwar (farheen_att, 14:03:24)
    1. Portal components: Mukesh in design and architecture where are we? (farheen_att, 14:05:11)
    2. Mukesh: All design and architecture are complete. There are two issues. Search and Theme pop up will be delivered in the Athena maintenance release. (farheen_att, 14:06:42)
    3. We had a discussion with test team and Mukesh the plan is to go with the current build that the test team has agreed to continue to work on the two issues and put it as a possible plan for the athena release. (farheen_att, 14:08:37)
    4. Ken: We want all of the components to be in release form. (farheen_att, 14:09:47)
    5. Ken: we have the staging ready to go but are waiting for one components. (farheen_att, 14:10:21)
    6. Ken: We want a code drop with only the theme or the theme and the search. Keep them separate. (farheen_att, 14:20:10)
    7. ACTION: : Ken get on a call with Mukesh. (farheen_att, 14:21:19)
    8. Anwar: We have to get better at our test release process. (farheen_att, 14:21:37)
    9. Having one build per fix is going to slow down everything. (farheen_att, 14:21:51)
    10. ACTION: Anwar: Take the triage of CI/CD process offline with Ken and Mukesh. (farheen_att, 14:22:44)
    11. Mukesh: Scoped 43 user stories tied to the epics. The initial step has been made. 20% on the design part. (farheen_att, 14:23:44)
    12. Phillippe: From my point of view for Athena release is 100% complete. Documentation change has been made. (farheen_att, 14:24:26)
    13. Anwar: For Boreas release? (farheen_att, 14:24:46)
    14. Phillippe: Working on Onboarding user stories. Code coverage. First feasibility of first release of boreas then how to enrich the code coverage. (farheen_att, 14:25:55)
    15. Anwar: So what percentage of design? (farheen_att, 14:26:13)
    16. Phillippe: Architecture and design for Boreas is 10% for the moment. (farheen_att, 14:27:02)
    17. : Anwar: other than onnyx what is onboarding team looking at? (farheen_att, 14:27:17)
    18. Phillippe: Possible to onboard a model that has already been saved. Data scientist creates and saves a model. We study the possibility to onboard a model directly into acumos (farheen_att, 14:28:33)
    19. : CDS: Chris Lott. I can't speak to the score card. Boreas we have 10 user stories defined and more to come. (farheen_att, 14:29:23)
    20. Chris I don't see any new changes. We'll be using the CRUD operations. (farheen_att, 14:29:54)
    21. Anwar: Chris what is the name of your component? Catalog Data Model. (farheen_att, 14:31:13)
    22. Chris: A restricted federation feature will be done in Boreas. (farheen_att, 14:31:30)
    23. Anwar: Federation training is coming in Boreas. (farheen_att, 14:31:59)
    24. Chris: 10% for portal. (farheen_att, 14:32:43)
    25. Training: Pantellis: Architectural design is 0%. I was hoping we would be able to get together the second meeting in November? (farheen_att, 14:34:17)
    26. ACTION: Anwar a need to set up a lockdown for training. (farheen_att, 14:35:43)
    27. Definitely all the PTLs will be required. (farheen_att, 14:36:37)
    28. ACTION: Ofer targeting for second week of November. Have a one day and possibly two. (farheen_att, 14:37:14)
    29. What would be the environment for the development of the pipeline? (farheen_att, 14:38:23)
    30. How will approach? (farheen_att, 14:38:36)
    31. Bryan: Scope out the specs and make a suggestion to the community. (farheen_att, 14:38:59)
    32. ACTION: Pantellis come up with a proposal for how we are going to use an environment. (farheen_att, 14:40:03)
    33. We want to make sure that the CMLP seed code is included in the training user stories. (farheen_att, 14:40:34)
    34. ACTION: Kazi between 12 and 13 set up a call with CMLP. (farheen_att, 14:42:54)
    35. Bryan system integration. Whatever gets done by Saturday night will be in the release. For Boreas nothing has been created user stories. (farheen_att, 14:43:31)
    36. for deployment we have 10% (farheen_att, 14:47:57)
    37. https://wiki.acumos.org/display/AR/Architecture+Reviews+Score+Card (farheen_att, 14:48:12)
    38. Design Studio: Athena: we are complete. No open items. Documentation has been completed. For Boreas we are working on mulitple fronts now. 1. Jupyter and CMLP with acumos. 2. how the pipelines and training projects will effect DS. (farheen_att, 14:49:24)
    39. Kazi: There will be a need for more discussion involving more people. (farheen_att, 14:49:53)
    40. : We are talking about integrating the CMLP Rapid Miner with it's training components. We want to identify what is the impact of training on DS. (farheen_att, 14:51:00)
    41. Adi: There is some work around the pipeline we had one session and we have to do more. (farheen_att, 14:51:18)
    42. Kazi: 10% from DS. (farheen_att, 14:52:06)
    43. Guy: We have a lot of things planned such as supporting NXP types of builds for other architectures. We are 10% done with creating user stories. (farheen_att, 14:52:46)
    44. there is a lot of work for supporting onnyx. last one is enriching and standardizing the client libraries model runner uniformity. (farheen_att, 14:53:26)
    45. want the model runner to offer a heartbeat service are you alive at a standard location. To give the meta data protobuf descriptions of the services they offer. We want them to have a standard swagger description. (farheen_att, 14:54:33)
    46. challenge is meeting with the stake holders and composition and deployment teams. (farheen_att, 14:55:13)
    47. license: Michelle we've gathere requirements and high level apis. We have drafted picture for that. (farheen_att, 14:55:54)
    48. we have to put together user stories. (farheen_att, 14:56:30)
    49. Anwar: Have close working partners can validate that license feature supports their needs and look to them to contribute. (farheen_att, 14:57:33)
    50. is there seed code? We are going to recommend some open source licensing processes that we can propose. (farheen_att, 14:58:48)
    51. Anwar: in summary we are going take 5 minutes to go through this score card. I want to utilize the time of this call for discussions. (farheen_att, 14:59:59)
    52. Pantellis: I am concerned about rapid miner on this project. It is not open source. Why are we referring to it. I also see table white box deployment. Is there a spec for the white box? (farheen_att, 15:00:50)
    53. Anwar: White box refers to your plain vanilla servers that run Linux and don't use the std. intel chip. The whole idea is to use these rather than commodity. Had a meeting with a vendor called NXV and their arm white boxes that can be used on the edge and easily managable scalable. (farheen_att, 15:02:17)
    54. more details when we meet for the lockdown. (farheen_att, 15:02:51)
    55. What about rapid miner? There is a github project for that. They GNU Afero license. That is a big concern. You can't put a GNU license for acumos. (farheen_att, 15:04:17)
    56. ACTION: Kazi check with Scott if we can use rapid miner and discuss with Adi. (farheen_att, 15:05:33)


Meeting ended at 15:05:38 UTC (full logs).

Action items

  1. : Ken get on a call with Mukesh.
  2. Anwar: Take the triage of CI/CD process offline with Ken and Mukesh.
  3. Anwar a need to set up a lockdown for training.
  4. Ofer targeting for second week of November. Have a one day and possibly two.
  5. Pantellis come up with a proposal for how we are going to use an environment.
  6. Kazi between 12 and 13 set up a call with CMLP.
  7. Kazi check with Scott if we can use rapid miner and discuss with Adi.


People present (lines said)

  1. farheen_att (59)
  2. collabot` (3)


Generated by MeetBot 0.1.4.