#acumos-meeting: Architecture Committee weekly

Meeting started by farheen_att at 14:56:22 UTC (full logs).

Meeting summary

  1. How to get approvals for the overall design and use cases. (farheen_att, 15:09:10)
    1. Anwar: By the API freeze date we need to have the design and architecture reviewed and agreed on. (farheen_att, 15:09:48)
    2. that is the overall timeline and what is our API freeze data? Nat: Jan 28 ending on Feb 1. (farheen_att, 15:10:18)
    3. so the first sprint starts feb first? Dev sprint starts jan 27. Manoop: Let me clarify one point. Per our plan starting 12/15 we have dev sprints starting. team has already started let them continue and then deliver. (farheen_att, 15:11:54)
    4. https://wiki.acumos.org/display/REL/Boreas+Release+Timeline (farheen_att, 15:13:27)
    5. discussion on themes, epics, user stories and storyboards. Storyboards are what we hand off to the wireframing team. (farheen_att, 15:27:34)
    6. Mukesh took care of the themes and what about the searches? (farheen_att, 15:28:00)
    7. Mukesh will discuss search on Monday. (farheen_att, 15:28:17)
    8. Phillippe: Documentation has been completed. ONNX, Code Coverage, Docker image on-boarding. (farheen_att, 15:29:58)
    9. Portal Epics/US created (44) (farheen_att, 15:30:57)
    10. Catalog Chris has 12 user stories. (farheen_att, 15:36:46)
    11. the goal for Monday is to come up with the pipelines. (Pantellis) (farheen_att, 15:37:19)
    12. We have a prioritized list of themes. These themes require story boards. (farheen_att, 15:45:50)
    13. Anwar: 18 items that were prioritized during lock down are the ones we want to address. (farheen_att, 15:46:48)
    14. Kazi: Pipelines work is opening the Pandoras box. There are many pipelines like Niffy. Niffy does not support Kubeflow. These are the types of tools we want to review on our Architecture meeting with Reuben, Jack. (farheen_att, 15:48:58)
    15. Anwar: There are many open pipelines we can use these first. (farheen_att, 15:50:21)
    16. Pantellis: We should design the open tools into pipelines. (farheen_att, 15:51:26)
    17. Kazi: We still have some choices to make. We will get most of that flushed out on Monday. (farheen_att, 15:51:54)
    18. Common Services NXP/ARM onboarding, ONNX, Client Lib Model runner are being designed now. Leave the numbers the same. Leaving off on training until we speak to Pantellis. (farheen_att, 15:54:50)
    19. planning for lockdown. For other components, portal, model onboarding. For other components do we have other items? (farheen_att, 15:55:59)
    20. : Phillippe would like to discuss onboarding first because he will be available for the first 2 hours of the meeting. (farheen_att, 15:56:40)
    21. ACTION: Ofer schedule Philippe first. (farheen_att, 15:57:15)
    22. Phillippe uploading of ONNX model and impact of training on onboarding project. (farheen_att, 15:59:01)
    23. What is our plan for PFA and PMML enhancements for Boreas? PMML is under GPL license so we can't integrate. And I have not looked into PFA. (farheen_att, 16:00:36)
    24. where are the slides from Acumos day? wiki.acumos.org/events (farheen_att, 16:01:49)


Meeting ended at 16:01:55 UTC (full logs).

Action items

  1. Ofer schedule Philippe first.


People present (lines said)

  1. farheen_att (27)
  2. collabot` (3)


Generated by MeetBot 0.1.4.