#acumos-meeting: Architecture Committee

Meeting started by farheen_att at 15:02:50 UTC (full logs).

Meeting summary

  1. CMLP Project and Repo Needs (Adi/Karthik) (farheen_att, 15:06:16)
    1. no representation will revisit (farheen_att, 15:09:03)

  2. Portal Scrorecard for Boreas release (farheen_att, 15:09:30)
    1. Epics/US created (43) Epics/US created 65% complete (farheen_att, 15:10:21)
    2. Epics address most of the Themes (farheen_att, 15:10:43)

  3. Model onboarding score card (farheen_att, 15:11:18)
    1. Guy: We presented on Monday the epics and user stories. I don't know if they're entered in jira yet but we've discussed in great detail. The document exists in the wiki and many are entered in jira (farheen_att, 15:12:26)
    2. ACTION: Farheen follow up with Phillippe about onboarding progress (farheen_att, 15:13:07)

  4. CDS Scorecard (farheen_att, 15:13:25)
    1. Chris: for Federation I have not seen major issues (farheen_att, 15:15:49)
    2. Chris I have 15 US. (farheen_att, 15:16:06)

  5. Training (farheen_att, 15:16:45)
    1. ACTION: Farheen follow up with Pantellis on scorecard update. (farheen_att, 15:17:11)

  6. Design Studio (farheen_att, 15:17:31)
    1. Kazi: There is a gap because Adi has been away. (farheen_att, 15:17:49)
    2. ACTION: Kazi reach out to Michelle to ask for a backup for Adi. (farheen_att, 15:18:13)
    3. Don't wait on Adi to return on 12/3 instead continue to make progress with Adi's backup. (farheen_att, 15:19:30)
    4. Kazi: I'm working on kubeflow but the workbench is Adi's. (farheen_att, 15:20:07)
    5. Manoop: We asked Adi to document a new workbench project with LF. (farheen_att, 15:20:49)
    6. Kazi: For juypyter we have completed the architecture. (farheen_att, 15:21:22)
    7. Manoop: Adi has not started this project request. (farheen_att, 15:21:50)
    8. Manoop: Kazi is it possible to share your architecture in the mailing list? (farheen_att, 15:23:22)
    9. ACTION: Kazi link to the architecture diagram. (farheen_att, 15:24:01)

  7. Deployment (farheen_att, 15:24:31)
    1. Bryan: The release is scoped and I have to organize the jira items a little more. (farheen_att, 15:25:13)
    2. Does this list capture the main items for Boreas release deployment? (farheen_att, 15:25:37)
    3. https://wiki.acumos.org/display/AR/Architecture+Reviews+Score+Card (farheen_att, 15:27:02)
    4. Can you do an initial review of your Boreas design and architecture? (farheen_att, 15:27:28)
    5. ACTION: Bryan present on 11/29 (farheen_att, 15:28:37)

  8. Security (farheen_att, 15:28:51)
    1. no progress but starting and Acumos/ONAP dialogue. (farheen_att, 15:29:08)
    2. Anwar: As a side note for Nat and Ofer we have to do tshirt sizing of low, medium, high (farheen_att, 15:29:40)
    3. we also have to distribute assign the themes to the development teams through release management (farheen_att, 15:30:32)
    4. ACTION: Nat Assign the themes to the development team. (farheen_att, 15:31:36)
    5. ACTION: Guy ask NXP to participate on the deployment calls. (farheen_att, 15:32:27)
    6. Guy has been working on how to deploy to their white boxes. We don't need them but they should be aware. (farheen_att, 15:32:55)
    7. ACTION: Guy start attending the Security calls with NXV. (farheen_att, 15:33:31)
    8. Bryan: The deployment process needs their collaboration. (farheen_att, 15:33:49)
    9. ACTION: Bryan forward your invitation to Lusheng and NXP (farheen_att, 15:34:14)

  9. Common Services (farheen_att, 15:34:23)
    1. Guy: We have all of our us and epics on the wiki page some in jira and some not. (farheen_att, 15:34:58)
    2. the other element is starting to get the model runner and client libraries together to harmonize. paul has a prototype that satisfies java and R as well. There will be more tasks and user stories. People involved would be me, Paul, Simon, and offshore team. (farheen_att, 15:36:19)
    3. Bryan: security verification for common services. Security is an over arching advisory group in TSC they don't do the work directly they work with projects to get things done and track it's progress. (farheen_att, 15:37:35)
    4. Bryan Security related work will be tracked inside the project. (farheen_att, 15:38:07)

  10. License Management (farheen_att, 15:38:17)
    1. Michelle: We're at about 40%. We are going to start putting our use cases into jira. (farheen_att, 15:38:38)
    2. ACTION: Michelle present License Management architecture on 11/29. (farheen_att, 15:39:26)

  11. Mukesh - Portal architecture (farheen_att, 15:39:54)
    1. Phillippe: We are at 20% perhaps we can add a PFA to check license compliance. (farheen_att, 15:40:34)
    2. Phillippe: Pytorch and Cafe will be through ONNYX. (farheen_att, 15:40:56)
    3. Phillippe: We didn't plan to develop pytorch and cafe client. (farheen_att, 15:41:18)
    4. ACTION: Mukesh add the architecture deck to the product architecture wiki (farheen_att, 15:56:29)


Meeting ended at 15:56:50 UTC (full logs).

Action items

  1. Farheen follow up with Phillippe about onboarding progress
  2. Farheen follow up with Pantellis on scorecard update.
  3. Kazi reach out to Michelle to ask for a backup for Adi.
  4. Kazi link to the architecture diagram.
  5. Bryan present on 11/29
  6. Nat Assign the themes to the development team.
  7. Guy ask NXP to participate on the deployment calls.
  8. Guy start attending the Security calls with NXV.
  9. Bryan forward your invitation to Lusheng and NXP
  10. Michelle present License Management architecture on 11/29.
  11. Mukesh add the architecture deck to the product architecture wiki


People present (lines said)

  1. farheen_att (54)
  2. collabot` (3)


Generated by MeetBot 0.1.4.