#acumos-meeting: Architecture Committee weekly

Meeting started by farheen_att at 15:05:38 UTC (full logs).

Meeting summary

    1. Michelle for Licensing and Bryan for Deployment (farheen_att, 15:06:12)
    2. Michelle Martens reviewed architecture diagram. (farheen_att, 15:10:06)
    3. Find the latest deck on the License management wiki page. (farheen_att, 15:10:59)
    4. One of the recommendations from Orange was to re-use ISO standards 19772-3 as licensing artifacts. The license artifact is the license terms and agreements for using the model. When they publish their model to the catalog they will attach a license artifact. That artifact states how you can use that model. That contains a subset of fields in ONAP. We will go through the license management artifact that the pu (farheen_att, 15:13:15)
    5. In the security verification workflow there are different checkpoints that check points call out to the license manager before we move on to the next step. The license manager will verify all relevant systems to check for entitlements. It will do all the decision making on the license facts. (farheen_att, 15:14:48)
    6. should license be bundled inside the platform our outside the platform? Issues arise: If it's external the users of the model can combine and have one inventory application. Example. Using ONAP they can combine VNF + model entitlements. However if it's internal we have a package license solution. We are still discussing. (farheen_att, 15:16:34)
    7. Other types of Boreas release. Different types of entitlements. We are starting with one type of license entitlement. But suppliers said they want to see some limited entitlements in the boreas release. At least track entitlements. (farheen_att, 15:18:06)
    8. We have gotten feedback from Hwawei and Ericsson but not... (farheen_att, 15:18:45)
    9. ACTION: Michelle reach out to Pantellis (farheen_att, 15:18:56)
    10. when you spin up VNF software you have to enter a key. That has been expressed by Hwawei and Ericsson to provide keys. There are a variety of tracking. It's a matter of what we can deliver within a release. (farheen_att, 15:19:59)
    11. Security Verification Workflow: Key impact to publishing and federation. The license artifact should be federated along with the model. (farheen_att, 15:20:40)
    12. Work Items and issues: Loading up the license entitlement inventory system has to be set up represent the actual model and the second step is to load up the reference or key identifiers and load up the actual entitlement of the model you are going to use. The process has to be worked out. There are APIs but we have to figure out what those steps are. We feel we want to load up the entitlements or placeholders f (farheen_att, 15:22:25)
    13. Anwar: What other major components have impacts in the Boreas release? (farheen_att, 15:22:47)
    14. ACTION: Michelle contact interfacing PTLs with requirements. (farheen_att, 15:23:27)
    15. download, deploy, and federate. I took the Mukesh's diagram and overlaid licensing component. see slide (farheen_att, 15:24:47)
    16. Michelle: Publishing, Downloading, Deploying, and Federation (farheen_att, 15:26:45)
    17. Guy: During onboarding time we can build in a tool to onboard the model with the license. (farheen_att, 15:27:18)
    18. Bryan: We should give them an option. (farheen_att, 15:27:32)
    19. Guy: Microservice creation. If you want to enforce license at run time talk to Guy Jacobson. (farheen_att, 15:28:48)
    20. Bryan: Yes, there are a variety of licensing features. (farheen_att, 15:29:15)
    21. Guy: Someone has to build the code. (farheen_att, 15:29:32)
    22. Michelle: If you look at the user story a license manager is going to go in and check that the entitlement exists in the microservice. (farheen_att, 15:30:29)
    23. Guy: It can also be done during the run time itself. If you want to do additional licensing restrictions then you can do that during run time itself. (farheen_att, 15:31:11)
    24. Guy: We don't have java run times in all of our code. They vary alot. The most useful is to write something into a binary to make a decision to proceed or not. That is something that needs to be implemented. (farheen_att, 15:32:11)
    25. https://wiki.acumos.org/display/LM/Release+Planning (farheen_att, 15:32:37)
    26. Bryan: There is likely something that can be built into the ms. (farheen_att, 15:33:14)
    27. ACTION: Michelle: work with onboardind, Chris Lott for CDS, and deployment. (farheen_att, 15:33:50)
    28. Anwar: In light of the use case. Once we have a model identified it is better to make this use case as an example. (farheen_att, 15:34:27)

  1. Bryan Security (farheen_att, 15:34:46)
    1. We've been having discussions around do we have to do level indication or not. There have been red face issues. We have resource issues. The existing approach is deployable and secure enough but people are insisting on user level authentication. (farheen_att, 15:37:00)
    2. Bryan: not an option (farheen_att, 15:37:09)
    3. diagree download is traceable. (farheen_att, 15:38:10)
    4. Bryan: There will be user level authentication. (farheen_att, 15:39:14)
    5. Bryan: Heads up K8 will be a part of deployment. (farheen_att, 15:40:22)
    6. Bryan: we talked about logging. We need to put on the architecture table. We need to bring in a portal plugin framework. We have a very tightly coupled and we need to move away from restful into a message bus asynchronous piece. If I want to bring in a new componkrkent I can't do it without massive disruption to the other components. CMLP suggested looking into Omni framewor (farheen_att, 15:42:42)
    7. ACTION: Mukesh review Omni-framework (farheen_att, 15:43:15)
    8. Bryan: you can use restful apis across message bus. (farheen_att, 15:43:48)
    9. ACTION: Bryan: Come up with what components be effected by message bus architecture. (farheen_att, 15:44:24)
    10. Bryan: Most difficult part will be migrating away from synchronous. (farheen_att, 15:44:54)
    11. Can we put in an architectural change for logging? (farheen_att, 15:46:38)
    12. ACTION: Ken put a jira item for logging issue (farheen_att, 15:47:00)
    13. Is message bus effect the overall platform or can it be done over time? It can be done over time. Will the data be persistent? Everything on the message bus gets logged. (farheen_att, 15:48:08)
    14. Bryan: I am working on the kubeflow and it's impact for deployment. Right now we have 3 different approaches for deployment. Whatever we have to do with NXV and kubeflow everything is aligning under kubernetes. While we will continue to support openstack and azure, we're not going to take it forward. Kubeflow are pipelines for kubernetes. It's looking like a abstracted (farheen_att, 15:51:09)

  2. Review of progress (farheen_att, 15:51:47)
    1. Mukesh: I started on high level design around security validation and CDS changes. (farheen_att, 15:52:47)
    2. ACTION: Mukesh look into omni frame work we are talking about. (farheen_att, 15:53:01)
    3. Nat: Mukesh have you started looking into training. (farheen_att, 15:53:21)
    4. two major things are training and licensing. (farheen_att, 15:53:45)
    5. model onboarding. We are not planning to create Pytorch and Cafe. We have to show some use case models that are pytorch and cafe. (farheen_att, 15:54:40)
    6. worked with licensing team regarding onboarding a model. We will also work ask the user if they want to create a microservice. We also have some work on the user experience. Regarding the epics and user stories look at the matrix. (farheen_att, 15:55:58)
    7. We have completed 30% (farheen_att, 15:56:11)
    8. Chris L. Improvements to page loading. Architecture and design work is 20%. (farheen_att, 15:58:18)
    9. ACTION: Pantellis update your percentage on the architecture community score care. (farheen_att, 15:59:03)
    10. ACTION: Gaurav prepare a presentation of workflow architecture. (farheen_att, 16:03:50)
    11. ACTION: Nat ML workbench needs TSC approval. Adi brought it up and wanted to work with Kazi to write it up in a wiki page. (farheen_att, 16:04:45)


Meeting ended at 16:06:54 UTC (full logs).

Action items

  1. Michelle reach out to Pantellis
  2. Michelle contact interfacing PTLs with requirements.
  3. Michelle: work with onboardind, Chris Lott for CDS, and deployment.
  4. Mukesh review Omni-framework
  5. Bryan: Come up with what components be effected by message bus architecture.
  6. Ken put a jira item for logging issue
  7. Mukesh look into omni frame work we are talking about.
  8. Pantellis update your percentage on the architecture community score care.
  9. Gaurav prepare a presentation of workflow architecture.
  10. Nat ML workbench needs TSC approval. Adi brought it up and wanted to work with Kazi to write it up in a wiki page.


People present (lines said)

  1. farheen_att (57)
  2. collabot` (3)


Generated by MeetBot 0.1.4.