#acumos-meeting: Architecture Committee

Meeting started by farheen_att at 15:04:11 UTC (full logs).

Meeting summary

  1. Onboarding (farheen_att, 15:05:23)
    1. Philippe: I modified the architecture diagram for Athena release with the objective that we want to add to Boreas. (farheen_att, 15:07:16)
    2. for a pre-dockerized model user option to onboard an pre-dockerized model. (farheen_att, 15:07:39)
    3. we want to give them ONNX and TSX formats. (farheen_att, 15:07:52)
    4. Philippe: We offer both CLI and web onboarding. On the first page is not like the legacy onboarding. We create an artifact starting with nexus and at the end we will ask the user if he wants to create the MS from it. IF yes, it will trigger the microservice generation. The complexity is not finished. I will ask the question to the user to trigger the microservice generation. (farheen_att, 15:09:24)
    5. Philippe: I will allow the user to onboard the ONNX and TSX. (farheen_att, 15:09:50)
    6. Adi: It would be good to work with you on PFA. Do you have a concept of plugability or very tightly coupled with Acumos? (farheen_att, 15:10:25)
    7. Adi: I left it open but let me share plugability: 1. Microservices. 2.Omni or web component. Is this a part of the view? (farheen_att, 15:11:12)
    8. Philippe: First we plan to onboard the model without treating protobuf. (farheen_att, 15:11:41)
    9. Adi: So it's more like and application instead of a service right now? (farheen_att, 15:11:56)
    10. Manoop: What is an AT&T framework. Just this week we had a session where people started using Omni. We don't have a choice within CMLP it is a front end standard. (farheen_att, 15:13:16)
    11. Jason: It is bringing the ability to plug components together in a single UI or with other plug-able micro-UIs. (farheen_att, 15:13:58)
    12. Bryan: That sounds like a fundamental architecture. Sounds like openstack plug and play. Yes. (farheen_att, 15:14:33)
    13. Bryan: I sent last week to the list a more flexible way to plug. (farheen_att, 15:15:12)
    14. Manoop: We want to de-couple the portal front end presentation. (farheen_att, 15:15:36)
    15. Bryan: There is a lot of backend that is point to point and hard wired today. (farheen_att, 15:15:51)
    16. Manoop: Yes, getting there in one night is a huge impact. (farheen_att, 15:16:05)
    17. Bryan: First we have to understand and agree that we want to discuss. (farheen_att, 15:16:22)
    18. Manoop: Yes, we asked the teams to review their architecture with community. (farheen_att, 15:16:54)
    19. Manoop: To start understanding we have to ask about Omni. (farheen_att, 15:17:16)
    20. Adi: It is not AT&T except for a few customizations. (farheen_att, 15:18:00)
    21. Manoop: Are there other open source tools that can solve this problem. (farheen_att, 15:18:30)
    22. Mukesh: Bryan is talking about some customization such as CSP. (farheen_att, 15:18:53)
    23. Manoop: Mukesh this will be a disruptive change. We have seen pros using Omni in building UIs in isolation instead on one component. (farheen_att, 15:19:34)
    24. Manoop: I can pull in resources to align with you. (farheen_att, 15:19:48)
    25. ACTION: Manoop take the omni topic to the portal meetings. (farheen_att, 15:20:12)
    26. Manoop: Who will be experts using Omni? (farheen_att, 15:20:24)
    27. Adi: Yes, we have a few. (farheen_att, 15:20:34)
    28. ACTION: Adi send Manoop the names of Yusen Istoc and Jason Tadros. (farheen_att, 15:21:08)
    29. ACTION: Bryan set up a call with Adi for a deep dive. (farheen_att, 15:21:27)
    30. Manoop: Regarding onboarding we don't have license artifact. (farheen_att, 15:21:59)
    31. Philippe: Yes, we will give the opportunity to the user to onboard a license along with the model. (farheen_att, 15:22:17)
    32. Bryan: All we need to do is give advice to the people who build the docker images what to place where. (farheen_att, 15:22:38)
    33. Michelle: Yes, it would be a separate artifact. (farheen_att, 15:22:52)
    34. Bryan: I was talking about the license being a part of the docker itself. (farheen_att, 15:23:07)
    35. Philippe: I spoke about the external license. From my point of user will have an option to onboard a model that has already been licensed. I think a lot of models will not have models. (farheen_att, 15:23:57)
    36. Bryan: It is clear as an artifact. We will have a security verification. (farheen_att, 15:24:31)
    37. Bryan: I am referring to the structure of the docker image when it's built. (farheen_att, 15:25:06)
    38. Guy: We will feature model runner that will deliver protobuf and meta-data and we can include the license along with the protobuf. (farheen_att, 15:25:56)
    39. Jason: Where would you see PFA as a part of this flow. (farheen_att, 15:26:34)
    40. Guy: In terms of delivering run time for PFA and ONNX I will get to that as a part of MS generation. (farheen_att, 15:26:57)
    41. Guy: We will let people write whatever they want and let them use this process here. (farheen_att, 15:27:21)
    42. Jason: We have a target of standardizing the portable format. (farheen_att, 15:27:44)
    43. Jason: we can do conversions with avaro. (farheen_att, 15:28:27)
    44. ACTION: Philippe: I will add the license artifact and the question to the user if they want to add a license. (farheen_att, 15:29:14)
    45. Manoop: Do you have the impacted component? What is your requirement and what you need from them? (farheen_att, 15:29:37)
    46. Yes, I tried to list in the Onboarding process in the wiki. (farheen_att, 15:30:01)
    47. Philippe: I will be talking to onboarding and Chris for CDS and regarding Documentation I have been writing. (farheen_att, 15:30:46)
    48. Philippe: There is not reliance on DS. (farheen_att, 15:31:36)
    49. Bryan: Do we document how the dockers are created? (farheen_att, 15:31:54)
    50. Guy: We should allow them to upload protobuf. (farheen_att, 15:32:44)
    51. Guy: We have a system called Argus so that people can find it but it doesn't fit our ms model. (farheen_att, 15:33:19)
    52. Guy: We should think about adding these extra artifacts by hand. Crafting the protobuf file is not that hard. Reuben: Many are not ms but will be running in a cloud somewhere and we have to be able to make a psuedo-ms. (farheen_att, 15:34:30)
    53. Reuben: We cant assume that everything is going to be onboarded as source and shrink wrapped. (farheen_att, 15:35:00)
    54. Bryan: We should allow them the opportunity to upload protobuf. We need to understand why we are enabling to onboard things other than MS design models. (farheen_att, 15:36:21)
    55. Bryan: I propose if a model proto and meta-data is present then we should create a tgix file for DS. (farheen_att, 15:36:57)
    56. Guy: Let's say you have something written in C++ but can create your own docker image. If people are willing to do that then they could construct a valid ms along with protobuf and metadata file to get them all into the system. (farheen_att, 15:38:29)
    57. Guy: You should be able to manually do what we've automated. We also don't support multi-language models. We could use the existing Python models runner and do your docker build. You'd have your docker and protobuf file and you could get them all together and upload them. You would have to understand the internals. (farheen_att, 15:40:01)
    58. Reuben: Since everything we're doing is in sourcecode it can be done in ant. There is no documentation explaining that. (farheen_att, 15:40:35)
    59. ACTION: Philippe: Include onboarding. (farheen_att, 15:40:54)
    60. Manoop: Why would DS not be impacted? We should have a bigger plan of how to address. (farheen_att, 15:41:21)
    61. Guy: MS generation has a significant impacts to DS. (farheen_att, 15:42:48)
    62. Manoop: We have to get down to what is aligned with themes. (farheen_att, 15:43:24)

  2. Log Standards (farheen_att, 15:44:46)
    1. Parichay: We will not be generating 4 logs instead we will be generating one log file. (farheen_att, 15:50:55)
    2. ACTION: Kazi: Provide question through devdiscuss email list. (farheen_att, 15:51:30)
    3. Parichay: Earlier there were 30 fields and reduced it to these. (farheen_att, 15:55:47)
    4. ACTION: Mukesh: Take the discussion around log standards to the devdiscuss. (farheen_att, 15:56:06)
    5. https://wiki.acumos.org/display/OAM/Acumos+Log+Standards (farheen_att, 15:57:09)
    6. ACTION: Chris I will reach out to Parichay. (farheen_att, 15:57:42)

  3. Release Management Ofer (farheen_att, 15:58:02)
    1. Sharing the 85 epic list. (farheen_att, 15:58:21)
    2. Nat: Ofer will lay out the community meeting. The community went over all the requirements and give their commitment. If the epics are marked as high they are committed. These 88 epics need to be prioritized and aligned with the teams. (farheen_att, 15:59:50)
    3. Ofer: We are trying to get commitments although not M1 we want to get the TSC approval. My understanding is out of these 88 there are only 40 mapped to the themes. The top 6 are already in a high rank and all of these themes are listed out according to priority. (farheen_att, 16:01:39)
    4. Manoop: If PTLs already mapped some of these epics with themes that means they are mapped. They have not put it as a high they are in good shape knowing that teams are looking into it. If we spend time on the ones that are not mapped. (farheen_att, 16:02:39)
    5. Nat: Out of the 88 49 are labeled. (farheen_att, 16:03:12)
    6. Bryan: How do you want us to indicate the priority? (farheen_att, 16:03:35)
    7. : Bryan: What did you mean by none of them are prioritized. (farheen_att, 16:04:04)
    8. Bryan: How are you looking at the prioritization? (farheen_att, 16:04:55)
    9. Nat: they are prioritized according to themes. (farheen_att, 16:05:18)
    10. Bryan: Previously you said the epics have not been prioritized. Now you are talking about this list. I have ignored any suggestion about priority. (farheen_att, 16:06:08)
    11. Nat: Ofer please step in. 18 themes have been prioritized according to the list. Was there an intent to layer on this list priority? (farheen_att, 16:07:06)
    12. The top theme should be the top priority. (farheen_att, 16:07:43)
    13. Bryan: It has not been explained to PTLs of their understanding of this list. (farheen_att, 16:08:18)
    14. Mukesh: I have put them into high medium according to the sprint plan. (farheen_att, 16:08:47)
    15. Manoop: These themes are prioritized. What is important to companies and then we moved them to the top level. (farheen_att, 16:09:26)
    16. : Manoop: People have to work with how many of those top themes? Reuben agrees. These four guidelines not for the work but for the themes. They are all important. (farheen_att, 16:10:40)
    17. Bryan: That's what I said. PTLs have to prioritize their epics. Nat there are jira items that have been prioritized. Maybe we can start and go through that list. (farheen_att, 16:11:37)
    18. Ofer: I think it will be good to work on those that are already prioritized. Bryan: Just ask the PTL. Ofer: I think this is my suggestion. I think we should work PTL take one PTL or managed to do it already. Work on his or her epics and move on to the next one. Bryan I assume you have done all of your prioritization? Bryan: Do you want to start with deployment? (farheen_att, 16:13:08)

  4. Deployment Epic Prioritization (farheen_att, 16:13:27)
    1. Bryan: Go to he deployment project. Go to Boreas release planning. Scroll down. That is everything that has been defined. (farheen_att, 16:14:08)
    2. Bryan: Here you have the prioritization and labels. From the deployment we have this set of issues that are all high priority. Ofer: Can you review them quickly and get agreement with everyone. Bryan: Deploy model in Azure Kubernetes. So that basically is last release we supported deployment into kubernetes environment. There will be changes to the screens some minor discussions. We will link those stories to t (farheen_att, 16:16:45)
    3. We are going to do deployment of models into Azure. (farheen_att, 16:17:02)
    4. Ken: How do I know which themes these epics are linked to? They are labeled. (farheen_att, 16:17:28)
    5. Deepti: In jira we have almost 12 issues that comes under model deployment. B: I need to update the query there. Manoop: you need to line up with the PTLs. Deepti: I see 12 items here and 3 are not matching. (farheen_att, 16:18:35)
    6. Bryan: What you're looking at is openstack, kubernetes, docker proxy. these epics are associated with their components. (farheen_att, 16:19:51)
    7. Bryan: kubernetes we're dploying models under openshift. There are a variety of enhancements to the deployment process that are going to improve the reliabiliy. We have deployment of models to white boxes that is a medium priority because we are unclear on edge cloud deployment. Next is model lifecycle management of kubernetes. We don't have a lot of detail around what the ask is. Reuben: Are you talking about e (farheen_att, 16:21:44)
    8. Bryan: Lifecycle management is scale up, down. R: Properties management. You're talking about the lifecycle of the ms. I have to reconfigure. It's one thing to say you need to be cloud native. This is medium because it is unclear and we don't have resources. We're also going to do user level authorization to download a model. That is not supported by the portal yet. I will follow up and that is high priority. (farheen_att, 16:23:56)
    9. for the high priorities? B: Yes. Only the high priority ones are committed. B: Yes, I think we have resources to support. M: In case you don't have resources you should get them done. IF they are a high priority and you don't have the resources raise this as a jeopardy to get support from other companies. B: We know deployment to google and AWS is a lower priority because the goal is not defined. The 3 lower p (farheen_att, 16:26:03)
    10. Manoop: We should raise a concern. B: yes, that is why it is a low priority. M: Does anybody have resources for the low priority items? (farheen_att, 16:28:02)
    11. : Ying from Ericsson will check to see if she has resources. (farheen_att, 16:28:37)
    12. Bryan: We can deploy a model in any machine environment. If people have expertise in the kubernetes stacks. (farheen_att, 16:29:16)
    13. Bryan: For GPU deployment are going to require custom work. (farheen_att, 16:29:45)
    14. Ofer: Yes, this is what we wanted to get from deployment lets move on. (farheen_att, 16:30:06)

  5. Onboarding (farheen_att, 16:30:52)
    1. Philippe: I have two Epics. I have not prioritized them. Ofer: Do you know what your resources are and can you commit? P: Yes. P:2106 and the other one is related to UX. We will ask the user if he wants to let Acumos create the MS docker image. In my point of view it is a medium. O: These are the two epics? OK the first one will be high and next is medium and you will commit both of them. We will start with t (farheen_att, 16:33:09)
    2. It could be linked to model interoperability and model type. P:Also 2107. (farheen_att, 16:35:15)

  6. OAM (farheen_att, 16:38:24)
    1. Bryan: 2004 is a medium epic. It is difficult to implement clean up tools. This is a medium priority. We may not deliver everything that people want. The next item is upgrading of the openstack. High priority. Sonar coverage is high priority. It doesn't fit one of the themes. I don't know that the themes address the sum total. There is no theme to improve the test process. In system integrtation the epics a (farheen_att, 16:41:13)
    2. we need to roadmap this. We need people to scope the things we're going to deliver. System integration tools are a high priority. It is improved. Deployment and lifecycle management for openshift is a high priority for kubernetes. It's going to help us test out the platform managed around the tenant focused. Enhance the testing and the all in one tool set will be a key enabler in doing that. We need to design (farheen_att, 16:44:06)
    3. All will be committed but are not high priority. Deepti: you are missing some theme labels. (farheen_att, 16:44:42)

  7. Portal (farheen_att, 16:46:08)
    1. Mukesh: I put it under Boreas release called Boreas Tasks. We have around 21 epics that are floating into 3 or 4 user stories. these are tied to 45 user stories. The ones that I am able to filter now is deployment changes. I am working with Bryan. there is restricted federation. Migration of the logs standards. Managing private models. Enhance screens for federation. Reuben: The three you just covered can be (farheen_att, 16:49:19)
    2. M: yes, global searches for Acumos. Portal Enhancement for CDS. There are 8 or 9 user stories. We have the portal license. This is a critical feature. Portal UI changes are high. (farheen_att, 16:50:47)
    3. These are pretty complex. Then we have the medium set. R: Wasn't one of the key elements was rearchitecting the UI so it is plugable. I don't see anyting called out for that design. M: I kept them up to the components. R: So you will try this new design on a couple of use cases before restructuring the system. M: We give the requirements and the PTLs will take it to their teams to plug together. There are a co (farheen_att, 16:53:15)
    4. M: I provided priority based on the resources that I have. (farheen_att, 16:53:31)
    5. M: I am committing to all the high epics. (farheen_att, 16:54:14)

  8. Security Verification prioritization of epics (farheen_att, 16:55:42)
    1. Bryan there is only one epic and it's a high priority and committed. (farheen_att, 16:56:11)
    2. Ofer: We reviewed 4 out of 9 projects. Security verfication was moved from common services to licensing. Portal we have reviewed and Onboarding and OAM. Ofer: Let's try to have a review next week. Nat: My suggestion is to take the high ones. (farheen_att, 16:58:35)
    3. Guy: be sensitive to end of year vacations. I will not be here. Nat: Mark your epic in jira as a high. (farheen_att, 16:59:26)
    4. Philippe can review. (farheen_att, 16:59:39)
    5. ACTION: Deepti: Prepare a report that highlights the epics that are in the top 6 themes that are not a high priority. (farheen_att, 17:00:56)
    6. O: Break down the list you reviewed today on TSC and then the epics that are not a high priority and label with themes. (farheen_att, 17:01:56)
    7. ACTION: Deepti join the TSC on Monday and share your report to have the discussion. M: should we send out a communication so TSC knows and ask Licensing PTLs like Michelle to remind them that 12/10 is a deadline. (farheen_att, 17:03:04)
    8. ACTION: Ofer reach out message to the remaining PTLs. (farheen_att, 17:03:38)


Meeting ended at 17:03:55 UTC (full logs).

Action items

  1. Manoop take the omni topic to the portal meetings.
  2. Adi send Manoop the names of Yusen Istoc and Jason Tadros.
  3. Bryan set up a call with Adi for a deep dive.
  4. Philippe: I will add the license artifact and the question to the user if they want to add a license.
  5. Philippe: Include onboarding.
  6. Kazi: Provide question through devdiscuss email list.
  7. Mukesh: Take the discussion around log standards to the devdiscuss.
  8. Chris I will reach out to Parichay.
  9. Deepti: Prepare a report that highlights the epics that are in the top 6 themes that are not a high priority.
  10. Deepti join the TSC on Monday and share your report to have the discussion. M: should we send out a communication so TSC knows and ask Licensing PTLs like Michelle to remind them that 12/10 is a deadline.
  11. Ofer reach out message to the remaining PTLs.


People present (lines said)

  1. farheen_att (128)
  2. collabot` (3)


Generated by MeetBot 0.1.4.