#acumos-meeting: Architecture Committee

Meeting started by farheen_cefalu_a at 15:11:05 UTC (full logs).

Meeting summary

  1. status (farheen_cefalu_a, 15:11:23)
    1. Michelle: We have resources from Ericsson fro License manager library. We started talking about the development yesterday to help them understand what is involved. Developers will start next week. We have sufficient resources Nimish: Ericsson will be taking the development lead with the licensing. (farheen_cefalu_a, 15:13:11)
    2. Sayee: Can we consolidate ML workbench resources: Kazi: We have 3 techM resources. (farheen_cefalu_a, 15:14:37)
    3. Ken: We had meetings about federation wireframes. How should should the receiving catalog get received? In private, company, or public. Anwar: this has to be designed and discussed. Chris is the lead on this. Work with Chris. (farheen_cefalu_a, 15:16:45)
    4. ACTION: Farheen, Ken, and Chris get together over the federation. Anwar: Jack has talked to TechM to provide resources for this and have it on Boreas. Mukesh: No we didn't meet after Raj's discussion. (farheen_cefalu_a, 15:17:50)
    5. ACTION: Nat get an update on how many resources TechM can provide for Federation later today. (farheen_cefalu_a, 15:18:43)

  2. We have portal platform concerns. Bryan: This is a discussion point I raised. We can't scale the variety of ways to deploy this platform. The current things that people do right now component, hand editing configuration files, we need to move beyond that. We can support kubernetes and openshift. We have needs to establish a process of how these platforms are maintained. (farheen_cefalu_a, 15:21:11)
    1. Anwar: Do you have developers for deployment, security? Bryan: Amit, Santosh. Anwar: I heard that you don't have dev resources. (farheen_cefalu_a, 15:22:02)
    2. Bryan: I would benefit from additional support with the scalability of the way you assume how you deploy this platform. They are to me a critical enabler to adopt this platform. (farheen_cefalu_a, 15:23:15)
    3. Bryan: Certain features may not be deployable in a docker environment vs. kubernetes. (farheen_cefalu_a, 15:24:18)
    4. Anwar: that is definitely a critical area we need to make progress on. (farheen_cefalu_a, 15:24:46)
    5. ACTION: Team: Any requirements discussions should be brought to the Product Committee. Any design technical api work has to be reviewed by the Architecture committee. Let's define and agree on all the requirements in the product committee and architecture committee. (farheen_cefalu_a, 15:26:19)
    6. Chris Lott will lead decisions about databases. Chris: We analyzed the licenses. Picking couch is an easy the harder decision is how much goes into couch and how much goes into CDS. If they need to do things into the existing Acumos they could. this is a workable solution to have a workbench integrated with acumos and not have them affect the other components. Anwar: We don't want to distribute the databa (farheen_cefalu_a, 15:30:44)
    7. Adi: Couch based. Bryan: I am OK as long as there are clear instructions on how it is deployed and configured. Bryan: We will have to see what are the constraints and resource. (farheen_cefalu_a, 15:34:04)
    8. Have you looked into deploying couchdb. Chris: No I have not. It will another docker container. Bryan: there are configuration, security tasks that have to be though through. I am not going to do the research for them. (farheen_cefalu_a, 15:35:29)
    9. ACTION: Chris ensure that deployment team is OK with the deployment team. Bryan: I thought CMLP team as taking this on. Anwar: This has fall under the overall data layer that Chris owns. I didn't think that Chris has signed up for the couchdb data extraction. A: It's not one person who is going to do but the PTL has to oversee. I don't want ML Workbench to create their own silo. (farheen_cefalu_a, 15:37:34)
    10. Nat: There is a legal issue with couch_base is not Apache 2.0. (farheen_cefalu_a, 15:38:23)
    11. ACTION: Nat: Confirm with Ibrahim that couch-base is OK. A: Tell him to let us know by today or tomorrow. Couchbase community. There are two 1. couchdb and 2. couchbase. Adi is suggesting the couchbase community edition it is Apache 2.0. Adi: Look at the website. I don't think we need high performance query execution not required. If you bring up the site there is nothing in the comm. edition that is lacking (farheen_cefalu_a, 15:41:26)
    12. Adi we don't need it for incremental backups. Bryan: What about security? There is no standalone couchdb container. Adi: I said in a deployment we are not going to have an integrated couchbase. Adi: One way we do couchbase is couple it with the container services and dbs. B: Do you mean a pod or an individual docker? Adi: A deployment contains a pod. Bryan: Will it be a separate pod? Either it's a co (farheen_cefalu_a, 15:44:11)
    13. deployments over name spaces, or a route. It needs to be defined. (farheen_cefalu_a, 15:45:41)
    14. ACTION: Nat work with Ibrahim who on the LF side is able to tell us yes/no couchbase community edition from LF point of view. (farheen_cefalu_a, 15:46:33)
    15. Anwar; We will check with ATT legal team. Bryan: couchbase comm. edition does not support deployment on openshift. That will not work. Bryan: caveat if we can figure out if we can make this work that's another thing. (farheen_cefalu_a, 15:48:03)
    16. Kazi: Both are Apache 2.0 license. Recommendation from AT&T architects to use couchbase. Couchdb is apache 2.0. (farheen_cefalu_a, 15:49:20)
    17. Anwar: The team has to keep both options open. Adi: The difference is couchbase includes memory in cache. They combined couchdb and couchbase to make it faster. (farheen_cefalu_a, 15:50:29)
    18. Bryan: We have to test the constraints that it has. We need to id how we intend to deploy this as part of the platform and those need to be recommendations of the people who depend upon it for their components. Anwar: Our deadline is tomorrow to get this decision finalized but I want to nail it today. (farheen_cefalu_a, 15:51:28)
    19. ACTION: Nat check the licensing issue with ibrahim. (farheen_cefalu_a, 15:51:43)
    20. ACTION: Farheen check with Umesh whether or not there is an issue with using couchdb or couchbase (farheen_cefalu_a, 15:53:13)
    21. couchbase. Chris and Adi and Sayee collectively spend time on this today. If we want to make progress or make a decision everything is going to fall back to Mariadb. (farheen_cefalu_a, 15:53:55)
    22. ACTION: Adi Sayee Bryan deployment issues between couchdb and couchbase community edition both are Apache 2.0 license. (farheen_cefalu_a, 15:54:57)
    23. Bryan: In the future we have to have the research done prior to designing the system. (farheen_cefalu_a, 15:57:02)
    24. Nat: there is no weekly meeting on Friday. (farheen_cefalu_a, 15:57:37)
    25. ACTION: Nat: Can you put 30 minutes tomorrow so we can circle back and know where we are. (farheen_cefalu_a, 15:58:08)


Meeting ended at 15:58:12 UTC (full logs).

Action items

  1. Farheen, Ken, and Chris get together over the federation. Anwar: Jack has talked to TechM to provide resources for this and have it on Boreas. Mukesh: No we didn't meet after Raj's discussion.
  2. Nat get an update on how many resources TechM can provide for Federation later today.
  3. Team: Any requirements discussions should be brought to the Product Committee. Any design technical api work has to be reviewed by the Architecture committee. Let's define and agree on all the requirements in the product committee and architecture committee.
  4. Chris ensure that deployment team is OK with the deployment team. Bryan: I thought CMLP team as taking this on. Anwar: This has fall under the overall data layer that Chris owns. I didn't think that Chris has signed up for the couchdb data extraction. A: It's not one person who is going to do but the PTL has to oversee. I don't want ML Workbench to create their own silo.
  5. Nat: Confirm with Ibrahim that couch-base is OK. A: Tell him to let us know by today or tomorrow. Couchbase community. There are two 1. couchdb and 2. couchbase. Adi is suggesting the couchbase community edition it is Apache 2.0. Adi: Look at the website. I don't think we need high performance query execution not required. If you bring up the site there is nothing in the comm. edition that is lacking
  6. Nat work with Ibrahim who on the LF side is able to tell us yes/no couchbase community edition from LF point of view.
  7. Nat check the licensing issue with ibrahim.
  8. Farheen check with Umesh whether or not there is an issue with using couchdb or couchbase
  9. Adi Sayee Bryan deployment issues between couchdb and couchbase community edition both are Apache 2.0 license.
  10. Nat: Can you put 30 minutes tomorrow so we can circle back and know where we are.


People present (lines said)

  1. farheen_cefalu_a (35)
  2. collabot` (3)


Generated by MeetBot 0.1.4.