#acumos-meeting: Architecture Committee

Meeting started by farheen_cefalu_a at 15:06:47 UTC (full logs).

Meeting summary

  1. Change of database for Design Studio (farheen_cefalu_a, 15:07:07)
    1. Bryan: we want to use Mariadb for delivering the training and ds features. (farheen_cefalu_a, 15:07:52)

  2. update score card (farheen_cefalu_a, 15:08:39)
  3. Model Onboarding (farheen_cefalu_a, 15:09:09)
    1. Phillippe: We will have an api for productized model. Will be implemented on the portal side. ONNX and PFA backend is done we are working on wireframes of the portal. I am working with Vinaik from TechM. Licensing and ms creation are working on to create the ms after onboarding. The onboarding api is ready and left with modification of the client and wireframes (farheen_cefalu_a, 15:13:11)
    2. Bryan: I don't have time to work on kubeFlow. (farheen_cefalu_a, 15:13:50)

  4. Data Management (farheen_cefalu_a, 15:14:01)
    1. Chris: working with Kazi for their CDS needs. Licensing is implemented and delivered and running. (farheen_cefalu_a, 15:14:50)

  5. Training (farheen_cefalu_a, 15:14:56)
    1. Bryan: Making progress on Jupytr Zeppeliln and starting with Nifi. I'm still waiting for the training team to flush out the UX. I've created demonstrations that notebooks can be onboarded quite easily. Ready to give demos. (farheen_cefalu_a, 15:16:13)
    2. Anwar: removal of user stories? The team is saying they are not doing Zeppelin we have to get the TSC approval to drop from Boreas. They need to give a review. (farheen_cefalu_a, 15:17:16)
    3. Sayee: With respect to training. We did the initial design on star schema and now we have redesigned. We decided to go with one database approach that's Mariadb for now. Flattening of tables to level 1 and level 2 to help us long term. WRT development we have a UI approach finalized and how UI can be developed as a dev component. We are talking through the path of UI to finalize by tomorrow. Chris will (farheen_cefalu_a, 15:19:27)
    4. S: Zeppelin is there from CMLP perspective. Bryan: I know how to deploy it but I don't know how much backend work has to be done. (farheen_cefalu_a, 15:20:12)
    5. Bryan: It's a little bit more then risk at this point. I need someone who understands the spawner for Zeppelin containers. We may have to take a simpler approach. There are still open questions. Anwar: I heard we don't have MVP for training. We have listed on the product call. It has not been voted and confirmed by the product committee. (farheen_cefalu_a, 15:21:57)
    6. Nat: Kazi went through the review and will be voted for on Monday's TSC. (farheen_cefalu_a, 15:22:26)
    7. Nat: It was finalized on yesterdays meeting and Ofer will bring it to TSC. (farheen_cefalu_a, 15:24:14)
    8. ACTION: Sayee: Review wireframes with the product committee team. (farheen_cefalu_a, 15:24:34)

  6. Deployment (farheen_cefalu_a, 15:24:42)
    1. Bryan: We don't have an openstack environment where it can be tested. Our lab team is no longer maintaining the open stack environment. Anwar: Will the vendor manage now? Who is going to manage? My understanding is that the vendor openstack is working on this We are working with redhat in tlab. There are VMs allocated for running open stack environments in the azure vms. Mukesh and Santosh are not expe (farheen_cefalu_a, 15:26:47)
    2. to take on responsibility. I don't have time. (farheen_cefalu_a, 15:27:02)

  7. Security (farheen_cefalu_a, 15:27:05)
    1. : making progress and on track. (farheen_cefalu_a, 15:27:18)

  8. Common Services (farheen_cefalu_a, 15:27:26)
    1. Guy: I would say we're at 100% now. We had the new model runner and it's on the wiki. Now it's just a matter of martialing the troops. (farheen_cefalu_a, 15:28:11)

  9. Training (farheen_cefalu_a, 15:28:17)
    1. Anwar: where are we with design. Sayee: With the db design change we will have to rewrite. We are at 60%. (farheen_cefalu_a, 15:29:08)

  10. License (farheen_cefalu_a, 15:29:25)
    1. Bryan: We reviewed license in the security meeting and agreed it addresses the needs of the stakeholders. We have the models logging in a running environment. Guy has a plan to implement the model runner part of it. We have the implementation of the license manager library. We should be delivering in sprint 3 the initial user stories. (farheen_cefalu_a, 15:30:57)
    2. Bryan: For sys-integration we have to have a discussion with Chris. We're starting to work from a bash based to a helm based. Does this mean that people that are starting with docker are going to be shut out? No they will still be supported but lower priority. Bryan: In the end it will be much more easy to use. Chris: External community is using docker. Docker based seems to be popular. Bryan: We are (farheen_cefalu_a, 15:34:17)
    3. Jupyter does not do docker as a platform. We are going to do our best to support the Docker community as much as possible but we are putting our support on kubernetes and helm. (farheen_cefalu_a, 15:35:10)

  11. Federation Catalogs vs. current design. (farheen_cefalu_a, 15:35:32)
    1. Nat do you have the plan for partner catalogs? Nat: We are waiting for the MVP. Can you put that on the agenda? (farheen_cefalu_a, 15:38:21)
    2. ACTION: Farheen Get the MVP for Partner catalogs. (farheen_cefalu_a, 15:39:16)


Meeting ended at 15:39:34 UTC (full logs).

Action items

  1. Sayee: Review wireframes with the product committee team.
  2. Farheen Get the MVP for Partner catalogs.


People present (lines said)

  1. farheen_cefalu_a (35)
  2. collabot` (3)


Generated by MeetBot 0.1.4.