#acumos-meeting: Architecture Committee

Meeting started by farheen_att at 15:15:07 UTC (full logs).

Meeting summary

  1. Onboarding (Phillippe) (farheen_att, 15:15:56)
    1. Predockerized model. Question Do you think it's possible for Boreas? Mukesh: Was there a design? Is this a pull or a manual upload of a docker image? Best way is to use the docker push to push the image to Acumos. If somebody has a dockerized image they can onboard we can simply upload that. The problem is about authentication on Nexus. Mukesh: Loading from UI is tricky. http does not scale. Use a docker (farheen_att, 15:18:48)
    2. artifacts id and uuid. I don't know what naming convention to give. Need to discuss and evaluate. If you create a local docker registry then you have two repos. The user has to know two there are two repos. That presents a challenge to user acceptance. There is a docker pull option as well. Pulling from private docker registry into Acumos registry? We don't want the portal storing credentials. That's a de (farheen_att, 15:27:01)
    3. You need to do a docker login. You need to give credentials to push. Yes, like you deploy today the user is going to need to use their credentials to push or pull from / to the portal. (farheen_att, 15:28:25)
    4. We need to decide what is more intuitive and secure and inline with our current implementation. (farheen_att, 15:30:12)
    5. the design for our catalog is not virtual links. Our catalog has to have the physical model in the catalog. So we are talking about having the docker image. Anwar: Has the team decided? Mukesh: There are credentials issues if we pull that image. We have to provide a URL. It is not scalable. Docker push or pull with credentials and connectivity. Guy: Either the push or pull approach there is a potential for (farheen_att, 15:32:26)
    6. layers. It determines what it has to transfer and pushes an easier faster process. Vs. Uploading and Downloading there will be a price to pay. There is a potential for speeding up but Docker potentially reduces the amounts of bytes that go back and forth. Phillippe: Do we include the third use case in Boreas? Guy: For the second use case it's useful to know what state the proxy is in time. Will the poxy be a (farheen_att, 15:34:35)
    7. in sprint 4. Basic authentication will be in sprint 4. So if docker proxy is available in sprint 4 we will not have enough time to code one of those use cases. Why? Docker proxy is one thing but we have to wireframe. Not enough time with the workload. (farheen_att, 15:38:15)
    8. Anwar: At least one of the three have to demonstrated as a part of the boreas release. (farheen_att, 15:38:33)

  2. Partner Catalog (farheen_att, 15:39:15)
    1. ACTION: Farheen bring Mukesh up to date wireframes. (farheen_att, 15:40:43)

  3. License Management (Michelle) (farheen_att, 15:40:53)
    1. Michelle: We are not creating any new apis. I want to show what is happening. Justin is supporting (Ericsson). We've created a new license manager component. License manager will call the CDS API. Chris already implemented this. We are going to call the CDS API and provide back to security verification. The other thing is the model activity tracking. We're going to be leveraging the logging and apis suppor (farheen_att, 15:43:42)
    2. api's from license manager team for this release. (farheen_att, 15:44:01)
    3. Anwar: Was this the last item that you had or is this going on in parallel with code development? This is all happening now and it will be across sprint 3 and sprint 4. Have we started entitlements, rtu. That is complete. In the next sprint we will be using CDS. The license component is in sprint 3 and the rest is in sprint 4. (farheen_att, 15:45:44)

  4. Training (farheen_att, 15:46:16)
    1. Mukesh: We finalized the microservices and UI in the backend and have been named. (farheen_att, 15:48:31)

  5. Scorecard review (farheen_att, 15:48:38)
    1. Portal Mukesh: De-scoping of user stories. I need time to tie them to the epics. Anwar: There are some that we have to keep. (farheen_att, 15:50:50)
    2. : Chris: I have the training teams requirements. They have to test. I am comfortable with the partner catalog requirements. (farheen_att, 15:57:04)
    3. Mukesh: Training omni components complete. Have them running next week. Is the ETE sprint planning available for review. We haven't seen user stories added to sprint 5 yet. We have 100+ for sprint 4 but none for sprint 5. For all the sprints what will reviewed and demonstrated. (farheen_att, 15:58:52)
    4. ACTION: Ken work with Deepti and Nat for an ETE workflow. (farheen_att, 15:59:22)
    5. Ken: There are 9 user stories for training. (farheen_att, 15:59:54)
    6. ACTION: Kazi work with Ken. When is the next demo? Next Tuesday on the Community call. Due to partial delivery he will be moving all of the user stories to sprint 4. We have the code checked in but can't demonstrate it next Tuesday. (farheen_att, 16:01:06)
    7. (farheen_att, 16:01:56)
    8. DS wireframes. Looking to Sayee. (farheen_att, 16:03:12)
    9. Bryan: We apply a lot of dicipline to push things to sprint 5. We need to use sprint 5 as not open but a high priority. (farheen_att, 16:03:56)


Meeting ended at 16:04:32 UTC (full logs).

Action items

  1. Farheen bring Mukesh up to date wireframes.
  2. Ken work with Deepti and Nat for an ETE workflow.
  3. Kazi work with Ken. When is the next demo? Next Tuesday on the Community call. Due to partial delivery he will be moving all of the user stories to sprint 4. We have the code checked in but can't demonstrate it next Tuesday.


People present (lines said)

  1. farheen_att (29)
  2. collabot (3)


Generated by MeetBot 0.1.4.