#acumos-meeting: Architecture Committee

Meeting started by farheen_cefalu_a at 14:05:31 UTC (full logs).

Meeting summary

  1. Security Verification (farheen_cefalu_a, 14:06:01)
    1. Michelle: Justin will assist Ken with security blocker while Bryan is out. #action Michelle: Inform Jack that Justin will be working with Ken for Security. (farheen_cefalu_a, 14:07:36)

  2. Acumos-CMLP (farheen_cefalu_a, 14:12:06)
    1. Sayee is not present. If he joins we will discuss the topics. (farheen_cefalu_a, 14:12:18)

  3. AI for EU (farheen_cefalu_a, 14:12:26)
    1. AI4EU is a project. A European project like Linux Foundation project. The European commission launched the project and asked European companies to form this project. AI4EU is to build an AI platform for European companies. They chose Acumos as the platform. They wanted to onboard a developed model with C C++ language. Phillippe has colleagues that participate to the AIf4EU project. Ai4EU is C, C++ clie (farheen_cefalu_a, 14:15:29)
    2. repo for client library for C, C++. (farheen_cefalu_a, 14:15:56)
    3. There is a formal process to creating repos. Best approach is to ask for a separate repo like acumos-r, and java, python. (farheen_cefalu_a, 14:17:07)
    4. We should create a wiki page with this request for the onboarding project. Send an email to TSC list pointing to the wiki page and they will decide. (farheen_cefalu_a, 14:18:24)
    5. The PTL of the project should create the wiki page. #action Manoop send Phillippe the process to create the wiki page and submit your request. (farheen_cefalu_a, 14:19:18)
    6. https://wiki.acumos.org/display/INTTEST/Acumos+subrepos+for+CMLP+integration (farheen_cefalu_a, 14:19:40)
    7. It impacts onboarding and microservice generation. (farheen_cefalu_a, 14:21:30)
    8. Guy: We discussed how to create a new client library and work with model runner. Technical challenges: C++ we don't have CI/CD process to build and run scans to see those repos. Work with LF that needs to be planned for. Come up with tools and tool chains we need. It is not as straight forward as java. Where to host the library? Is it Nexus Maven. LF will accept / reject the request. (farheen_cefalu_a, 14:29:08)
    9. help desk is https://docs.releng.linuxfoundation.org/en/latest/helpdesk.html (farheen_cefalu_a, 14:29:26)
    10. Bryan is returning to office 5/6/19. (farheen_cefalu_a, 14:30:25)

  4. ML Workbench (farheen_cefalu_a, 14:34:24)
    1. Guy has created steps to do a soup to nuts ML workbench. (farheen_cefalu_a, 14:34:57)
    2. Guy: It does what it needs to train and dump a simple model. All of that will be incorporated into the new soup to nuts video. There is a whole backend. (farheen_cefalu_a, 14:36:37)
    3. ACTION: Guy share findings with Vaibhav. (farheen_cefalu_a, 14:37:57)
    4. There was an issue with returning to a notebook after leaving. Vaibhav: Once we launch the notebook we can not control the notebook. Manoop: We should put our own config file to disable them. Vaibhav: Currently it's left to default. That frees up a lot of resources. (farheen_cefalu_a, 14:40:01)
    5. We are in good shape for ML Workbench and Training. Ken and team are struggling to deploy Jupyterhub and modules. (farheen_cefalu_a, 14:41:49)
    6. Bryan was trying to launch Jupyterhub with Kubernetes. Ken: We want a shell script. This goes beyond jupyter notebooks. Package would be nice. ML workbench team. Do you see this as a temporary. Yes, Bryan said one click install will handle. (farheen_cefalu_a, 14:45:44)
    7. Are we planning to jupyterhub or all in one? jupyterhub will be on docker compose. Boreas release will have only jupyterhub. If so then there should be a streamlined way of installing it. There are well documented steps but you have to create files, certificates, drop them in directories. There is a lot of moving stuff around. (farheen_cefalu_a, 14:48:26)
    8. Nat: We are moving towards Kubernetes. This is the MVP. Vaibhav: The moment I sent the script I was waiting for a ground level person to work with. (farheen_cefalu_a, 14:51:02)
    9. Viabhav we need admin user to be created the ssl, oauth variable. How do we move from one to another? One configuration file. (farheen_cefalu_a, 14:55:29)
    10. ACTION: Vaibhav we can do a working session and streamline to make it better. (farheen_cefalu_a, 14:55:48)
    11. improving the installation will help. #action Manoop, Guy work with Vaibhav. Priya is out this week. She should be back. #action Ken schedule the call during the ms services meeting. (farheen_cefalu_a, 14:59:23)
    12. Manoop will work with Ting Lu to add ONAP Acumos integration. (farheen_cefalu_a, 15:01:17)
    13. ACTION: Manoop: Michelle started the model activity tracking and wants to show a demo how we are tracking reporting through federation as well. (farheen_cefalu_a, 15:01:56)
    14. ACTION: Manoop add Michelles topic to next weeks architecture call. (farheen_cefalu_a, 15:02:12)


Meeting ended at 15:02:16 UTC (full logs).

Action items

  1. Guy share findings with Vaibhav.
  2. Vaibhav we can do a working session and streamline to make it better.
  3. Manoop: Michelle started the model activity tracking and wants to show a demo how we are tracking reporting through federation as well.
  4. Manoop add Michelles topic to next weeks architecture call.


People present (lines said)

  1. farheen_cefalu_a (33)
  2. collabot (3)


Generated by MeetBot 0.1.4.