#acumos-meeting: Architecture Committee

Meeting started by farheen_cefalu at 14:03:45 UTC (full logs).

Meeting summary

  1. agenda (farheen_cefalu, 14:04:06)
    1. we will have to discuss the security verification. Ken - I'd like to have a brief discussion so that everyone knows what's going on. (farheen_cefalu, 14:07:08)
    2. Agenda will be licensing (Michelle), archival process from the portal team (Mukesh), Boreas model tile re-arrangement (Murali, Vinayak), Docker compose issue (Ken). (farheen_cefalu, 14:08:53)

  2. License Manager (Michelle) (farheen_cefalu, 14:09:16)
    1. with Clio we are taking lessons learned from Boreas. We are going to implement a license usage manager component that will decide what actions can be approved/denied. That will be in another architecture review. For sprint 1 we are putting license profile with the artifact. The second thing for sprint 1 is RTU. Boreas it was yes/no for C (farheen_cefalu, 14:11:27)
    2. https://wiki.acumos.org/display/LM/License+Profile (farheen_cefalu, 14:12:47)
    3. the license profile is a text file. Security verification will confirm whether it is open or commercial. If open then it's in the github repo. If it's not then security verification will store including company, license type, and anything else the supplier provides. We have user stories that have onboarding text and json files. Portal wi (farheen_cefalu, 14:16:45)
    4. We also have a web form for Boreas. We will continue to host the web form. We are going to try to make it easier for the model owner. Their company should create a commercial license for their users. Is the web form included in Acumos? Justin - It's in gerrit. It was in security verification. It is a web component. It can be brought i (farheen_cefalu, 14:21:29)
    5. https://acumos-license-editor.stackblitz.io (farheen_cefalu, 14:22:26)
    6. changing the left side. It takes a json file and infers a json schema to create the web form on the right. The web form is tied to non-flat schema. Current model is to create a nested structure out of it. If you scroll down the right hand side we will add additional layers. This was used as a stop/gap. Mukesh - Has key value pair been d (farheen_cefalu, 14:31:42)
    7. There will be some standard licenses that don't need modification. Guy - the data attributes has company, copywright, and software. With this design it is more than just the license. Manoop - I assume that the license picked from drop down. I would download and upload the license with the changes. Example suppose you have repetitive compa (farheen_cefalu, 14:41:23)
    8. you have to add a license to publish a model. Sayee - I create an open source but evolve to licensed. Michelle - you can add a new license artifact. this is done by version. Manoop- when i update a new version for the same license. Each version needs a license. (farheen_cefalu, 14:44:53)
    9. Manoop - do we send notifications for expiration? No, something to consider for Clio. We still need to get an RTU and read it? (farheen_cefalu, 14:46:17)
    10. For commercial license you have to contact the supplier and negotiate the contract and license terms. The supplier takes the rules and asks them to populate the RTU file. We are working on the design and format fo the RTU file. We are defining some of the common terms. Some of these use cases are talking about what restrictions or metrics (farheen_cefalu, 14:49:22)
    11. https://wiki.acumos.org/pages/viewpage.action?pageId=20547401 (farheen_cefalu, 14:49:31)
    12. Justin - we are working on the minimal viable product for ODRL. Michelle - RTU can be used with one or many models. (farheen_cefalu, 14:50:31)
    13. The rites can be applied to set number of users, actions, instances, or time period. (farheen_cefalu, 14:51:37)

  3. Portal jira #3196 (farheen_cefalu, 14:53:03)
    1. Vanayak demonstrated jira 3196 (farheen_cefalu, 14:55:52)
    2. Sayee are we using responsive design. the text link for the tag will be fixed and "..." to (farheen_cefalu, 15:04:06)
    3. ACTION: Parichay set up an a doc meeting with Manoop, Farheen, Ken and TechM. (farheen_cefalu, 15:04:54)


Meeting ended at 15:05:36 UTC (full logs).

Action items

  1. Parichay set up an a doc meeting with Manoop, Farheen, Ken and TechM.


People present (lines said)

  1. farheen_cefalu (32)
  2. collabot` (3)
  3. earlyster (3)


Generated by MeetBot 0.1.4.