#acumos-meeting: Architecture Committee

Meeting started by farheen at 14:04:46 UTC (full logs).

Meeting summary

  1. agenda (farheen, 14:05:48)
    1. Manoop sharing Agenda. Search engine, ML Workbench, Licensing. (farheen, 14:09:34)
    2. Vasu, Vineet and Ashwini will be Tausif's backup for the architecture team to review next week while Tausif is away. Acumos portal footprint may have to be moved to next week. (farheen, 14:11:02)

  2. Justin - Licensing flows (farheen, 14:11:23)
    1. Manoop - what are the overall flows. What are the updates. Justin - I have two wiki pages one for license flow and the model runner right to use. (farheen, 14:12:41)
    2. Tausif if the file has already been uploaded portal does the validation that the json file is uploaded. If user selects create template. (farheen, 14:20:50)
    3. ACTION: Tausif talk to Justin regarding the portal validation of the json file. (farheen, 14:21:15)
    4. Justin the json file is not validated today. The license manager client library has a function that will evaluate the schema and save in the repo. If not the validation should alert the user that there are invalid values in the license. (farheen, 14:22:10)
    5. Once license is save it will be scanned by Security Verification by a third party tool. It evaluates the scan based on scanned data. (farheen, 14:22:49)
    6. Scan code data is the raw results. The results artifact are the results of the scan that will tell LUM to activate LTU it's not an SPDF library. (farheen, 14:23:29)
    7. If your model runner is running you should be able to access the license artifact. Sayee- Licenses come with an expiration date. Do we have something that checks for expiration dates? No this is the docker image to include the license. Currently there is no ability. (farheen, 14:26:43)
    8. Manoop - Michelle had noted does the license have an expiration and will they flow? That is not in scope in this release. (farheen, 14:28:18)
    9. the license expiration needs to be discussed further. Is this license artifact saved in nexus can it be seen by the end user? Yes it is there today. (farheen, 14:28:58)
    10. the default licenses are we going to make default licenses for Clio release? Justin yes we can. (farheen, 14:29:42)
    11. Give the users instructions on how to add it. Bryan we have instructions on how to add a license and it's up to the user to manage it with their legal team. (farheen, 14:31:02)
    12. Manoop - The impacted components are CDS, SV any points need to be raised. (farheen, 14:31:59)
    13. In the Boreas release we had the ability to track usage. We used a side car approach. We use ELK stack as an MVP for tracking. In Clio we need to track. We need to remove the proxy and bypass. We wanted to go down to he ML client library and we call it simple sequence of how the library will work with the license mananger. We want to ac (farheen, 14:33:43)
    14. Bryan - Are you saying the modeler will have to enter this in the pcl file? No they will not have to. It can be reverse engineered and remove it. There are two calls at design time. There are two actions the user has to do. Once you enable the function the verify RTU determines whether you are allowed or not allowed. (farheen, 14:37:06)
    15. https://wiki.acumos.org/display/LM/Model+Runner?preview=/20548377/20548668/model-runner.png (farheen, 14:39:02)
    16. Manoop - From the LUM demo we discussed what if LUM is not accessible. In that situation do we let them use the model? Guy - Goal is to make it easy to onboard and not get involved with licensing. Not their interest. We designed to stop them from getting involved. Bryan - this is optional for the designer at design time. Manoop - will I (farheen, 14:42:31)
    17. Justin - Enable production environments enable the RTU through configuration. Bryan - when the developer is vetting he has the option. The operator/publisher will configure this. Guy - If this can all be done during publishing then I am happy with it. Bryan - you may have to retrain the model. Guy - So I'm training a model that I am able (farheen, 14:47:05)
    18. You can put the proxy on the front end. If you push it into the CL then you have to write one for python, r, c++, etc... (farheen, 14:47:54)

  3. Sayee - ML Workbench (farheen, 14:48:14)
    1. Sayee - Will review the wireframes for ML Workbench. ML workbench is under design studio in development environment or test. This will take you to the UI layout. Models and data pipelines are still discussing. Attaching Notebooks and Data pipelines was in Boreas. (farheen, 14:50:27)
    2. When a user creates a project they are associating a project to a model. In Clio when you associate a model you will receive the meta data with an existing model. A single model can be associated with multiple projects. We want to see what is published vs. not published. (farheen, 14:56:08)
    3. We can add the associated catalog to the published and unpublished. We also removed the repetitive word Project in the UI for aesthetics. It was repeated. (farheen, 14:57:34)
    4. Sayee - We want to work with someone who understands CouchDB. (farheen, 14:58:25)
    5. ACTION: Sayee will have the end to end ready by the end of Sprint 2. (farheen, 14:58:45)

  4. CDS (farheen, 14:58:55)
    1. Chris - Java 8 reaches end of life. I had to change the dependency of my POM. There was not other impact on spring boot. For most projects the upgrade will not be a big deal. java 8 stopped receiving security updates so this is critical. This is not a big code impact. We need to try the new version and if nothing is failing. (farheen, 15:01:01)
    2. Once the PTLs give us the OK then one lead from each team has to run their component with java 11 inform the team so release management can start releasing. (farheen, 15:04:48)
    3. ACTION: Tausif schedule a call with the stake holders for the Search issues instead of waiting for another week. (farheen, 15:05:30)


Meeting ended at 15:05:34 UTC (full logs).

Action items

  1. Tausif talk to Justin regarding the portal validation of the json file.
  2. Sayee will have the end to end ready by the end of Sprint 2.
  3. Tausif schedule a call with the stake holders for the Search issues instead of waiting for another week.


People present (lines said)

  1. farheen (41)
  2. collabot` (4)


Generated by MeetBot 0.1.4.