#acumos-meeting: Architecture Committee

Meeting started by farheen_att at 14:10:37 UTC (full logs).

Meeting summary

  1. Acumos-1188 (farheen_att, 14:10:50)
    1. Bryan - We found that we don't have the flexibility to use k8 cluster. Host map is the only persistence volume of service. (farheen_att, 14:12:23)
    2. not scalable so you have to distribute the components across a cluster node. A side car is related to that cluster of services. (farheen_att, 14:13:19)
    3. this is an effort to deploy components across a k8 cluster. I am adding labels with their own log volumes. (farheen_att, 14:14:11)
    4. I have a patch open to system integration to see the first stage. (farheen_att, 14:14:44)
    5. Regarding the CI pipeline. The design of deployment is there. Still working on SV. (farheen_att, 14:15:14)
    6. Looking at how the platform works with Docker in all aspects and consider all of those things are offloaded to an external service like Jenkins. It is a security concern. We are establishing a pattern. Onboarding team should take a look. (farheen_att, 14:16:29)
    7. What is the scope in Clio? (farheen_att, 14:16:43)
    8. Bryan - I don't think anything in Clio will be developed in Clio. There is an interplay of Jenkins and Acumos components. APIs need to be created and roles distributed. It is a significant aspect change across the platform. (farheen_att, 14:17:47)
    9. ACTION: Guy and Phillippe how does the onboarding code need to be refactored to fit into the CI/CD pipeline. What can be done in short term and what is coming up in the releases. (farheen_att, 14:18:30)
    10. Guy - it is do-able but we may not have time to do it in Clio. It will disrupt and break things. (farheen_att, 14:19:12)
    11. The ms code is missing. Even though at a high level we know what can be done and what is feasible. If you can bring together a plan we can review. (farheen_att, 14:20:04)
    12. ACTION: Manoop add this topic to next week's agenda. (farheen_att, 14:20:16)
    13. Guy I agree we will discuss a bit and bring it up at the next architecture meeting. (farheen_att, 14:20:37)

  2. Access Control (farheen_att, 14:21:41)
    1. Bryan the need for the Docker proxy is less and less therefore it's role can be simplified. Proposal to manage images through workflow that wraps the platform. (farheen_att, 14:23:10)

  3. HA Availability (farheen_att, 14:23:18)
    1. Bryan this is a big ask. I don't know that the platform will scale. Suggested to plan out experiments to test whats possible. We need to take a planned experiment to see impacts. (farheen_att, 14:24:32)
    2. ACTION: Manoop Bryan wants to have a design review for HA (farheen_att, 14:24:59)
    3. we can perform load tests to baseline what our platform can support. This will give us a clue to which components are impacted by the load tests. Save them in he HELM charts. (farheen_att, 14:26:11)
    4. we need two action items. Load test and analyze the deployment techniques. (farheen_att, 14:27:05)
    5. Ask the component leads these questions. (farheen_att, 14:27:14)
    6. ACTION: Ken to perform the load test to baseline the platform performance (talasila, 14:27:58)
    7. ACTION: Parichay to analyze the helm chart of k8 deployment to address HA/scalability (talasila, 14:28:23)
    8. Is your component stateless? What aspects of your app depend on a state. What aspects are stateless? (farheen_att, 14:28:47)

  4. Search functionality (farheen_att, 14:29:53)
    1. Many defects are being opened. Records per page. When we search we search on the 11 - 20 records. Search does not search all records. To do the entire database search a lot of changes will be required. (farheen_att, 14:31:24)
    2. Do we really want to achieve the database search. Acumos-2940. (farheen_att, 14:33:56)
    3. ACTION: Tausif, Nat suggested collecting the search defects and we can review on the community call. (farheen_att, 14:36:28)
    4. ACTION: Tausif review with the product committee and then with the architecture committee. (farheen_att, 14:37:40)
    5. regarding Acumos-1188 need support from the Federation team. When we do an un-publish on the model that has been federated we need to know the rules around how to handle a federated file. (farheen_att, 14:40:17)
    6. when a model is federated from A to B. B wants to unpublish the model. If a model has been published and federated to another instance then the federated instance should un-publish. (farheen_att, 14:41:49)
    7. un-publish will delete the model everywhere? (farheen_att, 14:42:05)
    8. yes (farheen_att, 14:42:13)
    9. Manoop once a model is federated it will show up somewhere. We can not remove a model once it is federated to the internet. Show the model as depricated. (farheen_att, 14:44:49)
    10. what rites does the publisher have? (farheen_att, 14:45:31)
    11. what rites does the publisher has after publication? (farheen_att, 14:45:53)
    12. How instance A can changed ownership via instance B? Can we restrict further access? (farheen_att, 14:46:50)
    13. It depends on license and terms if any. (farheen_att, 14:47:02)
    14. Does the licensing team address the federated license models? (farheen_att, 14:48:08)
    15. That has not been discussed. If the company wants to remove their model and they don't want anyone to use it they will have to do it offline. (farheen_att, 14:48:56)
    16. Publisher takes the model down from A and B through the federation API? (farheen_att, 14:49:18)
    17. yes, a scenario has to put together for that. (farheen_att, 14:49:33)
    18. We can trigger the request from Portal front end but need Federation team to take the action for portal to trigger so it can be un-published. (farheen_att, 14:53:21)
    19. this is not for-seen in the federation model. The need to withdraw a model we have to decide how to notify the peer. (farheen_att, 14:54:49)
    20. ACTION: Tausif put together a clear design and bring this topic to the Community call to Reuben. (farheen_att, 14:55:35)
    21. ACTION: Justin add link to documentation to meeting minutes to the documentation api (farheen_att, 14:58:20)
    22. ACTION: Manoop add Priya's Spark review to next weeks agenda. (farheen_att, 14:59:08)
    23. https://wiki.acumos.org/display/AR/Architecture+Reviews+Score+Card (farheen_att, 15:00:32)
    24. reviewed score card link above (farheen_att, 15:00:57)


Meeting ended at 15:01:07 UTC (full logs).

Action items

  1. Guy and Phillippe how does the onboarding code need to be refactored to fit into the CI/CD pipeline. What can be done in short term and what is coming up in the releases.
  2. Manoop add this topic to next week's agenda.
  3. Manoop Bryan wants to have a design review for HA
  4. Ken to perform the load test to baseline the platform performance
  5. Parichay to analyze the helm chart of k8 deployment to address HA/scalability
  6. Tausif, Nat suggested collecting the search defects and we can review on the community call.
  7. Tausif review with the product committee and then with the architecture committee.
  8. Tausif put together a clear design and bring this topic to the Community call to Reuben.
  9. Justin add link to documentation to meeting minutes to the documentation api
  10. Manoop add Priya's Spark review to next weeks agenda.


People present (lines said)

  1. farheen_att (50)
  2. collabot` (3)
  3. talasila (2)


Generated by MeetBot 0.1.4.