#acumos-meeting: Architecture Committee

Meeting started by farheen_att at 14:04:59 UTC (full logs).

Meeting summary

  1. Agenda (farheen_att, 14:06:31)
    1. we want to spend time on release status, sprint 4 blockers, kafka pub/sub, planning for Demeter, new feature ideas. (farheen_att, 14:07:26)
    2. Add the self-release of artifacts for mavin or docker feature for gerrit. (farheen_att, 14:08:09)
    3. Chris Lott has done some self-release process. This is a good topic to cover. (farheen_att, 14:08:40)
    4. Chris - Self release is only good for jar files (farheen_att, 14:08:53)
    5. Justin - LF fixed the bugs and we are releasing docker also. (farheen_att, 14:09:11)

  2. Release Status (farheen_att, 14:10:02)
    1. We want to focus on blockers for the pending items in sprint 4. Are we on target? (farheen_att, 14:10:37)
    2. Federation We ware on track Murali is having a separate discussion with Ting. (farheen_att, 14:11:06)
    3. Guy - we had a pass thru feature for ONAP that has been implemented. More work regarding adding meta data. For that we need to synchronize with Tommy. It is not blocking the demo but it should be finished. It's work that has to be done by onboarding or common services team. (farheen_att, 14:12:40)
    4. we will have a demo that will benefit the Acumos community. (farheen_att, 14:13:18)

  3. O-RAN October 8th demo (farheen_att, 14:13:33)
    1. Guy will have it ready next week. (farheen_att, 14:13:50)

  4. ONS demo (farheen_att, 14:14:01)
    1. Guy - There was a resource that was stalled. Nat said they have gotten someone but I have not heard from TechM. (farheen_att, 14:14:25)
    2. Nat - I got the input from Amol offshore. (farheen_att, 14:14:55)
    3. ACTION: Nat will align the resource to join the next onboarding scrum call (farheen_att, 14:16:31)
    4. ACTION: Murali put it as a blocker waiting for a resource. One week task for a skilled developer. (farheen_att, 14:17:54)

  5. Jenkins Model Deployment (farheen_att, 14:18:48)
    1. Bryan - Was released yesterday. Mark it as deliver to testing team. It is available on the TechM K8 server. (farheen_att, 14:19:38)
    2. Ken - no issues with alignment on deployment. (farheen_att, 14:21:00)
    3. when can we have the demo on that? (farheen_att, 14:21:07)
    4. when the portal is integrated with portal 3.0.15. (farheen_att, 14:21:43)
    5. Ken - we have to wait for the portal team to complete? (farheen_att, 14:22:00)
    6. yes (farheen_att, 14:22:02)
    7. in your absense is there anyone who can back you up? (farheen_att, 14:22:23)
    8. No (farheen_att, 14:22:26)
    9. open issue in deployment (farheen_att, 14:23:00)
    10. ACTION: Vasu talk to Santosh and come up with an ETA. (farheen_att, 14:23:20)
    11. is there a portal user story? (farheen_att, 14:23:29)
    12. ACTION: Murali update jira epic to 3433. (farheen_att, 14:24:03)
    13. ACTION: Murali check ETA for deployment. This is important to track at that level to set expectations. (farheen_att, 14:24:39)

  6. MLWB (farheen_att, 14:27:42)
    1. Sayee - working through issues no blockers (farheen_att, 14:27:53)

  7. Licensing (farheen_att, 14:28:00)
    1. - no blockers (farheen_att, 14:28:11)
    2. Justin we are dependent on SV 1.10 to get our SV checking on platform done. We are tracking down the abandoned commit. (farheen_att, 14:28:53)
    3. 3024 is the issue to track. (farheen_att, 14:29:15)
    4. Acumos-3005 should be updated. (farheen_att, 14:29:43)
    5. ACTION: Murali update Acumos-3005 (farheen_att, 14:29:57)
    6. Acumos-3065 is open, why? (farheen_att, 14:30:10)
    7. there may be documentation user stories. (farheen_att, 14:30:23)

  8. Upgrade to java 11. (farheen_att, 14:30:51)
    1. who are the teams working on this? (farheen_att, 14:30:59)
    2. ACTION: Murali follow up on the upgrade to java 11. (farheen_att, 14:31:14)
    3. Ken do you see testing related concerns. Have you started on the delivered cycle. (farheen_att, 14:31:38)
    4. Yes, Bryans release does not have portal integration. (farheen_att, 14:32:18)
    5. keep the progress on the delivered items to test. (farheen_att, 14:32:53)

  9. Pub/Sub mechanism support thru Kafka. (farheen_att, 14:33:53)
    1. Bryan - do homework to understand what is meant and done in other open source projects in the same space. (farheen_att, 14:34:21)
    2. we change component address to connect to a message bus and know how to subscribe on that bus. Incoming API subjects on the bus. It is a more flexible and cloud native approach. (farheen_att, 14:35:15)
    3. People need to understand the technology to understand the value of this approach to the Acumos project. People need to come to the table with an understanding of the technology. (farheen_att, 14:35:59)
    4. Is there a performance hit? and do we become dependent on the bus. If the bus goes down does everything stop? (farheen_att, 14:36:24)
    5. latency of transactions being filled need to be considered. Openstack would not be based on the same concept for real production clouds. (farheen_att, 14:37:15)
    6. There is a spring-cloud to help us with this. There are many message systems such as Kafka nanakube. (farheen_att, 14:37:52)
    7. To what extent will we go? (farheen_att, 14:38:02)
    8. this enables a service discovery a lot smoother. Cost is you have to replace a jar. (farheen_att, 14:38:25)
    9. wouldn't we put it out as a platform service and allow those who want to use it? (farheen_att, 14:38:49)
    10. There is a roadmap to adoption. Everything will have to be changed from APIs to message bus. (farheen_att, 14:39:41)
    11. suggestion Initially build one component that listens to the bus and reroutes that to the appropriate web API calls. (farheen_att, 14:40:11)
    12. over time as components switch over they can stop the central bus. (farheen_att, 14:40:47)
    13. Kafka are for continuous message. Such as knowing the status. Or save something on a database. We don't have to go through Kafka (farheen_att, 14:41:31)
    14. Yes, CDS is like that. It is well served by the rest interface no need to apply. (farheen_att, 14:42:03)
    15. we do need to solve the service discovery issue. When you bring up a system things aren't connected properly. (farheen_att, 14:42:30)
    16. Service discovery is not the primary use case. (farheen_att, 14:42:54)
    17. primary benefit is asynchronous use cases. Any component that wants this mechanism can switch. Those who do not don't have to. (farheen_att, 14:43:33)
    18. you are not going to solve this complex spaghetti code system by taking a half step. You want every API to report to the bus. (farheen_att, 14:44:25)
    19. what would benefit non lazy components? (farheen_att, 14:45:07)
    20. Coupling . I can start a service and no other component cares. Project needs to adopt. (farheen_att, 14:45:46)
    21. wouldn't bringing down a service change the other components? (farheen_att, 14:46:26)
    22. remote procedure calls. (farheen_att, 14:46:49)
    23. To accommodate a-synchronous would require recoding in a lot of places. (farheen_att, 14:47:29)
    24. java programmers typically don't program that way. (farheen_att, 14:47:45)
    25. it removes dependencies of trigger events. (farheen_att, 14:48:10)
    26. If you have a piece of code that says get the list of models from this user. Put a call back function that updates something. that will be tricky. (farheen_att, 14:49:00)
    27. luckily that paradigm familiar to web programmers. (farheen_att, 14:49:17)
    28. Good discussion. Let's do our homework on this. Once we have the intial module the licensing team is building we will adopt pub/sub (farheen_att, 14:50:23)

  10. Demeter ideas (farheen_att, 14:51:16)
    1. enter ideas into the etherpad. (farheen_att, 14:51:28)

  11. Self Serve release (farheen_att, 14:52:09)
    1. https://docs.releng.linuxfoundation.org/projects/global-jjb/en/latest/jjb/lf-release-jobs.html (farheen_att, 14:52:17)
    2. This will remove the long wait from LF to grant permission. (farheen_att, 14:52:57)
    3. you do one commit for the mavin and one commit in docker. Stage the release as you normally do. pre-req you must have the release job added to your jenkins job configuration. These are the two jobs in jenkins (farheen_att, 14:54:13)
    4. two configs in jenkins some projects have multiple jars and single. on a side note we are ways to release each jar independenly. If you have all of these sub modules in maven defined. (farheen_att, 14:55:08)
    5. we want to see the releases we have in the past. (farheen_att, 14:59:29)
    6. in ONAP we are not creating multiple version files. (farheen_att, 14:59:54)
    7. ONAP history and release artifacts will address that concern. (farheen_att, 15:00:15)
    8. use acumos/ and update the tags. (farheen_att, 15:03:01)
    9. Thank you for stepping up and sharing with the PTLs. Expect Eric Ball from LF. LF turn around time is 24 hours. If you follow this process you can release your artifacts yourself. (farheen_att, 15:04:51)

  12. 3433 3430 are in a delivered state. (farheen_att, 15:05:25)
    1. verify with the portal team that the expected items for SV and jenkins workflow are completed. (farheen_att, 15:05:46)
    2. which commit were they delivered. (farheen_att, 15:06:07)
    3. ACTION: Vasu double check commits to Murali and Bryan. (farheen_att, 15:06:41)


Meeting ended at 15:06:46 UTC (full logs).

Action items

  1. Nat will align the resource to join the next onboarding scrum call
  2. Murali put it as a blocker waiting for a resource. One week task for a skilled developer.
  3. Vasu talk to Santosh and come up with an ETA.
  4. Murali update jira epic to 3433.
  5. Murali check ETA for deployment. This is important to track at that level to set expectations.
  6. Murali update Acumos-3005
  7. Murali follow up on the upgrade to java 11.
  8. Vasu double check commits to Murali and Bryan.


People present (lines said)

  1. farheen_att (95)
  2. collabot` (3)


Generated by MeetBot 0.1.4.