#acumos-meeting: Architecture Committee

Meeting started by farheen_att at 14:05:16 UTC (full logs).

Meeting summary

  1. Manually deploy Acumos ML based xApp in RIC and Adapter speaks RMR protocol to RIC (Guy/Manoop) (farheen_att, 14:12:34)
    1. https://wiki.o-ran-sc.org/display/RICA/ML-based+xApp (farheen_att, 14:14:56)
    2. Guy reviewing link above. (farheen_att, 14:15:07)
    3. Do we need the central hub? Latency is an issue in messaging, (farheen_att, 14:19:36)
    4. we would have to create a model runner for every model we support in RMR. (farheen_att, 14:20:05)
    5. endpoints can be called by java. (farheen_att, 14:20:24)
    6. the model runner takes the services the user has written and presents a net interface. Standard would present a rest interface. (farheen_att, 14:20:55)
    7. this two step approach can communicate with all languages. (farheen_att, 14:21:18)
    8. having a config manager is better than a hop from the services (farheen_att, 14:22:08)
    9. view the Future work section of the link above (farheen_att, 14:26:57)

  2. Blockers for Clio release (farheen_att, 14:27:54)
    1. Resource issue blocker (farheen_att, 14:28:06)
    2. Guy - in the next few days we will get an update from the resource. (farheen_att, 14:28:25)
    3. Priya - End of this week we can provide an ETA. (farheen_att, 14:29:09)
    4. Bryan is sending us the instructions on how to set up a jenkins job for SV. (farheen_att, 14:29:41)
    5. Ken- Deploy to Kubernetes is a blocker. We're being asked to run a curl command. It should be done through the Admin gui. The portal team did not have a heads up for this. There are no user stories. (farheen_att, 14:32:30)
    6. Manoop Acumos- 3433? (farheen_att, 14:36:14)
    7. Tausif - it is in a delivered state. (farheen_att, 14:36:32)
    8. Acumos - 3340 SV dependent on the next version of portal. (farheen_att, 14:37:10)
    9. Tausif - this is delivered. (farheen_att, 14:37:17)
    10. Manoop - What is delivered? SV team has opened a story or sub-task to call a reference or API of sub epics. (farheen_att, 14:38:10)
    11. Tausif Justin has to test. (farheen_att, 14:38:28)
    12. Justin - There is an issue with the current version. We will have a version bump for SV and LUM. (farheen_att, 14:39:31)
    13. Justin Licensing and SV will change. Because we're moving checking into portal I will work with Tausif. (farheen_att, 14:40:35)
    14. Mural - Acumos-3538 improvements RTU comminication with LUM server and UI for LUM editor. (farheen_att, 14:48:02)
    15. Parag - Waiting on review. (farheen_att, 14:48:16)
    16. https://wiki.acumos.org/display/REL/Clio+Release+Project+Status (farheen_att, 14:49:58)
    17. Murali reviewed demo calendar. (farheen_att, 14:50:45)
    18. Guy AIO Jenkins build. We would like help to reduce the size and efficiencies. (farheen_att, 14:53:08)
    19. Justin - the failure rate is pretty high. When there is a build failure that causes an issue because the user gets stuck. (farheen_att, 14:53:41)
    20. error found is cryptic (farheen_att, 14:53:51)
    21. it looks like the R model is while having dependencies can pull the base model. (farheen_att, 14:54:54)
    22. Guy - difficult to do system level installs in python. The high failure rate is using the docker in docker using All in One. The MS generation doesn't work well in an All in One installation. (farheen_att, 14:56:15)
    23. this is temporary. We will have the kubernetes deployment. (farheen_att, 14:57:11)
    24. Guy - an issue with running docker generation in kubernetes. (farheen_att, 14:57:30)
    25. Justin - Calling too many times can be denial of service. This happens in both AIO and docker compose. (farheen_att, 14:58:28)
    26. ACTION: Guy - Add this to Demeter release. (farheen_att, 14:58:57)
    27. ACTION: Manoop - Add this topic to the Architecture Committee call. (farheen_att, 14:59:11)
    28. ACTION: Justin - prepare to raise this issue at the face to face meeting. (farheen_att, 14:59:36)
    29. Parag - What is our recommendation for our users? (farheen_att, 14:59:51)
    30. Manoop - All in One is available for Kubernetes style. For enterprise we want to use Docker compose. (farheen_att, 15:00:22)
    31. Ken recommends if you want to start from scratch then use AIO. If you're going to use an existing nexus then the Docker compose. (farheen_att, 15:00:58)
    32. Manoop - Parichay was primarily working on reducing these gaps. (farheen_att, 15:01:19)
    33. Parag - From Acumos client perpective they can mix and match both approaches. They have a K8 cluster and cloud. They want to setup Acumos in that environment. Docker compose gives more control but requires extensive understanding of Acumos. AIO is good for a quick. How easy is it to upgrade? (farheen_att, 15:03:00)
    34. Ken - set up a helm chart that has non-core and a helm chart for core components. This way all the core components are in one pod. It reduces the risk of opening up the doors and deploy a stateless component into a pod. That will be covered in the D release. (farheen_att, 15:04:16)
    35. Manoop - Gaps were identified by Bryan. Streamlining the delivery of the product is a priority in Demeter. (farheen_att, 15:05:30)
    36. ACTION: Manoop list Tausif's topic as a first topic in next weeks agenda item. (farheen_att, 15:06:14)
    37. Mural - Demeter agenda Reuben shared a proposed agenda. Asked the PTLs to come up with ideas for November workshop. Prepare and have ready by this Friday. (farheen_att, 15:07:12)
    38. Manoop - This is a chance to work with your company management to come with focused ideas of what your company cares about. Bring that to these discussions so we can identify slots for the focused agenda. (farheen_att, 15:07:56)
    39. ACTION: PTLs bring key objectives for Demeter to the face to face. (farheen_att, 15:08:17)


Meeting ended at 15:08:20 UTC (full logs).

Action items

  1. Guy - Add this to Demeter release.
  2. Manoop - Add this topic to the Architecture Committee call.
  3. Justin - prepare to raise this issue at the face to face meeting.
  4. Manoop list Tausif's topic as a first topic in next weeks agenda item.
  5. PTLs bring key objectives for Demeter to the face to face.


People present (lines said)

  1. farheen_att (52)
  2. collabot_ (3)


Generated by MeetBot 0.1.4.