#acumos-meeting: Architecture Committee

Meeting started by farheen at 14:02:48 UTC (full logs).

Meeting summary

  1. Agenda portal topics. Onboarding version (Bryan). Release status (Murali) (farheen, 14:06:02)
    1. Tausif is sharing a word document (farheen, 14:07:51)
    2. Issues reflecting the Search functionality. (farheen, 14:08:36)
    3. reviewed Catalog search issues. Viewing the catalog screen. (farheen, 14:11:11)
    4. CDS Search requires exact string match. (farheen, 14:11:32)
    5. problem: today the front end is flitering the data. From data base we only get 10 records. If you go for all records then you cache everything and then present it. (farheen, 14:14:17)
    6. niche search or site search? (farheen, 14:17:53)
    7. Manoop - Site search addresses common problem. Does the site search support only catalog searches such as search for 5G (farheen, 14:18:38)
    8. to search within the catalog would be a nice feature but in the screen they have shown is the first 5. This doesn't expose the contents of the catalog. (farheen, 14:19:30)
    9. Tausif - the search criteria should be applicable for all the columns. (farheen, 14:20:26)
    10. Manoop - we are trying to apply this logic throughout the tables. Should we add a custom search field consistently? (farheen, 14:20:56)
    11. Tausif - yes this is what we want to achieve. (farheen, 14:21:10)
    12. Assuming everyone agrees that this is valuable and needed then what is your proposal? (farheen, 14:21:28)
    13. Tausif - modify CDS to do that. (farheen, 14:21:42)
    14. Tausif ask the user to put a % after (farheen, 14:23:52)
    15. Sayee - CDS calls are causing latency. This should not be database dependencies. (farheen, 14:24:18)
    16. Tausif either you get all the data on the front end to slow things down. (farheen, 14:25:00)
    17. Sayee- It should be more dynamic. (farheen, 14:25:45)
    18. Tausif - Yes either you make multiple calls to CDS or you make a call to the front end. If the community agrees to get all the data at the front end then it is fine. (farheen, 14:26:20)
    19. Manoop - Rather than imposing new requirements to CDS per table. Getting the data onto UI and making optimal call to CDS and filtering on the UI would be a better approach. (farheen, 14:26:55)
    20. Chris - You have a lot of features in responsive manner. There is a great risk of blowing up the users browser. The user you give 10 rows of data and not 1000s. (farheen, 14:27:47)
    21. Manoop - We don't need to add changes to CDS but portal side will handle it. (farheen, 14:28:22)
    22. Tausif - There will be a lot of work that is time consuming for the front end developers. (farheen, 14:28:49)
    23. Manoop - We have to start adapting chacheing mechanism and using the elastic features unless there are millions of records. (farheen, 14:30:20)
    24. We should go on the UI side of filtering. (farheen, 14:30:34)
    25. Parag - It depends on the UI filtering when there are getting subset of 1000 records then it will require server side filtering. (farheen, 14:35:37)
    26. Change in revision version attribute as set by Onboarding is breaking SV (farheen, 14:36:23)

  2. Change in revision version attribute as set by Onboarding is breaking SV (farheen, 14:36:30)
    1. Bryan - Incrementing integer that changes the logic. (farheen, 14:38:19)
    2. Phillippe I tested with Muktar today and the test was successful. (farheen, 14:38:42)
    3. Bryan - there was nothing I did to change that. (farheen, 14:39:08)

  3. Acumos-3531 (farheen, 14:39:21)
    1. We are publishing one model in two catalogs and the version changes in the second catalog. (farheen, 14:50:16)
    2. ACTION: Ken work with Nancy from the test team. (farheen, 14:50:32)

  4. Clio release blockers and issues. (farheen, 14:50:53)
    1. November 6 will be the ONAP demo (farheen, 14:51:24)
    2. Documentation for Acumos C client. We are OK with the user guide. The developer guide is not finished. I didn't anticipate the developer would be out this week. (farheen, 14:52:04)
    3. the developer guide will be late. (farheen, 14:52:32)
    4. Murali covered all open issues and user stories with the PTLs. (farheen, 14:56:14)


Meeting ended at 15:02:10 UTC (full logs).

Action items

  1. Ken work with Nancy from the test team.


People present (lines said)

  1. farheen (41)
  2. collabot (3)


Generated by MeetBot 0.1.4.