#acumos-meeting: Architecture Committee

Meeting started by farheen at 14:12:57 UTC (full logs).

Meeting summary

  1. Release Status and issues (farheen, 14:13:24)
    1. no blockers but there are critical and high defects that need to be addressed. (farheen, 14:14:59)
    2. Epic 3256 was expecting to have the raw client library delivered. (farheen, 14:15:58)
    3. Manoop worked with Priya on a model that had issues with protobuf conversion. When they start using the new raw client lib they will not go through the protobuf conversion. This needs to be watched and closed. (farheen, 14:16:55)
    4. Guy - all the code is there. We have to sit down with Tommy to show him how to use it. (farheen, 14:17:17)
    5. It's up to Guy and Tommy to get it going. (farheen, 14:17:32)
    6. Murali - is there user story? (farheen, 14:17:55)
    7. Manoop create a task against the epic to track. (farheen, 14:18:12)
    8. ACTION: Guy create a task on Epic 3256 regarding meeting with Tommy. (farheen, 14:18:55)
    9. Are we able to make progress on test? (farheen, 14:19:08)
    10. Ken - Test team is blocked on an issue with the license editor to not be able to proceed. (farheen, 14:19:33)
    11. It is a port issue that we will have resolved shortly. (farheen, 14:19:44)
    12. Access to the editor is a problem not the edtior. It is completely separate installation. Bryan offered the instructions on Tuesday but no one was able to set up. (farheen, 14:21:03)
    13. Bryan Security verification and deployment are separate installations. Not a part of the core. It is a learning process. (farheen, 14:21:54)
    14. Ken - Does each instance of Acumos need it's own Jenkins? Can we re-use the same jenkins? (farheen, 14:22:33)
    15. Bryan - Each instance of acumos today has to have it's own jenkins. In the future that will not be required. (farheen, 14:23:43)
    16. Vineet - log user stories have to be incorporated into all the components. (farheen, 14:24:43)
    17. Manoop - Review that they are the java objects but using these modules will have to incorporate into the maintenance release. We need someone can verify, re-use. (farheen, 14:25:38)
    18. Vineet - Yes, we want to show what we have done. (farheen, 14:25:58)
    19. ACTION: Manoop add Vineet's demo of logs in Clio to next weeks agenda. (farheen, 14:26:29)
    20. Murali - Clio press release slide reminder. Please respond to my request. (farheen, 14:26:55)
    21. Ken - License editor. I am finding in ML WOrkbench as well in configuring all the ports. I understand they want the some pluggable and non pluggable. Is there ML workbench had to have a fully qualified name and ports. Are we going to look at Acumos as much more pluggable. Are we going to start to look from an architectural perspective. (farheen, 14:28:33)
    22. Manoop - Requires a kubernetes deployment expert. (farheen, 14:28:48)
    23. Bryan components do interact intnernally. Front door are designed to be exposed through the ingress end point. They are presented in an iframe and their content comes from a front end service. (farheen, 14:29:29)
    24. Ken - Dockerized version it doesn't matter which Docker or K8. We have to pick a port. Service names were said to use the fully qualified names. (farheen, 14:30:21)
    25. Byran - As mentioned even under docker you can communicate outside of the cluster. Every docker is known by it's docker name. Exact same in k8 use the cluster domain name. (farheen, 14:31:15)
    26. Bryan - possible to have secure intra connections using the service page. (farheen, 14:31:36)
    27. Ken - If you're talking inside the container everyone can start using the same port. I can't test. (farheen, 14:32:08)
    28. Bryan - every component uses the same port at a different service. Any component that has to have a service exposure it has to be mapped. External mapping should be minimal. (farheen, 14:32:46)
    29. Ken - What I usually get is everything needs to be external. I don't know if someone has hard coded to the external port. (farheen, 14:33:18)
    30. Bryan encourages to review the architecture diagram. (farheen, 14:33:34)
    31. Ken - The architectural perspective it needs to be reviewed by the architecture committee. (farheen, 14:35:24)
    32. Manoop - Follow the architecture guidelines. (farheen, 14:35:58)
    33. is ML Workbench on that diagram? (farheen, 14:36:09)
    34. yes (farheen, 14:36:13)
    35. there is a core and they do need to be updated. Some aspects have been clarified. (farheen, 14:36:33)

  2. Apache Nifi Integration - Nat (farheen, 14:38:25)
    1. IBM supported Romeo is from IBM. IBM AIF projects to work with Acumos AI (farheen, 14:39:04)
    2. the models we onboard on the platform can leverage this tool set for unbiased vs biased context. Ken worked with design tools and the Nifi pipeline. Romeo has worked out a prototype of Apache Nifi AI 360. Both Acumos AI and AIF will work together. (farheen, 14:40:13)
    3. Romeo - sharing screen. we have a couple of toolkits (farheen, 14:40:42)
    4. AI Bias tool lets you check for bias. Python library. In order to integrate thru Nifi possibilities. Hello fairness script but data is generated in the script and is editable to see how the lib works (farheen, 14:42:02)
    5. data driven ground truth and model predictions in the database. After that fairness call (farheen, 14:42:28)
    6. Able to add bias detector to the data flow. (farheen, 14:47:14)
    7. https://wiki.acumos.org/display/AR/Meetings (farheen, 14:47:44)
    8. recording of demo recorded in link above. (farheen, 14:48:04)
    9. the models with high bias their bias is removed from the nifi data. (farheen, 14:51:22)
    10. will Ai360 be a library or service? Will it be deployed on need to know basis? (farheen, 14:51:51)
    11. all 3 possible. pipinstall ai360 python library. Can be wrapped in any framework. Also can be provided as rest. (farheen, 14:52:44)
    12. ACTION: Nat form a focus team and call around Ai 360. Once determined we can propose to TSC. (farheen, 14:53:14)
    13. Nat - The Security verification and ml workbench teams. (farheen, 14:53:39)
    14. Sayee - Model training steps? (farheen, 14:53:57)
    15. - Romeo - Yes, it can be integrated or as a separate microservice. It is up to the team to decide. (farheen, 14:54:31)
    16. Nat - We have to have a focused discussion. There are two other products Robust and inaudible. (farheen, 14:55:18)
    17. Romeo - I will be in Lyon next week. (farheen, 14:56:05)
    18. Nat and Phillippe will be there. Martin will be there too. (farheen, 14:56:43)
    19. ACTION: Nat report out on your findings at the face to face in Lyon. (farheen, 14:57:28)
    20. ACTION: Murali add the Demeter release events to the lists.acumos.org calendar. (farheen, 15:00:29)


Meeting ended at 15:00:36 UTC (full logs).

Action items

  1. Guy create a task on Epic 3256 regarding meeting with Tommy.
  2. Manoop add Vineet's demo of logs in Clio to next weeks agenda.
  3. Nat form a focus team and call around Ai 360. Once determined we can propose to TSC.
  4. Nat report out on your findings at the face to face in Lyon.
  5. Murali add the Demeter release events to the lists.acumos.org calendar.


People present (lines said)

  1. farheen (59)
  2. collabot (3)


Generated by MeetBot 0.1.4.