#acumos-meeting: Architecture Committee

Meeting started by farheen_att at 15:03:18 UTC (full logs).

Meeting summary

  1. Agenda (farheen_att, 15:04:00)
  2. Acumos 3733 - Optional license. (farheen_att, 15:05:13)
    1. recording the wireframe review. See Architecture Committee Meeting Minutes page for recording. (farheen_att, 15:05:57)
    2. recording will be on the wiki and also in the Acumos 3733 (farheen_att, 15:20:45)

  3. New agenda items (farheen_att, 15:21:20)
    1. Jason RTU or model that has already been onboarded. You may receive a denial method. The easiest path is to re-publish the model. (farheen_att, 15:22:35)
    2. ACTION: Jason post migration documentation for users to migrate to rite to use. (farheen_att, 15:22:54)
    3. Guy - There may be a way to re-onboard the models without having the user go through re-publishing. (farheen_att, 15:23:42)
    4. Needs to be discussed. (farheen_att, 15:29:37)

  4. Onboarding Architecture Phillippe (farheen_att, 15:30:02)
    1. https://wiki.acumos.org/display/MOB/Architecture+Diagram+for+Demeter+release (farheen_att, 15:30:06)
    2. Guy invoke the existing artifacts. Why don't we generate the artifacts on the fly when DS is spun up. Not sure why we pre-compute these things. (farheen_att, 15:31:20)
    3. Phillipe - Impacts on portal - add the possibility to upload this file to Acumos. (farheen_att, 15:31:42)
    4. Phillippe - We can also add the license file. Today dockerized models don't allow licenses to be added. This is a good opportunity to add these license files here. This is a good opportunity to push this file to nexus (farheen_att, 15:32:35)

  5. Acumos Platform support (farheen_att, 15:43:16)
    1. Bryan - Proxy - All components leads. I need to know does your component require anything from the internet? (farheen_att, 15:44:13)
    2. Bryan Meaning the component retrieving. (farheen_att, 15:44:30)
    3. other than what the java requires proxy settings. Are there others who require a proxy setting? (farheen_att, 15:44:59)
    4. Guy - the docker host wanted that for some instances. (farheen_att, 15:45:46)
    5. Bryan - if you are using a proxy then you need to document that in your user guide. (farheen_att, 15:46:04)
    6. Bryan what are the features that require proxies and document it. (farheen_att, 15:46:27)
    7. It is better to plan ahead then to find proxy errors in testing. (farheen_att, 15:46:56)
    8. Ask yourself does your component require anything that requires a proxy. Document this ahead of time to avoid issues with installers of Acumos. (farheen_att, 15:53:45)

  6. Filebeat (farheen_att, 15:53:51)
    1. Azure does not support sharing (re-write many). So Bryan had to turn off logs. Workarounds are not acceptable. Instead put the logs in standard out. This standard gets shipped to logstash. (farheen_att, 15:55:24)
    2. this eliminates the dependency for persistant volume to logs. (farheen_att, 15:55:49)
    3. Guy - you don't want to buffer logs too much because you don't want recent logs to be flushed by the buffer. (farheen_att, 15:56:49)
    4. bryan agree it is simple but substantial overhead such as in Azure. It is inconvenient to not be able to share persistent logs across cluster nodes. (farheen_att, 15:57:36)
    5. Generic environment (accepts), Azure throws logs out the window, and ... docker host? (farheen_att, 15:58:24)

  7. Demeter Release wiki jira updates (farheen_att, 16:00:32)
    1. ACTION: all PTLs add your epics and user stories with the Demeter Release label! (farheen_att, 16:00:50)


Meeting ended at 16:01:08 UTC (full logs).

Action items

  1. Jason post migration documentation for users to migrate to rite to use.
  2. all PTLs add your epics and user stories with the Demeter Release label!


People present (lines said)

  1. farheen_att (33)
  2. collabot` (3)


Generated by MeetBot 0.1.4.