#acumos-meeting: Architecture Committee

Meeting started by farheen_att at 15:02:27 UTC (full logs).

Meeting summary

  1. SoaJS demo by Antoine Hage (farheen_att, 15:07:34)
    1. meeting being recorded. (farheen_att, 15:08:42)
    2. SoaJS is an open tool that Anton proposed. They are interested in integrating with Acumos. We want to start with a simple PoC in the deployment area. We should ask questions. (farheen_att, 15:09:38)
    3. meeting being recorded and will be available. (farheen_att, 15:10:17)
    4. on wiki.acumos.org under Architecture Committee meetings (farheen_att, 15:10:38)

  2. Deployment best practices (farheen_att, 15:54:37)
    1. Justin we are running into issues with 3rd party dependencies. We have to go in and reconfigure. (farheen_att, 15:55:43)
    2. Manoop - When Python code version is the latest? Guy - We're using something in our build process and we don't specify enough the build fails. This can be easily fix this by saying we want this version. For explicitly declared packages we specify an exact version. (farheen_att, 15:57:43)
    3. It's the generic version that we use with model runner where it's failing. (farheen_att, 15:58:02)
    4. Guy - it is a part of the common services. There is a base requirements.txt and expand that. The idea to create our own docker image is a good idea but it's difficult. It also speeds up generation. (farheen_att, 15:58:49)
    5. This is serious problem. Can we make this a priority for Common Services. (farheen_att, 15:59:48)
    6. Guy - yes we will include it in Demeter release. (farheen_att, 16:00:07)

  3. Clios maintenance release patch - Michelle (farheen_att, 16:00:38)
    1. Licensing with accessing Nexxus we needed Portal federation and the license management library. It's been done and delivered. What is the safest way to deliver it in the Demeter release. (farheen_att, 16:02:36)
    2. Manoop - were they successful in packaging it on the Clio branch Rajesh. (farheen_att, 16:03:44)
    3. Nat - We mentioned on the PTL call. Amol and Rajesh are having issues recreating the environment 3.28. (farheen_att, 16:04:29)
    4. Manoop - can we add a snap shot patch? (farheen_att, 16:05:17)
    5. Justin - Can you take the Demeter code base with packages for Federation. CDS was upgraded and there will issues there. I took two separate Docker images that are snap shots (farheen_att, 16:06:13)
    6. I am not sure if portal back end has taken the integration. (farheen_att, 16:06:52)
    7. Justin - we took the Clio branch and built federation and portal be and it worked fine. We made sure Nexus didn't have anonymous access. The AIO allowed annonymous access. (farheen_att, 16:07:32)
    8. Manoop - Rajesh why could you not move forward on the Clio maintenance release. Snapshots that Justin provided should work. Any concerns with anyone, testing team portal team or federation. (farheen_att, 16:08:18)
    9. Ken - we're going to take the existing Clio and add the updated federation and onboarding and the portal be. (farheen_att, 16:08:53)
    10. Manoop - We keep Clio Maint as is. We change these two snapshots. These fixes the patch with this issue. (farheen_att, 16:09:28)
    11. there should be two docker images we are interested in for this fix

docker pull nexus3.acumos.org:10003/acumos/acumos-portal-be:3.0.29-SNAPSHOT docker pull nexus3.acumos.org:10003/acumos/federation-gateway:3.0.3-SNAPSHOT These 2 images are not using any code changes from Demeter. The only test is to ensure Nexus connection is ok (farheen_att, 16:11:26)
    12. ACTION: Justin - move this patch to the staging version. (farheen_att, 16:21:25)
    13. ACTION: Ken - do IST testing on Justin's patches (farheen_att, 16:21:58)
    14. ACTION: Vasu - update the release notes and publish once IST approves the patches. (farheen_att, 16:22:30)
    15. ACTION: Vasu - move the staging version onto acumosr-dev (farheen_att, 16:23:50)


Meeting ended at 16:23:57 UTC (full logs).

Action items

  1. Justin - move this patch to the staging version.
  2. Ken - do IST testing on Justin's patches
  3. Vasu - update the release notes and publish once IST approves the patches.
  4. Vasu - move the staging version onto acumosr-dev


People present (lines said)

  1. farheen_att (32)
  2. collabot` (3)


Generated by MeetBot 0.1.4.