#acumos-meeting: Architecture Committee

Meeting started by farheen_att at 14:06:51 UTC (full logs).

Meeting summary

    1. Agenda - Offshore is on holiday. The agenda is open today. (farheen_att, 14:07:38)

  1. Michelle - Look out for emails requesting plus ones. Alex sent a code review email and it went unwatched for a little over one week. Please do code reviews. (farheen_att, 14:08:52)
    1. Michelle - Alex sent email for code review for the LUM. No one gave a +1 or -1 for one week. (farheen_att, 14:09:26)
    2. The committer should be able to support. (farheen_att, 14:10:12)
    3. Michelle - documentation - I needed to assign to the maintenance release sprint. (farheen_att, 14:10:57)
    4. ACTION: Murali create a sprint in jira for the Demeter maintenance release. (farheen_att, 14:11:28)
    5. Secure way to launch the RTU editor jira ticket. Priya had a suggestion for Clio. (farheen_att, 14:12:20)
    6. Priya - who can access these features? Super admin? if we restrict or not expose these features as they are today the way can still expose these features using the reverse proxy. API tokens get authenticated first from Kong. Then to portal B. We don't want to directly expose these to anybody. If this can be done it will be easier. (farheen_att, 14:14:13)
    7. Priya - From the role based access perspective I wasn't able to discuss with Rajesh. (farheen_att, 14:14:40)
    8. 1. I want authenticated access to the RTU editor and not a portal interface for that. 2. and use Priya's reverse proxy to keep the RTU secure. (farheen_att, 14:21:32)
    9. ACTION: Priya - add the reverse proxy solution to (farheen_att, 14:21:51)
    10. https://jira.acumos.org/browse/ACUMOS-4063 (farheen_att, 14:22:05)
    11. Manoop - regarding open src integration. We will have an open solution with a model and show an internal use case. (farheen_att, 14:23:11)
    12. Nat- is pursuing the lifecycle of the feature. I need confirmation that we have a use case and I can put this use case into open source. I want to check with the community if we have a use case to integrate Ai360 with Acumos. (farheen_att, 14:24:43)
    13. ACTION: Manoop add Nat's request for internal use case confirmation in the Architecture backlog. (farheen_att, 14:25:23)

  2. Action and Blocker in Demeter (farheen_att, 14:25:55)
    1. Murali - Portal team SOAJS user story was created by Manoop Acumos-3095. (farheen_att, 14:26:51)
    2. ACTION: Murali initiate a meeting regarding acumos-3095. (farheen_att, 14:28:24)
    3. ACTION: Ken start communication with Sanjay on how to install SOAJS. (farheen_att, 14:31:15)
    4. Manoop - Should we use his existing SOAJS or install our own? (farheen_att, 14:31:42)
    5. We should install this in the IST environment. (farheen_att, 14:31:56)
    6. we can get Bobbie's help to install SOAJS. (farheen_att, 14:32:24)
    7. How do we do the hooks for SOAJS. (farheen_att, 14:32:34)
    8. Manoop - we are working on that in #link https://jira.acumos.org/browse/ACUMOS-4070 (farheen_att, 14:34:32)
    9. Ken - standing up SOAJS it still won't have access to nexus, etc. True? (farheen_att, 14:42:23)
    10. no it will have access just standing up is not good enough. (farheen_att, 14:43:07)
    11. ACTION: Sayee - Address Acumos-3797Acumos-2385 (farheen_att, 14:47:25)
    12. ACTION: Wenting address Acumos-2385. (farheen_att, 14:48:14)
    13. Murali is waiting for TechM team to respond about taking over Acumos-3797. (farheen_att, 14:50:27)
    14. https://jira.acumos.org/browse/ACUMOS-3956 (farheen_att, 14:52:35)
    15. Phillippe it is urgent to work on this 3956. Orange will provide Python developers next week. There is a concern about merge conflict. I can not merge my own change. (farheen_att, 14:54:13)
    16. This change was created one month ago. Now we are waiting for two weeks a comment or plus 2 from Paul and we have not gotten any response from Paul. This change blocks future work. It is urgent to merge this change to continue. (farheen_att, 14:55:45)
    17. ACTION: Guy work with Paul and Eric to unblock Phillippe. (farheen_att, 14:58:20)
    18. Murali - Anwar asked to update the architecture score card. (farheen_att, 15:00:05)
    19. ACTION: Manoop link the score card to the Project status page. (farheen_att, 15:00:37)
    20. Guy on the next architecture meeting we'd like to do a brief demo of CLI onboarding using C++. Martin and his student will demo. (farheen_att, 15:01:22)


Meeting ended at 15:01:45 UTC (full logs).

Action items

  1. Murali create a sprint in jira for the Demeter maintenance release.
  2. Priya - add the reverse proxy solution to
  3. Manoop add Nat's request for internal use case confirmation in the Architecture backlog.
  4. Murali initiate a meeting regarding acumos-3095.
  5. Ken start communication with Sanjay on how to install SOAJS.
  6. Sayee - Address Acumos-3797Acumos-2385
  7. Wenting address Acumos-2385.
  8. Guy work with Paul and Eric to unblock Phillippe.
  9. Manoop link the score card to the Project status page.


People present (lines said)

  1. farheen_att (38)
  2. collabot` (3)


Generated by MeetBot 0.1.4.