#acumos-meeting: Architecture Committee

Meeting started by farheen_att at 14:05:11 UTC (full logs).

Meeting summary

  1. Agenda (farheen_att, 14:05:24)
    1. Installation of SOAJS and review the PTL current architecture diagram. (farheen_att, 14:06:58)

  2. SOAJS (farheen_att, 14:07:09)
    1. AT&T team received instructions from SOAJS team to install SOAJS remotely (farheen_att, 14:07:46)
    2. Anotoine planning on securing resources to provide HELM charts. (farheen_att, 14:08:06)
    3. Antoine is waiting for resources. If he can't find resources he will inform Manoop once installed. (farheen_att, 14:08:49)
    4. Bobbie installed SOAJS in a development environment. (farheen_att, 14:09:25)
    5. is it configured with docker registries to pull the docker images? Ken: no (farheen_att, 14:09:54)
    6. Manoop - in the dev environment we are the users. We need to deploy and test (farheen_att, 14:11:18)
    7. Ken connectivity needs to connect back to nexus. (farheen_att, 14:11:41)
    8. Vaibhav: Is there anyone who can help us from SOAJS to help us configure. (farheen_att, 14:12:19)
    9. Antoine yes, I can help you and it takes about 2 minutes. (farheen_att, 14:12:40)
    10. Vaibhav do you have links? (farheen_att, 14:12:54)
    11. Antoine yes check the detailed documentation. (farheen_att, 14:13:47)
    12. Manoop how can he configure the docker registry. (farheen_att, 14:14:06)
    13. Vaibhav first we will review the documentation and then get on a call with Antoine. (farheen_att, 14:15:02)
    14. Manoop - What should be our overall design while making API calls to SOAJS, etc.. (farheen_att, 14:15:21)
    15. Manoop - Once we have the right step set up we can take the decision to that step. (farheen_att, 14:15:40)
    16. Vaibhav - Who will be leading this? I went through the documentation to start a daemon you need a profile. Do we need a pre-defined profile for deploying the model. How should we be changing the profile. That kind of documentation I am looking for. (farheen_att, 14:16:49)
    17. Vaibhave What packages should we be using. It comes out with a lot of things. What things have to be used. (farheen_att, 14:17:41)
    18. Manoop - I will be coordinating your questions from the architecture perspective. How it will be used in details have to be taken to Antoine. (farheen_att, 14:18:58)
    19. Manoop we will discuss these questions before taking them to Antoine and team. (farheen_att, 14:19:16)
    20. ACTION: Vaibhav provide questions to Manoop for architecture and detailed questions to Antoine. (farheen_att, 14:20:01)
    21. Ken - it doesn't have to be K8. (farheen_att, 14:20:19)
    22. ACTION: Ken provide Manoop with the details for SOAJS resources. (farheen_att, 14:21:46)
    23. Manoop - We need two development teams. (farheen_att, 14:22:10)
    24. Priya - we have to have deployments in the same environment as kubernetes. Second dev vm has deployed jenkins. If we can use that server it will help. (farheen_att, 14:23:00)
    25. Ken - Jenkins is running on the core vm. (farheen_att, 14:23:22)
    26. Priya - there is one on the dev server. There is another one that Santosh uses for the k8 environment. (farheen_att, 14:23:47)
    27. Ken we don't want the deploy to an environment in it's own namespace. I guess you need another namespace. (farheen_att, 14:24:34)
    28. Antoine SOAJS needs its own namespace then you start to create your own environments with their own namespaces. It doesn't put you into a cluster. (farheen_att, 14:25:09)
    29. Antoine - If you want to create in the same cluster another cluster or deploy to cloud. (farheen_att, 14:25:41)

  3. Architecture diagram review (farheen_att, 14:26:47)
    1. Onboarding Guy Phillippe (farheen_att, 14:28:31)
    2. Guy - We added Jenkins to the onboarding microservices. (farheen_att, 14:32:21)
    3. Security verification also calls jenkins (farheen_att, 14:32:58)
    4. Manoop we want to use the same deployment client. It would be simpler to switch the api calls to soajs api calls. (farheen_att, 14:33:40)
    5. Priya should we stop working on the defect about jenkins deployment to kubernetes? (farheen_att, 14:34:01)
    6. Manoop yes that is right. (farheen_att, 14:34:10)
    7. Phillippe - Onboarding add the C++ client under tools. (farheen_att, 14:35:26)
    8. onboarding add the c++/pythong client under tools. (farheen_att, 14:35:48)
    9. ACTION: Michelle work with Manoop to update the architecture diagram. (farheen_att, 14:37:09)


Meeting ended at 14:51:52 UTC (full logs).

Action items

  1. Vaibhav provide questions to Manoop for architecture and detailed questions to Antoine.
  2. Ken provide Manoop with the details for SOAJS resources.
  3. Michelle work with Manoop to update the architecture diagram.


People present (lines said)

  1. farheen_att (44)
  2. collabot` (3)


Generated by MeetBot 0.1.4.