#chaoss-community: Monthly Metrics call

Meeting started by GeorgLink at 19:02:08 UTC (full logs).

Meeting summary

  1. Software committee updates (GeorgLink, 19:04:31)
    1. https://unomaha.zoom.us/j/720431288 (GeorgLink, 19:04:57)
    2. GrimoireLab repositories are contuing to move to CHAOSS GitHub organization. Also integration collaboration with GHData is continuing. (GeorgLink, 19:06:48)
    3. if help is needed, the IRC channel would be a good place to be. (GeorgLink, 19:10:47)
    4. i.e., help with software - we will monitor the IRC more closely. (GeorgLink, 19:11:13)
    5. tutorials will be posted to the new CHAOSS YouTube channel (GeorgLink, 19:13:56)

  2. Google Summer of Code submission update (GeorgLink, 19:14:16)
    1. application submitted. waiting on Google now (GeorgLink, 19:14:37)

  3. LFLS BoF session update (GeorgLink, 19:14:48)
    1. waiting for information from LF what kind of room we will have to determine what kind of interaction we can have (GeorgLink, 19:15:07)
    2. focus will be on Diversity and Inclusion (GeorgLink, 19:15:17)

  4. CHAOSSCon (GeorgLink, 19:17:17)
    1. The first CHAOSSCon was run in cooperation with GrimoireCon (GeorgLink, 19:17:38)
    2. day before FOSDEM in Brussels (GeorgLink, 19:18:02)
    3. https://grimoirelab.github.io/con/ (GeorgLink, 19:18:15)
    4. Schedule is on the website https://grimoirelab.github.io/con/ (GeorgLink, 19:18:28)
    5. maybe have a CHAOSSCon at the Open Source Summit North America (GeorgLink, 19:25:24)

  5. Risk Metric (GeorgLink, 19:25:34)
    1. almost ready to merge (GeorgLink, 19:25:41)
    2. https://github.com/chaoss/metrics/pull/45 (GeorgLink, 19:25:48)
    3. Add a third column to metrics tables? Maybe "known implementation from software side" or "qualitative ways to understand a metric" (GeorgLink, 19:27:13)
    4. maybe a map of use cases of the tools (GeorgLink, 19:28:19)
    5. problem with use cases: becoming out of data as software (and metrics) advance. (GeorgLink, 19:29:15)
    6. https://github.com/chaoss/metrics/blob/master/activity-metrics-list.md (GeorgLink, 19:31:00)
    7. we started providing more information on metrics, but we stopped working on it for a while; now we want to bring back this additional information (GeorgLink, 19:31:43)
    8. ACTION: link metrics out to metric detail pages (GeorgLink, 19:38:34)
    9. We discussed our community approach to patentable methods for generating metrics. We will ask Mike Dolan (GeorgLink, 19:42:18)
    10. we have a template for metrics https://github.com/chaoss/metrics/blob/master/activity-metrics/metric-template.md (GeorgLink, 19:42:35)
    11. https://github.com/chaoss/metrics/blob/master/activity-metrics-list.md (GeorgLink, 19:42:51)

  6. Code of Conduct (GeorgLink, 19:43:48)
    1. https://github.com/chaoss/governance/pull/3 (GeorgLink, 19:44:15)
    2. the code of conduct is ready to be voted on and has all the features we initially wanted. (GeorgLink, 19:47:15)
    3. to be voted on next week by the Governing Board (GeorgLink, 19:47:28)

  7. D&I Workgroup (GeorgLink, 19:47:37)
    1. https://github.com/chaoss/wg_diversity_inclusion (GeorgLink, 19:47:53)
    2. workgroup brings together the metrics and the software work to focus on one specific area (GeorgLink, 19:48:46)
    3. we'll send out a call to participate (GeorgLink, 19:52:01)

  8. Website updates and roadmap (GeorgLink, 19:52:21)
    1. roadmap: Have stable releases of metrics. Target is open source leadership summit (GeorgLink, 19:52:46)
    2. maybe leave Dependency metric off (GeorgLink, 19:54:31)
    3. use the release as a motivation to update the slide deck (GeorgLink, 19:55:11)
    4. whitepaper: goal is to have it ready before the Open source leadership summit (GeorgLink, 19:57:07)
    5. https://chaoss.community/about/ (GeorgLink, 19:57:51)
    6. website: maybe moving over to GitHub Pages (GeorgLink, 19:58:28)
    7. the link (https://chaoss.community/about/) shows a high-level roadmap (GeorgLink, 19:58:40)
    8. feedback welcome (GeorgLink, 19:59:00)


Meeting ended at 20:00:23 UTC (full logs).

Action items

  1. link metrics out to metric detail pages


People present (lines said)

  1. GeorgLink (52)
  2. rpaik (5)
  3. collabot` (3)
  4. BenLloyd (1)


Generated by MeetBot 0.1.4.