#cip: CIP IRC weekly meeting

Meeting started by gavinlai at 09:00:38 UTC (full logs).

Meeting summary

  1. rollcall (gavinlai, 09:00:50)
  2. AI review (gavinlai, 09:02:00)
    1. https://lists.cip-project.org/pipermail/cip-dev/2019-June/002506.html (gavinlai, 09:02:32)
    2. ACTION: Provide the script for CIP kernel config collection - bwh (gavinlai, 09:03:01)
    3. ACTION: List real time kernel questions to ask Daniel Wagner - szlin (gavinlai, 09:03:48)
    4. https://github.com/Linaro/test-definitions/tree/master/automated/linux/cyclictest (sangorrin, 09:08:00)

  3. Kernel maintenance updates (gavinlai, 09:10:32)
  4. Kernel testing (gavinlai, 09:16:08)
    1. lab-cip-mentor should be online today with a qemu machine. Mentor will then add the SIMATIC IPC227E and Cyclone V DE0-Nano-SoC boards. (patersonc, 09:16:38)
    2. We now have direct access to the CIP LAVA master (thank you Ryan). This should make maintenance a bit easier. (patersonc, 09:16:48)
    3. I've created a linux-cip-ci repository that creates build and test Docker containers that can be used to build the linux-cip Kernel using GitLab CI/CD. (patersonc, 09:16:58)
    4. https://gitlab.com/cip-playground/linux-cip-ci (patersonc, 09:17:07)
    5. https://docs.gitlab.com/ee/ci/multi_project_pipelines.html (sangorrin, 09:23:55)
    6. lab-cip-mentor is now up and running: https://lava.ciplatform.org/scheduler/worker/lab-cip-mentor (patersonc, 09:32:50)

  5. CIP Core (gavinlai, 09:34:09)
    1. ACTION: Work out a solution for LAVA master backups - patersonc (patersonc, 09:34:11)

  6. Software update (gavinlai, 09:37:44)
    1. We are working on the PoC demo for OSSJ2019 (sangorrin, 09:37:56)
    2. Raw image updates with Hawkbit on the server side working#info TODO: finish u-boot script, use librsync, rollback example (sangorrin, 09:38:03)
    3. Raw image updates with Hawkbit on the server side working (sangorrin, 09:38:13)
    4. TODO: finish u-boot script, use librsync, rollback example (sangorrin, 09:38:18)

  7. AOB (gavinlai, 09:39:46)


Meeting ended at 09:41:17 UTC (full logs).

Action items

  1. Provide the script for CIP kernel config collection - bwh
  2. List real time kernel questions to ask Daniel Wagner - szlin
  3. Work out a solution for LAVA master backups - patersonc


Action items, by person

  1. patersonc
    1. Work out a solution for LAVA master backups - patersonc
  2. UNASSIGNED
    1. Provide the script for CIP kernel config collection - bwh
    2. List real time kernel questions to ask Daniel Wagner - szlin


People present (lines said)

  1. patersonc (44)
  2. pave1 (34)
  3. gavinlai (32)
  4. sangorrin (32)
  5. kazu (5)
  6. brlogger (4)
  7. Yamamodo (3)
  8. fujita[m] (1)
  9. hiraku (1)


Generated by MeetBot 0.1.4.