#fdio-csit: csit weekly 161109
Meeting started by mackonstan at 15:00:37 UTC
(full logs).
Meeting summary
- : agenda bashing (mackonstan, 15:00:59)
 
- Inputs from FD.io projects - vpp (mackonstan, 15:03:39)
  - Dave Wallace (dwallacelf,
    15:04:19)
 
  - vhost test requirements discussion in email
    thread: "[vpp-dev] [csit-dev] vHost user test scenarios for
    CSIT" (mackonstan,
    15:04:55)
 
  - vhost tests today in perf testbed are with
    testpmd in ubuntu1604 guest, and in virl testbed with linux-bridge
    in ubuntu1604 guest. (mackonstan,
    15:07:00)
 
  - Tom Herbert (tfherbert,
    15:07:04)
 
  - integrating vpp make test into verify
    jobs (mackonstan,
    15:12:06)
 
  - https://gerrit.fd.io/r/#/c/3736
    - transitions the vpp-lite-* jobs to using 'make test' (which also
    builds vpp-lite) (mackonstan,
    15:12:22)
 
  - https://gerrit.fd.io/r/#/c/3737
    - renames vpp-lite-* jobs to vpp-test-* jobs (mackonstan,
    15:12:32)
 
  - need to test drive this properly (mackonstan,
    15:12:53)
 
 
- HoneyComb (mackonstan, 15:13:35)
  - no update (mackonstan,
    15:13:58)
 
  - waiting for CentOS  in VIRL testbed
    (mackonstan,
    15:14:10)
 
 
- Peter - few patches (mackonstan, 15:15:11)
  - https://gerrit.fd.io/r/#/c/3620/
    (mackonstan,
    15:15:18)
 
  - https://gerrit.fd.io/r/#/c/3743/
    (mackonstan,
    15:15:25)
 
 
- DPDK+VPP focused pre-integration testing (mackonstan, 15:16:01)
  - no update (mackonstan,
    15:16:40)
 
  - expecting commit from Anna, Waterman this
    week (mackonstan,
    15:16:52)
 
 
- TLDK (mackonstan, 15:16:57)
  - two blocker issues in Jira (mackonstan,
    15:17:06)
 
 
- FD.io CSIT operational status (mackonstan, 15:19:31)
  - would be good to split trend graphs and make
    them less crowded (mackonstan,
    15:22:38)
 
 
- Test environment infra topics (mackonstan, 15:24:49)
  - Adding Centos - func VIRL, perf phy testbeds,
    https://wiki.fd.io/view/CSIT/CSIT_Update_Testbed (mackonstan,
    15:25:35)
 
  - https://wiki.fd.io/view/CSIT/CSIT_Update_Testbed
    (mackonstan,
    15:26:19)
 
  - CSIT Testbeds - Adding CentOS - version to be
    decided based on vpp users with CentOS - currently mainly (only?)
    OPNFV/FDS, hence requirement for CentOS Linux release 7.2.1511
    (Core) (mackonstan,
    15:34:26)
 
  - ACTION: Maciek to
    clarify with OPNFV/FDS situation re vhost reconnect (mackonstan,
    15:36:56)
 
  - CSIT VIRL Testbed (mackonstan,
    15:37:43)
 
  - ACTION: tfherbert,
    dwallacelf - Create CentOS VIRL image (CSIT) (mackonstan,
    15:38:20)
 
  - dwallacelf to provide pointerst to CSIT TOI
    sessions (mackonstan,
    15:38:55)
 
  - ACTION: tfherbert,
    edwarnicke - Create new set of verify jobs with CentOS executor
    (CI-MAN) (mackonstan,
    15:40:52)
 
  - ACTION: tfherbert,
    pmikus - Create CentOS bootstrap script (CSIT) (mackonstan,
    15:42:47)
 
  - Verify CSIT Framework - then it's integration
    time … (mackonstan,
    15:43:56)
 
 
- Performance tests (mackonstan, 15:46:37)
 
- vhost-user - test requirements (mackonstan, 15:47:31)
  - Tom - still collecting feedback from
    ovscon (mackonstan,
    15:47:42)
 
  - Tom - proposal to see if it makes sense to
    integrate OPNFV/VSPERF tests into CSIT .. or the other way round …
    to be followed up (mackonstan,
    15:50:10)
 
 
- Performance tests (mackonstan, 15:51:27)
  - dpdk rls baseline - dpdk16.11rc1 tests
    started (mackonstan,
    15:53:16)
 
 
- - generating online docs - sphinx, RF (mackonstan, 15:53:51)
  - - Tibor to send sphinx auto-generated
    sample (mackonstan,
    15:57:52)
 
 
- Functional tests - vpp make test framework (mackonstan, 15:59:57)
  - user guide now available (mackonstan,
    16:00:11)
 
  - https://git.fd.io/cgit/vpp/tree/test/doc/index.rst
    (mackonstan,
    16:00:24)
 
  - integrating vpp make test into verify
    jobs (mackonstan,
    16:00:46)
 
  - ewarnicke - patches proposed to run them for
    ubuntu and centos (mackonstan,
    16:01:24)
 
  - irc://barjavel.freenode.net:6697/#link
    https://gerrit.fd.io/r/#/c/3736 - transitions the vpp-lite-*
    jobs to using 'make test' (which also builds vpp-lite) (mackonstan,
    16:01:33)
 
  - https://gerrit.fd.io/r/#/c/3736 - transitions the vpp-lite-*
    jobs to using 'make test' (which also builds vpp-lite) (mackonstan,
    16:01:57)
 
  - https://gerrit.fd.io/r/#/c/3737 - renames vpp-lite-* jobs to
    vpp-test-* jobs (mackonstan,
    16:02:10)
 
  - dwallacelf, mackonstan - create a new wiki page
    describing the e2e vpp test architecture, covering vpp make test,
    csit virl, cist perf physical testbed (mackonstan,
    16:03:44)
 
 
- Functional tests - csit virl (mackonstan, 16:04:05)
  - all action in jira (mackonstan,
    16:04:13)
 
 
- CSIT HC tests (mackonstan, 16:04:37)
  - no updates (mackonstan,
    16:05:03)
 
 
Meeting ended at 16:09:42 UTC
(full logs).
Action items
  - Maciek to clarify with OPNFV/FDS situation re vhost reconnect
 
  - tfherbert, dwallacelf - Create CentOS VIRL image (CSIT)
 
  - tfherbert, edwarnicke - Create new set of verify jobs with CentOS executor (CI-MAN)
 
  - tfherbert, pmikus - Create CentOS bootstrap script (CSIT)
 
Action items, by person
  -  dwallacelf 
    - tfherbert, dwallacelf - Create CentOS VIRL image (CSIT)
 
  
 
  -  tfherbert 
    - tfherbert, dwallacelf - Create CentOS VIRL image (CSIT)
 
    - tfherbert, edwarnicke - Create new set of verify jobs with CentOS executor (CI-MAN)
 
    - tfherbert, pmikus - Create CentOS bootstrap script (CSIT)
 
  
 
People present (lines said)
  - mackonstan (57)
 
  - collabot` (4)
 
  - tfherbert (1)
 
  - dwallacelf (1)
 
Generated by MeetBot 0.1.4.