#fdio-csit: csit weekly 161207

Meeting started by mackonstan at 15:01:25 UTC (full logs).

Meeting summary

    1. Jan Gelety (jgelety1, 15:01:27)
    2. Matej Klotton (mklotton1, 15:02:02)
    3. Peter Mikus (pmikus, 15:02:12)
    4. Billy McFall (BillyM, 15:02:50)
    5. Thomas Herbert (tfherbert, 15:02:58)
    6. Dave Wallace (dwallacelf, 15:03:55)
    7. Samuel Elias (selias, 15:04:13)

  1. Agenda bashing (mackonstan, 15:04:45)
  2. Inputs from FD.io projects (mackonstan, 15:06:04)
  3. VPP project (mackonstan, 15:06:35)
    1. vpp+dpdk1611 XoverIPv4 tests failing due to wrong checksum (mackonstan, 15:08:08)
    2. Peter will add link to related gerrit patch (mackonstan, 15:08:34)
    3. Patch on VPP is abandoned now: https://gerrit.fd.io/r/#/c/4115/1 (pmikus, 15:09:03)
    4. mackonstan - discussing CSIT code freeze in relation to VPP release on 18-Jan (mackonstan, 15:10:51)
    5. proposal for complete CSIT code freeze on 11-Jan-2017 (mackonstan, 15:11:06)

  4. HoneyComb (mackonstan, 15:11:57)
    1. selias - not much updates, updates to verify jenkins jobs, will announce on csit-dev (mackonstan, 15:12:31)
    2. selias - will consult with HC project devs to see what can be included in csit1701 report (mackonstan, 15:13:42)

  5. TLDK project (mackonstan, 15:14:24)
    1. pmikus - patches reviewed, but no activity observed on patches (mackonstan, 15:15:04)
    2. pmikus to followup with TLDK projectdevs (mackonstan, 15:16:10)
    3. edwarnicke - robots in place monitoring state of Jenkins slaves and size of the job queue (mackonstan, 15:17:30)
    4. edwarnicke - robots work, generate some false positive, but otherwise working incl. detecting zombie jbos (mackonstan, 15:18:14)

  6. Test environment infra topics (mackonstan, 15:22:07)
  7. vhost CPU jitter fixes - adding CFS settings (mackonstan, 15:22:41)
    1. pmikus - still working on it - issues with nested thin VM not including task-set commands (mackonstan, 15:25:02)
    2. pmikus - this is the last patch to make vhost tests work as expected and observed in the manual tests (mackonstan, 15:26:20)

  8. Adding Centos - func VIRL (mackonstan, 15:26:52)
  9. Progress to date - Thomas Herbert (mackonstan, 15:27:08)
    1. tfherbert - making good progress, base image created and stable, working on packages and qemu 2.3, infra working pretty well, hopefully will get to the nested image most likely tomorrow. (mackonstan, 15:31:27)

  10. Performance tests (mackonstan, 15:33:46)
    1. will keep in touch with dwallace and pmikus if I have some problems or questions about VIRL (tfherbert, 15:34:06)

  11. adding cryptodev tests - Sergio, Radu (mackonstan, 15:35:30)
    1. mackonstan - no progress reported (mackonstan, 15:35:59)
    2. ACTION: - mackonstan - to set up a TWS call to discuss the tech details about cryptodev tests onboarding onto CSIT (mackonstan, 15:36:23)
    3. ACTION: - mackonstan - poke for status on csit-dev thread: [csit-dev] AES-GCM support for ipsec tests (mackonstan, 15:36:42)

  12. DPDK perf baseline pre VPP integration (mackonstan, 15:37:01)
    1. pmikus - separate patch now available - DPDK-perf patches https://gerrit.fd.io/r/#/c/3961/ https://gerrit.fd.io/r/#/c/3960 (mackonstan, 15:38:03)
    2. https://gerrit.fd.io/r/#/c/3961/ https://gerrit.fd.io/r/#/c/3960/ (mackonstan, 15:38:12)
    3. https://gerrit.fd.io/r/#/c/3961/ (mackonstan, 15:38:49)

  13. trending baseline tests - one-core, multi-core (mackonstan, 15:39:19)
    1. tifrank - send email to csit-dev (mackonstan, 15:39:52)
    2. tifrank - requires further analysis as performance is not completely linear (mackonstan, 15:40:23)

  14. online documentation (mackonstan, 15:42:46)
    1. edwarnicke - follow the example of the doc auto-gen job here (mackonstan, 15:43:52)
    2. https://git.fd.io/ci-management/tree/jjb/vpp/vpp.yaml#n507 (mackonstan, 15:44:01)
    3. https://git.fd.io/ci-management/tree/jjb/vpp/include-raw-vpp-docs.sh#n22 <- example of where the groupId is set. Note, for csit, its going to need to be groupId io.fd.csit (edwarnicke, 15:44:03)
    4. ACTION: tifrank mackonstan - implement doc auto-gen for all csit tests as scripted by tifrank, edwarnicke to assist (mackonstan, 15:44:57)
    5. same should apply for vpp make test (mackonstan, 15:45:37)

  15. Functional tests - csit virl (mackonstan, 15:46:32)
    1. no updates (mackonstan, 15:47:07)
    2. https://git.fd.io/vpp/tree/Makefile#n330 <- make doxygen creates the docs for vpp (edwarnicke, 15:47:13)
    3. mackonstan - need to update jira (mackonstan, 15:48:51)
    4. ACTION: mackonstan Vladimir Holly - work on cleaning jira to reflect the targets for csit1701 and status (mackonstan, 15:50:06)

  16. Functional tests - vpp make test framework (mackonstan, 15:50:53)
    1. mackonstan - vpp make test are not verifying (mackonstan, 15:51:22)
    2. https://gerrit.fd.io/r/#/c/4109/ <- patch to turn on make test (edwarnicke, 15:51:51)
    3. edwarnicke - make test got broken by python api updates by Ole (mackonstan, 15:51:52)
    4. edwarnicke - now Ole fixed APIs (mackonstan, 15:52:05)
    5. edwarnicke - make test verify passed once, but need to do more tests (mackonstan, 15:52:34)

  17. Use case tests (mackonstan, 15:56:06)
  18. vhost use cases - see thread on csit-dev (mackonstan, 15:56:26)
    1. next FD.io TWS call today at 9am PST (mackonstan, 15:59:56)
    2. details on TWS page (mackonstan, 16:00:03)
    3. https://wiki.fd.io/view/TWS (mackonstan, 16:00:12)
    4. vhost user cases and test cases tracked on fd.io wiki here (mackonstan, 16:00:48)
    5. https://wiki.fd.io/view/CSIT/vhostuser_test_scenarios (mackonstan, 16:00:57)

  19. vpp-csit-verify job failures (mackonstan, 16:01:16)
    1. dbarach reported issue with CSIT functional test failure, not likely related to the patch (mackonstan, 16:01:35)
    2. https://lists.fd.io/pipermail/csit-dev/2016-December/001322.html (mackonstan, 16:02:05)
    3. issue with Map-E TC06 test failing (mackonstan, 16:02:41)
    4. pmikus - confirmed that he observed this test sporadically failing before (mackonstan, 16:02:54)
    5. mackonstan - RF error messages seem to be bogus: return STDERR WARNING: Failed to execute tcpdump. Check it is installed and in the PATH WARNING: No route found for IPv6 destination (mackonstan, 16:03:46)


Meeting ended at 16:03:53 UTC (full logs).

Action items

  1. - mackonstan - to set up a TWS call to discuss the tech details about cryptodev tests onboarding onto CSIT
  2. - mackonstan - poke for status on csit-dev thread: [csit-dev] AES-GCM support for ipsec tests
  3. tifrank mackonstan - implement doc auto-gen for all csit tests as scripted by tifrank, edwarnicke to assist
  4. mackonstan Vladimir Holly - work on cleaning jira to reflect the targets for csit1701 and status


Action items, by person

  1. edwarnicke
    1. tifrank mackonstan - implement doc auto-gen for all csit tests as scripted by tifrank, edwarnicke to assist
  2. mackonstan
    1. - mackonstan - to set up a TWS call to discuss the tech details about cryptodev tests onboarding onto CSIT
    2. - mackonstan - poke for status on csit-dev thread: [csit-dev] AES-GCM support for ipsec tests
    3. tifrank mackonstan - implement doc auto-gen for all csit tests as scripted by tifrank, edwarnicke to assist
    4. mackonstan Vladimir Holly - work on cleaning jira to reflect the targets for csit1701 and status


People present (lines said)

  1. mackonstan (66)
  2. edwarnicke (4)
  3. collabot` (3)
  4. pmikus (2)
  5. tfherbert (2)
  6. selias (1)
  7. jgelety1 (1)
  8. dwallacelf (1)
  9. BillyM (1)
  10. mklotton1 (1)


Generated by MeetBot 0.1.4.