#fdio-csit: 03-May FD.io CSIT Project Meeting

Meeting started by mackonstan1 at 13:59:52 UTC (full logs).

Meeting summary

    1. Jan Gelety (jgelety, 14:00:01)
    2. Samuel Elias (selias, 14:00:58)
    3. Peter Mikus (pmikus1, 14:01:12)

  1. Agenda bashing (mackonstan1, 14:06:24)
    1. Dave Wallace (dwallacelf, 14:06:29)

  2. Centos7 VIRL tests - resolution status, next steps (mackonstan1, 14:08:53)
    1. RA patch from Jan combined with tb3-virl upgrade - made all tests passing with Centos7 (mackonstan1, 14:09:34)
    2. all manually triggered tests for volume test of RA issue pass (mackonstan1, 14:11:35)
    3. but there are sporadic issues with simulation failing to start (mackonstan1, 14:12:03)
    4. https://jenkins.fd.io/job/csit-vpp-functional-master-ubuntu1604-virl/1091/robot/ (mackonstan1, 14:12:09)
    5. https://jenkins.fd.io/job/csit-vpp-functional-master-centos7-virl/1091/robot/ (mackonstan1, 14:12:17)
    6. ACTION: Jan and Tom to investigate further (mackonstan1, 14:12:42)
    7. tb3-virl is staying out of production (mackonstan1, 14:13:36)
    8. before tb1-virl, tb2-virl are upgrade, need to complete the documentation of tb3-virl upgrade (mackonstan1, 14:14:16)

  3. Inputs from LF and FD.io project (mackonstan1, 14:14:30)
    1. patches for nsh_sfc, tldk - commented, and progressing (mackonstan1, 14:19:34)

  4. FD.io CSIT operational status (mackonstan1, 14:19:37)
    1. perf tb1 testbed issue - Peter reporting sporadic low count pkt drops (always 2 pkts lost) in NDR tests on x520 - t/shooting in progress (mackonstan1, 14:21:06)
    2. centos7 VIRL tests - see earlier note re resolving sporadic failures. (mackonstan1, 14:24:16)
    3. remaining virl servers tb1, tb2 need to be upgraded before Centos7 tests are productized into vpp-csit-verify (mackonstan1, 14:26:15)

  5. csit1704 report (mackonstan1, 14:26:41)
    1. Sergio - interested in seeing throughput plots for IMIX, 1518B for IPSec suites, in addition for 64B frames. (mackonstan1, 14:39:09)
    2. should be addressed it as part of continuous report improvements and generation based on master data (mackonstan1, 14:43:11)
    3. csit1704 rls notes - pls note known issues (mackonstan1, 14:47:57)
    4. testpmd fortville performance issues - Sergio suggesting increasing descriptor ring size to 2k (mackonstan1, 14:52:23)

  6. csit rls1707 (mackonstan1, 14:55:29)
    1. https://wiki.fd.io/view/CSIT/csit1707_plan (mackonstan1, 14:56:10)

  7. CSIT jobs reorgs (mackonstan1, 15:00:17)
    1. https://wiki.fd.io/view/CSIT/csit-perf-jobs-reorg-proposal (mackonstan1, 15:00:30)
    2. functional tests - job reorg proposal worked by Jan (mackonstan1, 15:01:05)

  8. VPP SW cryptodev tests - status? (mackonstan1, 15:04:32)
    1. Sergio reported the VPP patch to enable this is done, but not merged due to not working with Ubuntu 14.04 (mackonstan1, 15:05:34)
    2. https://gerrit.fd.io/r/#/c/5847/ (mackonstan1, 15:22:27)
    3. Ubuntu14.04 dependency is nasm ver 2.10.09-1 - cryptodev needs at least ver 2.12.02 (nasm = Netwide Assembler). (mackonstan1, 15:31:31)


Meeting ended at 15:31:36 UTC (full logs).

Action items

  1. Jan and Tom to investigate further


People present (lines said)

  1. mackonstan1 (33)
  2. collabot (4)
  3. dwallacelf (1)
  4. jgelety (1)
  5. selias (1)
  6. pmikus1 (1)


Generated by MeetBot 0.1.4.