#fdio-csit: 21-Mar FD.io CSIT Project Meeting

Meeting started by mackonstan at 15:05:42 UTC (full logs).

Meeting summary

    1. Dave Wallace (dwallacelf, 15:05:59)
    2. Marek Gradzki (mgradzki, 15:06:08)
    3. Peter Mikus (pmikus1, 15:06:16)
    4. Tibor Frank (tifrank, 15:06:24)
    5. Jan Gelety (jgelety, 15:06:29)

  1. agenda bashing (mackonstan, 15:07:20)
  2. Inputs from LF and FD.io projects (mackonstan, 15:09:01)
    1. VPP - no updates, API deadline today (mackonstan, 15:09:13)
    2. https://gerrit.fd.io/r/#/c/9257/ (mgradzki, 15:10:05)
    3. HC - test breakage, moving HC out of vpp test tree with its own init.robot file fixed the issue (mackonstan, 15:10:28)

  3. Operational status (mackonstan, 15:14:07)
    1. Peter - more MRR tests introduced - 64B MRR added to daily trending (mackonstan, 15:14:56)
    2. currently 184 perf tests in mrr trending daily (mackonstan, 15:17:25)
    3. taking 7h20m already.. lots of time taken by vhost test due to qemu build (mackonstan, 15:18:06)
    4. when we move to ubuntu 18.04, no qemu recompiling be required as vring size is configurable (mackonstan, 15:19:53)
    5. consider dropping vring 256 from trending daily (mackonstan, 15:20:34)
    6. MRR  = pumping a link rate, maximum recieve rate. (mackonstan, 15:24:33)

  4. rls1801 performance regressions (mackonstan, 15:25:06)
    1. https://lists.fd.io/g/csit-dev/message/2505 (mackonstan, 15:25:14)
    2. re CSIT-928 IPSec scale with HW QAT crypto-dev (mackonstan, 15:26:27)
    3. patch for performance improvement (mackonstan, 15:26:43)
    4. https://gerrit.fd.io/r/#/c/11082/ (mackonstan, 15:26:51)
    5. ACTION: Ray to follow up with Radu on this (mackonstan, 15:28:13)
    6. deep dive discussion about CSIT-925, CSIT-926 (mackonstan, 15:45:01)
    7. ACTION: Ray - should have a separate tech brkout call to discuss the dpdk1711 related regressions (mackonstan, 15:47:51)
    8. ACTION: Maciek - schedule a call next week (mackonstan, 15:48:06)
    9. ACTION: Maciek - post the detailed regression bisecting results (mackonstan, 15:51:27)
    10. Ray - will check with dpdk folks if any regressions or substantial code changes could have affected x520 niantic performance (mackonstan, 15:52:31)

  5. DMM extensions discussions - Adarsh (mackonstan, 15:57:19)
    1. Adarsh provided DMM project overview (mackonstan, 15:58:15)
    2. https://wiki.fd.io/view/Project_Proposals/DMM (mackonstan, 15:58:29)
    3. ACTION: Adarsh - publish gerrit patches for initial DMM tests and announce on csit-dev list (mackonstan, 16:00:29)

  6. VPP performance trending and analysis (mackonstan, 16:01:08)
    1. Tibor - PT jobs running, Perf Analysis is merged (mackonstan, 16:01:25)
    2. PA job should start running as of today (mackonstan, 16:01:49)
    3. PA artefacts posted in nexus, accessible via docs.fd.io (mackonstan, 16:02:08)
    4. https://docs.fd.io/csit/master/trending (mackonstan, 16:03:25)

  7. FD.io CSIT lab infra updates (mackonstan, 16:09:48)
    1. Maciek - proposed high-level design for FD.io CSIT lab extensions last week - pls review/approve (mackonstan, 16:13:30)
    2. would like to vote on it on csit-dev list, once all comments come in and are addressed (mackonstan, 16:13:58)
    3. https://lists.fd.io/g/csit-dev/message/2499 (mackonstan, 16:14:02)
    4. Brian - would like to discuss TG setup for ARM testbeds (mackonstan, 16:15:40)
    5. ACTION: Brian - meet with Maciek at ONS in LA (mackonstan, 16:15:53)


Meeting ended at 16:16:30 UTC (full logs).

Action items

  1. Ray to follow up with Radu on this
  2. Ray - should have a separate tech brkout call to discuss the dpdk1711 related regressions
  3. Maciek - schedule a call next week
  4. Maciek - post the detailed regression bisecting results
  5. Adarsh - publish gerrit patches for initial DMM tests and announce on csit-dev list
  6. Brian - meet with Maciek at ONS in LA


People present (lines said)

  1. mackonstan (40)
  2. collabot` (4)
  3. mgradzki (2)
  4. mortderire (1)
  5. dwallacelf (1)
  6. jgelety (1)
  7. pmikus1 (1)
  8. tifrank (1)


Generated by MeetBot 0.1.4.