#fdio-csit: FD.io CSIT TWS - VPP_Device design

Meeting started by pmikus1 at 13:32:44 UTC (full logs).

Meeting summary

    1. Peter Mikus (pmikus1, 13:33:07)
    2. Vratko Polak (vrpolak, 13:34:11)
    3. Jan Gelety (jgelety, 13:37:21)
    4. Ed update: Not easy to do SSH connection (interactive SSH) (pmikus1, 13:39:29)
    5. Agreed that best would be having the scripts in CSIT repo. (pmikus1, 14:08:17)
    6. ACTION: Ed to commit all the scripts so far to gerrit so we can see more clearly the whole mechanics and make better picture of how it work (pmikus1, 14:09:30)
    7. Resources wise, it is possible to run 100+ containers with blank (void) functionality. It is not clear what is CSIT footprint and how much containers will work reliably with accepted response time once CSIT will run there. (pmikus1, 14:13:10)
    8. ACTION: Ed to start implementing and running CSIT-shim containers on 1-node SKX TB to provide playground by next week (pmikus1, 14:13:55)
    9. Containers templates should be also post to gerrit for reviews and comments. We can laverage the work done on jenkins slave container hosted on https://hub.docker.com/u/snergster/ (pmikus1, 14:15:48)
    10. Single template for both TG/DUT is most probably the way to go from manageability point of view. (pmikus1, 14:16:44)
    11. ACTION: Peter to review https://hub.docker.com/u/snergster/ jenkins containers if suitable for use for CSIT or CSIT can be based on these. (pmikus1, 14:17:39)
    12. TB to use: s1-t11-sut1/s2-t12-sut1 currently stock ubuntu-18.04 installed there with single user (pmikus1, 14:23:16)
    13. So far virtio expose was not tested in containers. (Exposing /sys/bus/pci/) need to agree on who will code the arbiter and reservation mechanics. (pmikus1, 14:25:20)


Meeting ended at 14:25:31 UTC (full logs).

Action items

  1. Ed to commit all the scripts so far to gerrit so we can see more clearly the whole mechanics and make better picture of how it work
  2. Ed to start implementing and running CSIT-shim containers on 1-node SKX TB to provide playground by next week
  3. Peter to review https://hub.docker.com/u/snergster/ jenkins containers if suitable for use for CSIT or CSIT can be based on these.


People present (lines said)

  1. pmikus1 (15)
  2. collabot (4)
  3. vrpolak (1)
  4. jgelety (1)


Generated by MeetBot 0.1.4.