#fdio-csit: FD.io CSIT project meeting

Meeting started by mackonstan at 14:01:51 UTC (full logs).

Meeting summary

    1. Jan Gelety (jgelety, 14:01:53)
    2. Tibor Frank (tifrank, 14:01:54)
    3. Peter Mikus (pmikus, 14:01:55)
    4. Vratko Polak (vrpolak, 14:02:06)

  1. Agenda bashing (mackonstan, 14:04:43)
    1. Dave Wallace (dwallacelf, 14:05:02)

  2. FD.io CSIT lab infrastructure (mackonstan, 14:05:17)
    1. skip, no Mohammed (mackonstan, 14:05:25)

  3. VPP project update (mackonstan, 14:06:17)
    1. DaveW - plan to release vpp-19.01.2 waiting for one more outstanding vpp patch (mackonstan, 14:07:39)
    2. DaveW - waiting for CSIT to confirm testbed resource for 19.01.2 testing (mackonstan, 14:08:13)
    3. DaveW - 19.04.1 gated by IPsec verification tests, currently scheduled for 19.01.2 + 14d (mackonstan, 14:08:50)
    4. DaveW - 19.08 tag applied, rls plan hasn't started yet, AndrewY and DaveW leading it (mackonstan, 14:10:59)

  4. HC update (mackonstan, 14:11:16)
    1. Michal - HC stable/1904 released, test results in the report (mackonstan, 14:11:37)
    2. Michal - HC doesn't need to retest for VPP maintenance releases as long as APIs are not changing (mackonstan, 14:12:07)
    3. Michal - have some outstanding jvpp issues. (mackonstan, 14:12:59)
    4. Michal - HC tests running in VIRL, some ported to VPP_Device platform (mackonstan, 14:13:23)

  5. TSC (mackonstan, 14:14:11)
    1. Modernizing CI/CD infrastructure working team recommendations available (mackonstan, 14:17:06)
    2. Infrastructure Working Group Summary Report available (mackonstan, 14:17:13)
    3. https://wiki.lfnetworking.org/display/LN/Infrastructure+Working+Group+Summary+Report (mackonstan, 14:17:20)

  6. Operational status (mackonstan, 14:18:14)
    1. Jenkins down yesterday - number of CSIT-1904 jobs killed - few 100s hrs of testing lost (mackonstan, 14:19:25)
    2. Tom Herbert (tfherbert, 14:24:55)
    3. Maciek - sharing screen with Jan's CSIT-1904 test job execution tracking xls (mackonstan, 14:29:26)
    4. need to cap max job duration to better manage the risk of Jenkins/infra outages (mackonstan, 14:30:07)
    5. and in the meantime seriously pursue alternative CI strategy to the existing one, even if it's quite a stretch to expect any migration is successfully completed during one release cycle (mackonstan, 14:33:40)
    6. Peter - recommend to consider async mode for Jenkins job, that do not require non-stop presence of jenkins over the job lifecycle (mackonstan, 14:39:31)

  7. Release CSIT-1904 (mackonstan, 14:41:36)
    1. latest version week20 of report published (mackonstan, 14:48:12)
    2. https://docs.fd.io/csit/rls1904/report/ (mackonstan, 14:48:23)
    3. data missing: 3n-hsw full test runs, some nfv density tests, tcp wrk tests - will be added in next report ver(s) (mackonstan, 14:49:14)
    4. data missing: vpp operational data "show runtime" due to CSIT bug, will be added in the next full run for VPP-19.04.1 (mackonstan, 14:49:52)
    5. TomFH - still working on Centos VPP_Device tests, should be ready for 19.04.1 (mackonstan, 14:51:51)
    6. ACTION: JanG, Maciek, DaveW - work out and propose test coverage for vpp-19.01.2 based on available resources (mackonstan, 14:59:16)


Meeting ended at 15:01:01 UTC (full logs).

Action items

  1. JanG, Maciek, DaveW - work out and propose test coverage for vpp-19.01.2 based on available resources


People present (lines said)

  1. mackonstan (32)
  2. collabot (3)
  3. pmikus (1)
  4. vrpolak (1)
  5. jgelety (1)
  6. dwallacelf (1)
  7. tfherbert (1)
  8. tifrank (1)


Generated by MeetBot 0.1.4.