#fdio-csit: FD.io CSIT project meeting

Meeting started by mackonstan at 15:00:07 UTC (full logs).

Meeting summary

    1. Jan Gelety (jgelety, 15:00:13)

  1. Agenda bashing (mackonstan, 15:00:26)
    1. Vratko Polak. (vrpolak, 15:00:30)
    2. Tibor Frank (tifrank, 15:01:00)
    3. Maciek: would like to add two topics: i) jenkins configuration transparency; ii) physical DCs (YUL-1, YUL-2) move and consolidation into one physical DC location as proposed by Vexxhost (deadline 15-March-2021). (mackonstan, 15:01:48)
    4. Dave Wallace (dwallacelf, 15:02:30)

  2. Inputs from projects - VPP (mackonstan, 15:08:03)
    1. F0 milestone classified as a no-op, will be removed from the next release (mackonstan, 15:09:26)

  3. Inputs from projects - TSC (mackonstan, 15:10:02)
  4. Releases - CSIT-2101 (mackonstan, 15:11:24)
    1. https://wiki.fd.io/view/CSIT/csit2101_plan (mackonstan, 15:11:39)
    2. Vratko, working on improving / enhancing nat44ed astf pps throughput tests (mackonstan, 15:14:05)
    3. Jan, re geneve perf tests, should be able to correct uncovered issues by RC1 date (mackonstan, 15:14:54)
    4. Juraj, re Arm items, not expecting any delays, all phy lab infra tasks got completed (mackonstan, 15:16:18)

  5. Physical Infrastructure (mackonstan, 15:16:35)
    1. Juraj, mgmt switch will be procured so no more issues expected (mackonstan, 15:17:03)
    2. Maciek, physical DCs (YUL-1, YUL-2) move and consolidation into one physical DC location as proposed by Vexxhost (deadline 15-March-2021). (mackonstan, 15:23:08)
    3. Andrew, if we have a visibility and influence on the move schedule, then we should aim for hitless move (mackonstan, 15:24:06)
    4. Dave, agrees with Andrew, collocation stuff is good, chance to complete the cleanup (mackonstan, 15:26:33)

  6. Virtual Infrastructure, CI/CD (mackonstan, 15:27:57)
    1. Vanessa, since Monday, every morning, Jenkins UI becomes unresponsive, getting 500 errors (mackonstan, 15:28:31)
    2. Vanessa, keep comparing FD.io instance vs. ODAP and XXXX instances that have 4x number of jobs, and keep increasing scale params in FD.io instanc (mackonstan, 15:29:08)
    3. Vanessa, yesterday upgraded monitoring plugins, and everything was running good yday (mackonstan, 15:29:29)
    4. Vanessa, unfortunately still the issue was observed this morning (mackonstan, 15:29:47)
    5. Vanessa, side issue discovered was a buggy gerrit trigger plugin, upgraded to by mistake, now reverted to previous version (mackonstan, 15:30:23)
    6. Vanessa, one observation, RF plugin is killing the CPU util and eating lots of memory … could this be a cause of Jenkins UI issues (mackonstan, 15:31:32)
    7. Bug tracking Jenkins system: https://jira.linuxfoundation.org/browse/RELENG-3325 (mackonstan, 15:32:29)
    8. https://jira.linuxfoundation.org/browse/RELENG-3325 (mackonstan, 15:32:49)
    9. Vanessa Q: can the RF plugin be disabled temporarily? (mackonstan, 15:37:06)
    10. 6+1 committers/contributors answered: yes, nobody against, so let's go ahead. (mackonstan, 15:37:45)
    11. Vanessa, going ahead then. (mackonstan, 15:38:21)
    12. Vanessa, see the following error in logs, in thousands "error javax.imageio.IIOException: I/O error writing PNG file!" (mackonstan, 15:40:59)
    13. Maciek's new topic: jenkins configuration transparency (mackonstan, 15:41:54)
    14. Vanessa, Jenkins moving to jcasc configuration, see this patch for details (mackonstan, 15:45:28)
    15. https://gerrit.fd.io/r/c/ci-management/+/30100 (mackonstan, 15:45:31)
    16. Vanessa, all startup and runtime configuration is covered, minus credentials (mackonstan, 15:46:56)
    17. Vanessa, some global and cloud variables are also excluded (mackonstan, 15:47:15)
    18. https://git.fd.io/ci-management/tree/jenkins-config (mackonstan, 15:47:31)
    19. Dave, patch 30100 went thru initial reviews by Dave, Vratko, Peter, but more reviews pending (mackonstan, 15:48:55)
    20. Migration from Nexus to S3 (mackonstan, 15:49:25)
    21. Vanessa, working on logs (mackonstan, 15:49:33)
    22. Vanessa, ETA in 2021 (mackonstan, 15:49:41)
    23. Vanessa, will also be moving to different Vexxhost VM flavour for Jenkins executors (mackonstan, 15:51:30)
    24. Juraj, VPP device jobs, arm thunderx2 jobs are still unstable, due to intermittent AVF issue - firmware or i40e driver (mackonstan, 15:52:23)
    25. see email thread (mackonstan, 15:54:05)
    26. Juraj, in the meantime see if a w/a can be implemented (mackonstan, 15:55:07)
    27. Vratko Update on PAPI socket connection (dwallacelf, 15:58:56)
    28. Vratko added GPL license checker for CSIT tox job (dwallacelf, 15:59:17)
    29. No issues to be discussed (dwallacelf, 16:00:04)
    30. Already discussed in release topics (dwallacelf, 16:00:50)
    31. ACTION: Andrew to investigate process for deactivating fdio-yul users (dwallacelf, 16:04:02)


Meeting ended at 16:05:20 UTC (full logs).

Action items

  1. Andrew to investigate process for deactivating fdio-yul users


People present (lines said)

  1. mackonstan (44)
  2. dwallacelf (11)
  3. collab-meetbot (4)
  4. jgelety (1)
  5. vrpolak (1)
  6. tifrank (1)


Generated by MeetBot 0.1.4.