#fdio-csit: FD.io CSIT Weekly Meeting

Meeting started by dwallacelf at 14:05:37 UTC (full logs).

Meeting summary

    1. Vratko Polak. (vrpolak, 14:05:41)
    2. Jan Gelety (jgelety, 14:05:42)
    3. Dave Wallace (dwallacelf, 14:05:43)
    4. Tibor Frank (tifrank, 14:05:51)
    5. Peter Mikus (pmikus, 14:06:14)

  1. Agenda bashing (dwallacelf, 14:06:22)
  2. Inputs from projects (dwallacelf, 14:08:25)
    1. VPP: nothing new to report (dwallacelf, 14:09:12)
    2. VSAP: nothing to report (dwallacelf, 14:09:29)
    3. TSC: scapy waiting for permission to re-license from Nidhi, other code was rewritten (dwallacelf, 14:10:41)
    4. CNCF: nothing to report (dwallacelf, 14:11:14)

  3. Releases (dwallacelf, 14:11:31)
    1. CSIT-21.01 Plan TBD (dwallacelf, 14:11:43)
    2. CSIT-20.09: Report 20.09.43 added today, added Nat44 tests (dwallacelf, 14:13:10)
    3. CSIT-20.09: RCA's no regressions bigger than 5%, but looking at regression of L2patch (some regression, but also period of time test was broken) (dwallacelf, 14:13:59)
    4. Bi-secting under way (dwallacelf, 14:14:13)
    5. RCA: Nat44 deterministic investigation under way. (dwallacelf, 14:15:30)

  4. Physical Infrastructure (dwallacelf, 14:16:01)
    1. Performance testing: (dwallacelf, 14:16:26)
    2. Performance testing: (dwallacelf, 14:16:47)
    3. Functional driver testing: nothing new to report (dwallacelf, 14:17:11)
    4. New ARM testbeds: thunder-x2 servers are in nomad, but working on adding CI jobs running on them. (dwallacelf, 14:18:07)
    5. New AMD testbeds: issues with stability and test runs (~40% test failures). Work to continue via email thread. (dwallacelf, 14:19:23)
    6. FD.io lab extension in 2021: New Icelake servers delayed ~3 months. Plan to be worked on in preparation for March/April delivery. (dwallacelf, 14:20:52)

  5. Virtual Infrastructure, CI/CD (dwallacelf, 14:21:10)
    1. LFN FD.io CI/CD systems: Another Jenkins restart required this Monday. No RCA provided to date. (dwallacelf, 14:21:47)
    2. No RCA for jenkins memory issue provided by LFIT to date. (dwallacelf, 14:26:28)
    3. Gerrit ci-management change 28022 is ready for final review/merge. Docker images are being built and put into production using the scripts from 28022. (dwallacelf, 14:27:21)
    4. Centos-8 docker x86_64 images are being worked on next as well as aarch64 images (centos-7 & 8). (dwallacelf, 14:28:33)
    5. Generation of csit docker images will be worked on after 28022 is merged. Currently delayed a bit due to additional workload of developers. (dwallacelf, 14:30:11)
    6. It is time to create CSIT-20.09 LTS branch and start trending jobs for 20.09 LTS branch (dwallacelf, 14:31:39)
    7. ACTION: jgelety work on patch to create trending jobs and create branch. (dwallacelf, 14:33:13)

  6. Environment, Framework (dwallacelf, 14:34:06)
    1. Linux updates: Plan for updating CSIT to Ubuntu-20.04 is to complete docker image generation for CSIT executors in 21.01 and start conversion to Ubuntu20.04 in Feb 2021 (dwallacelf, 14:39:02)
    2. Juraj reported vppdevice aarch64 nodes updated to latest kernel caused a VPP crash. Will work on a process for kernel updates and qualification of kernel updates. (dwallacelf, 14:42:00)
    3. Would like to see if the crash can be reproduced on x86_64. (dwallacelf, 14:42:32)
    4. ACTION: DaveW to start email thread to address definition of CSIT process to test VPP with the latest linux kernel, cpu firmware, device drivers, &/or nic firmware. (dwallacelf, 14:50:31)
    5. ACTION: Juraj to send email to vpp-dev@lists.fd.io to bring VPP community attention to the aarch64 crash and ask for help verifying if this happens on x86_64. (dwallacelf, 14:52:15)
    6. TRex updates: currently no plans to update trex unless a bug is encountered (dwallacelf, 14:53:07)
    7. Vratko proposes to addition of Trex and python library updates to the kernel (et al) discussion. (dwallacelf, 14:54:31)
    8. VPP API changes' tracking: 1 pending change for nat44, csit changes ready & being tested (dwallacelf, 14:55:24)

  7. Performance Tests (dwallacelf, 14:58:42)
    1. Nothing to discuss (dwallacelf, 14:58:59)

  8. Functional Tests (dwallacelf, 14:59:10)
    1. Nothing to discuss (dwallacelf, 14:59:23)


Meeting ended at 15:00:18 UTC (full logs).

Action items

  1. jgelety work on patch to create trending jobs and create branch.
  2. DaveW to start email thread to address definition of CSIT process to test VPP with the latest linux kernel, cpu firmware, device drivers, &/or nic firmware.
  3. Juraj to send email to vpp-dev@lists.fd.io to bring VPP community attention to the aarch64 crash and ask for help verifying if this happens on x86_64.


Action items, by person

  1. jgelety
    1. jgelety work on patch to create trending jobs and create branch.
  2. UNASSIGNED
    1. DaveW to start email thread to address definition of CSIT process to test VPP with the latest linux kernel, cpu firmware, device drivers, &/or nic firmware.
    2. Juraj to send email to vpp-dev@lists.fd.io to bring VPP community attention to the aarch64 crash and ask for help verifying if this happens on x86_64.


People present (lines said)

  1. dwallacelf (46)
  2. collab-meetbot (7)
  3. vrpolak (1)
  4. jgelety (1)
  5. tifrank (1)
  6. pmikus (1)


Generated by MeetBot 0.1.4.