#fdio-meeting: FD.io CSIT Project Meeting

Meeting started by mackonstan at 13:59:10 UTC (full logs).

Meeting summary

    1. mackonstan (mackonstan, 13:59:15)
    2. Tibor Frank (tifrank, 13:59:30)
    3. Vratko Polak. (vrpolak, 13:59:45)
    4. Juraj Linkeš (jlinkes, 14:02:03)

  1. Agenda bashing (mackonstan, 14:02:54)
  2. Inputs from projects (mackonstan, 14:03:45)
  3. Inputs from projects - VPP (mackonstan, 14:03:51)
    1. Andrew, vpp v22.06 rls artefacts in packagecloud - should be there in a matter of 3-4 hrs (mackonstan, 14:04:49)

  4. Inputs from projects - TSC (mackonstan, 14:05:04)
    1. Maciek - getting quotations for MLX 100 GbE NICs from Vexxhost (mackonstan, 14:06:24)

  5. Releases CSIT-2206 (mackonstan, 14:07:34)
    1. Tibor, rc2 testing is done, all data published in the master report. retesting of previous rls 22.02 in the current csit environment also done. (mackonstan, 14:08:24)
    2. Fan Zhang - sorry for being late. (fan_zhang, 14:08:43)
    3. Tibor, added all new icx testbeds, they've been tested with rc2 images, quite a few issues, all fixed (mackonstan, 14:08:48)
    4. Welcome Fan! (mackonstan, 14:08:59)
    5. Tibor, added comparison tables with throughput normalized to 2 GhZ frequency (mackonstan, 14:10:41)
    6. Tibor, the new comparison tables are available for preview here (mackonstan, 14:14:05)
    7. https://s3-docs.fd.io/csit/master/report/_static/vpp/norm-compare-testbeds-3n-skx-3n-icx-1c-pdr.txt (mackonstan, 14:14:37)
    8. the original comparison tables are still there (mackonstan, 14:15:21)
    9. https://s3-docs.fd.io/csit/master/report/_static/vpp/performance-compare-testbeds-3n-skx-3n-icx-1c-pdr.txt (mackonstan, 14:15:43)
    10. Vratko proposed improvement, add new column to existing tables, call it normalized diff and be done with it (mackonstan, 14:23:28)
    11. no need to calling out any normalizaation freq as it cancels out (mackonstan, 14:23:50)
    12. AGREED: go ahead with Vratko's proposal, Tibor will push a new patch (mackonstan, 14:24:15)
    13. Dave Wallace (dwallacelf, 14:24:32)
    14. Tibor, rls artefacts testing starting tomorrow (mackonstan, 14:25:15)
    15. Maciek, Viliam, working on the documenting the known issues into the report (mackonstan, 14:25:47)
    16. Vratko, looking at regressions, one at 2% but noisy so unclear if a real one (mackonstan, 14:26:41)
    17. Vratko, some 3n-dnv fluctuations due to wrong links speed negotiations (mackonstan, 14:27:44)
    18. Vratko, 100 GbE multi-core speedup results are looking good, close to linear :) (mackonstan, 14:28:13)
    19. Vratko, Peter, 2n-zn2 multi-core speedup graphs are not looking too good (mackonstan, 14:30:46)
    20. https://s3-docs.fd.io/csit/master/report/vpp_performance_tests/throughput_speedup_multi_core/ip4-2n-zn2-cx556a.html (mackonstan, 14:30:57)
    21. Peter, will double-check the setup and the environment and report back in next couple of days (mackonstan, 14:33:22)
    22. Peter, vpp telemetry collection, fixed now, and showing the correct as expected values for all telemetry, show run, show int, show perfmon (mackonstan, 14:34:17)
    23. Maciek, now that we are collecting correct telemetry, would like us to consider, after the release, to add them to the CSTI UTI model and provide User Interface to see and compare them (mackonstan, 14:36:52)
    24. Maciek, Peter, SNR SUTs re still down, due to inability to use IPMI for console access. (mackonstan, 14:37:56)
    25. Peter, working on adding SNR testbeds to ansible playbooks, to bring them up and verify them, possibly may be able to executed dry runs, and possibly have data for the rls (mackonstan, 14:38:48)
    26. Peter, as we don't have access to BIOS, the test results may not be reliable (mackonstan, 14:39:54)
    27. Tibor, re CVL 100 GbE flow-based tests, got added to job - the patch is still not merged (mackonstan, 14:41:54)
    28. 36491: job_specs: add IPsec perf tests and GTPU perf tests to regression | https://gerrit.fd.io/r/c/csit/+/36491 (mackonstan, 14:41:58)
    29. one outstanding comment (mackonstan, 14:42:06)
    30. Fan, will take care of this comment (mackonstan, 14:42:18)
    31. Tibor, another patch for job_specs affecting rls testing (mackonstan, 14:42:35)
    32. 36544: job-spec: Reduce number of iterative tests for 2n-clx | https://gerrit.fd.io/r/c/csit/+/36544 (mackonstan, 14:43:01)
    33. Maciek, will review it after this call (mackonstan, 14:43:11)
    34. Maciek, Tibor, re report, main work is adding 3n-alt testbed (Juraj, Maciek), normalized comparisons (Tibor), rls_notes, methodology (astf, autogen) (mackonstan, 14:46:45)

  6. Physical Infrastructure (mackonstan, 14:47:34)
  7. Virtual Infrastructure, CI/CD (mackonstan, 14:47:53)
    1. Dave, re 1.5 weeks ago Jenkins in Shutdown Mode, it was put into this state by a human operator pre/during upgrade; LF-IT / Vanessa confirmed that the SRE / NOC team got re-confirmed to never do this (mackonstan, 14:49:52)
    2. without prior notice warning (mackonstan, 14:50:04)
    3. Dave, hoststack and quick tests, got all fixed by VPP patches - Dave and Florin - got merged into the stable branch yesterday (mackonstan, 14:50:51)
    4. Dave, Maciek, action to add those tests to trending (mackonstan, 14:52:39)
    5. Dave, note to Peter, need a single landing page for docs.fd.io, currently the index does not exist for top-level directories, for both docs.fd.io and s3-docs.fd.io (mackonstan, 14:55:58)

  8. Trending (mackonstan, 14:57:26)
    1. Maciek, see latest email from Viliam in csit-report mailer - no new failures (mackonstan, 14:57:46)
    2. Vratko, some issues listed in meeting agenda have been fixed. (mackonstan, 14:58:02)


Meeting ended at 14:59:19 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. mackonstan (52)
  2. collab-meetbot` (3)
  3. tifrank (1)
  4. vrpolak (1)
  5. jlinkes (1)
  6. fan_zhang (1)
  7. dwallacelf (1)


Generated by MeetBot 0.1.4.