#fdio-meeting: FD.io TSC

Meeting started by edwarnicke at 16:00:38 UTC (full logs).

Meeting summary

  1. rollcall (edwarnicke, 16:00:41)
    1. edwarnicke (edwarnicke, 16:00:43)
    2. Joel Halpern (JoelHalpern, 16:00:46)
    3. mackonstan (mackonstan, 16:02:34)
    4. valderrv (valderrv, 16:04:29)
    5. Ray Kinsella (mortderire, 16:06:38)
    6. Dave Wallace (dwallacelf, 16:07:48)
    7. AGREED: ask for four week nomination and then four week election procedure to be initiated by Trishan (edwarnicke, 16:13:05)
    8. mackonstan (mackonstan, 15:02:49)
    9. Fan Zhang (fan_zhang, 15:04:13)
    10. Juraj Linkeš (jlinkes, 15:04:38)
    11. Dave Wallace (dwallacelf, 15:04:53)
    12. Tibor Frank (tifrank, 15:05:15)

  2. Agenda bashing (mackonstan, 15:06:38)
    1. Maciek: added "VPP RC1 hot patch(es) items" topic (mackonstan, 15:06:55)
    2. Maciek: TRex and 100GbE NICs for performance testing, ICE/CVL, MLX (mackonstan, 15:07:41)
    3. reply to pim - we will be discussing it later in this call that is currently live, details at the link below (mackonstan, 15:10:39)
    4. https://wiki.fd.io/view/CSIT/Meeting (mackonstan, 15:10:47)

  3. VPP updates (mackonstan, 15:11:05)
    1. Andrew, rc1 tag to be applied today (mackonstan, 15:11:49)
    2. Andrew, no showstopper for rc1 identified (mackonstan, 15:12:05)

  4. TSC update (mackonstan, 15:14:10)
    1. TSC chair election is imminent (mackonstan, 15:14:20)
    2. Dave, Ed will be sending email (mackonstan, 15:14:26)
    3. Maciek, Dave, in last TSC meeting, all agreed to have at least 4 weeks nomination, followed by max 2 weeks voting (mackonstan, 15:15:12)
    4. mackonstan reply to pim - meeting is open to everyone. But zoom requires attendees to authenticate to avoid abuse/hijacking. Standard free zoom logins work, I am just using one (google login) (mackonstan, 15:16:57)

  5. New or (to be) refactored tests (mackonstan, 15:17:19)
    1. Fan, E810 flow "offload" tests, device: plan to update tests with new dpdk offload flags - discussing it with the team … (mackonstan, 15:18:30)
    2. mackonstan reply to pim: if you are still struggling attending this meeting, then i'm happy to assist you later to make sure you get it sorted (mackonstan, 15:20:11)
    3. Maciek: Scale tests, Address perf test jobs with excessive execution time - weekly ndrpdr - 2n-skx, 2n-clx over 24hrs - work with Tibor to reduce the qty / combination of tests to bring it within 24hrs window (mackonstan, 15:21:51)

  6. VPP RC1 hot patch(es) items (mackonstan, 15:22:33)
    1. VPP MTU patches: latest one 34928: vnet: distinguish between max_frame_size and MTU | https://gerrit.fd.io/r/c/vpp/+/34928 (mackonstan, 15:25:17)
    2. above patch is merged, made before rc1 deadline (mackonstan, 15:25:59)
    3. Maciek, Andrew, need to follow up on how CSIT tests are setting the MTUs, and specifically the error handling by VPP (and CSIT) when wrong/bad MTU value is set (mackonstan, 15:29:07)
    4. Fan, Maciek, re DPDK v21.11 vhost tests passing, Fan: unclear what got fixed for this bug only … will follow up with code review with Damjan (mackonstan, 15:30:19)

  7. Releases CSIT-2202 (mackonstan, 15:31:04)
    1. Fan, late comment, re VPP RC1 patches, some patches didn't verify yet, QAT support for chacha/poly (mackonstan, 15:32:45)
    2. Andrew, to follow up on the vpp list / calls (mackonstan, 15:32:57)
    3. Maciek - any hot item work to complete before CSIT RC2 (mackonstan, 15:33:08)
    4. Peter - need to upgrade FVL and CVL DPDK drivers to be compatible with DPDK v21.11, luckily no firmware upgrade (mackonstan, 15:34:32)

  8. Physical Infrastructure (mackonstan, 15:35:20)
    1. Peter - 2nd 1n-skx vpp-device testbed is back in operation (mackonstan, 15:36:44)
    2. Peter - after driver changes in the past, hitting issue in 2n-dnv and 3n-dnv testbed, seems to be related to mtu and with ethernet autonegotiation (mackonstan, 15:37:56)
    3. Maciek, new topic - TRex and 100GbE NICs for performance testing, ICE/CVL, MLX (mackonstan, 15:38:26)
    4. Maciek, Pim, Peter - discussed options - cx5 for clx, cx5ex or cx6 for icx (cx6 if better than cx5ex justified), future consider cx7 for spr (mackonstan, 15:49:25)
    5. Peter, Perf - Initial 5 Intel ICX servers install and commissioning status - mgmt switch should be coming online next week (mackonstan, 15:51:22)
    6. Juraj, re Perf - Ampere Altra server(s) delivery ETA, Arm still waiting for hardware, current ETA Feb 2022 (mackonstan, 15:53:17)
    7. Juraj, re Ampere Altra servers delivery ETA , should be shipping from Austin shortly (mackonstan, 15:53:53)

  9. Virtual Infrastructure, CI/CD (mackonstan, 15:54:01)
    1. Dave, re FD.io storage migration to S3, away from Nexus - list is still WIP, but comleting migration tracking for after 22.02 rls (mackonstan, 15:55:18)

  10. Trending (mackonstan, 15:57:12)
    1. quick review of csit-report failures digest email (mackonstan, 15:57:32)
    2. https://lists.fd.io/g/csit-report/topic/csit_breakages_for_week_03/88482678?p=,,,20,0,0,0::recentpostdate/sticky,,,20,2,0,88482678,previd=1642493791780721342,nextid=1642186267432562827&previd=1642493791780721342&nextid=1642186267432562827 (mackonstan, 15:58:25)

  11. Fd.io Events (mackonstan, 15:58:46)
    1. Maciek, had a really good FD.io CSIT talk in LFN dev&testing forum last Thu, "Performance Benchmarking, Anomaly Detection, Results Tracking" (mackonstan, 16:03:37)
    2. Links to: i) session wiki, ii) slides, iii) zoom mp3 recording, listed below (in that order) (mackonstan, 16:04:20)
    3. https://wiki.lfnetworking.org/pages/viewpage.action?pageId=65538382 (mackonstan, 16:04:33)
    4. https://wiki.lfnetworking.org/download/attachments/65538382/lfn-ddts21-fdio-csit.pdf?version=1&modificationDate=1642187365000&api=v2 (mackonstan, 16:04:48)
    5. https://wiki.lfnetworking.org/download/attachments/65538382/lfn-ddts21-fdio-csit.mp4?version=1&modificationDate=1642175623000&api=v2 (mackonstan, 16:05:01)


Meeting ended at 16:05:04 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. mackonstan (51)
  2. collab-meetbot (14)
  3. collab-meetbot` (11)
  4. edwarnicke (9)
  5. dwallacelf (2)
  6. pim (2)
  7. JoelHalpern (1)
  8. valderrv (1)
  9. mortderire (1)
  10. fan_zhang (1)
  11. jlinkes (1)
  12. tifrank (1)
  13. vrpolak (0)
  14. Fan (0)
  15. Zhang (0)
  16. Dave (0)
  17. Wallace (0)
  18. Tibor (0)
  19. Frank (0)
  20. Juraj (0)
  21. Linkeš (0)


Generated by MeetBot 0.1.4.