#fdio-meeting: GoVPP Community Meeting

Meeting started by dwallacelf at 13:37:29 UTC (full logs).

Meeting summary

  1. Roll Call / Agenda Bashing (dwallacelf, 13:37:59)
    1. Attendees: Ondrej, Nathan, Dave, Arthur, Vlado (dwallacelf, 13:38:22)

  2. Action Items (dwallacelf, 13:48:38)
    1. there is a pull request that is required for the upcoming GoVPP release (dwallacelf, 13:55:27)
    2. https://gerrit.fd.io/r/c/vpp/+/39205 (dwallacelf, 13:55:33)
    3. ACTION: Ondrej to ensure the correct solution is merged prior then generate the release (dwallacelf, 13:56:13)
    4. Dave notified VPP community about api clean up patches, some were merged, then after a week or so Dave merged the rest (dwallacelf, 13:56:53)

  3. Technical Discussion (dwallacelf, 13:57:24)
    1. Discussion on adding GoVPP CLI api verification into VPP CI & adding comments to gerrit with the issues discovered. (dwallacelf, 13:58:02)
    2. No new Issues (dwallacelf, 13:58:58)
    3. Ondrej is working on Issue#82 'Move generated binapi' (dwallacelf, 13:59:55)
    4. Discussion of PR#116 'Trace refactored' (dwallacelf, 14:03:58)
    5. Vlado to work on refactoring the PR based on discussion (dwallacelf, 14:08:46)

  4. Inputs From Projects (dwallacelf, 14:10:51)
    1. VPP Release 23.06 is complete (dwallacelf, 14:11:17)
    2. Discussion of issue with compatibility check for api where new api's were causing failures with compatibility of previous releases due to the api not existing (dwallacelf, 14:13:34)
    3. Ondrej implemented a quick workaround, but will update logic to differentiate between non-existing api messages and changed crc for api message (dwallacelf, 14:14:25)
    4. nothing from NSM -- seems mostly active with integration testing (dwallacelf, 14:17:19)
    5. Calico/VPP v3.26.0 release is complete (dwallacelf, 14:18:14)


Meeting ended at 14:24:02 UTC (full logs).

Action items

  1. Ondrej to ensure the correct solution is merged prior then generate the release


People present (lines said)

  1. dwallacelf (21)
  2. collab-meetbot` (3)


Generated by MeetBot 0.1.4.